split developer and cdnoperations out of welcome.html
[plstackapi.git] / opencloud.spec
index 16f1b23..e877ff4 100644 (file)
@@ -1,7 +1,7 @@
 Summary: OpenCloud core services
 Name: opencloud
 Version: 1.0.10
-Release: 2
+Release: 4
 License: GPL+
 Group: Development/Tools
 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
@@ -59,6 +59,11 @@ if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
    gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
 fi
 
+if [ "$1" == 2 ] ; then
+    echo "UPGRADE - saving current state"
+    /opt/planetstack/scripts/opencloud dumpdata
+fi
+
 %install
 rm -rf %{buildroot}
 mkdir -p  %{buildroot}
@@ -67,19 +72,15 @@ install -d %{buildroot}/opt/planetstack
 # in builddir
 cp -rp ./planetstack %{buildroot}/opt/.
 
-find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g"  > %{_tmppath}/tmp-filelist
+find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
+cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
 
 %clean
 rm -rf %{buildroot}
 
 %files -f %{_tmppath}/tmp-filelist
 %defattr(-,root,root,-)
-
-%pre
-if [ "$1" == 2 ] ; then
-    echo "UPGRADE - saving current state"
-    /opt/planetstack/scripts/opencloud dumpdata
-fi
+%config /opt/planetstack/plstackapi_config
 
 %post
 if [ "$1" == 1 ] ; then