Requires: python-lxml
[plcapi.git] / plcapi.spec
index 2d3f5f4..2022047 100644 (file)
@@ -1,6 +1,6 @@
 %define name plcapi
-%define version 5.2
-%define taglevel 6
+%define version 5.3
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -27,6 +27,8 @@ Requires: postgresql >= 8.2, postgresql-server >= 8.2
 Requires: postgresql-python
 Requires: python-psycopg2
 Requires: python-pycurl
+# used in GPG.py as a replacement to PyXML's Canonicalize
+Requires: python-lxml
 Requires: httpd
 # requirement to mod_python or mod_wsgi: deferred to myplc
 Requires: mod_ssl
@@ -54,7 +56,9 @@ Conflicts: MyPLC <= 4.3
 # BuildRequires: postgresql-devel
 
 # Standard xmlrpc.so that ships with PHP does not marshal NULL
-BuildRequires: php-devel PyXML python-simplejson
+# for building the wsdl interface we used to require PyXML
+# but this has gone with f20 so turning this off for now
+BuildRequires: php-devel python-simplejson
 Obsoletes: php-xmlrpc
 Provides: php-xmlrpc
 
@@ -146,6 +150,28 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
+- create accessor 'hrn' for site as well
+- create accessors 'sfa_created' for site/slice/person
+- AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
+- UpdatePerson() updates Person HRN according to updated email.
+- UpdateSite() updates Site HRN according to updated login_base.
+- Fix AddPersonToSite().
+- GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
+- RefreshPeer() manages Site*Person and Person*Role relationships.
+
+* Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
+- provide a slicename_to_hrn function
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
+- add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
+
+* Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
+- fix for wsgi-based deployments, each thread has its own api()
+
+* Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
+- also cleanup omf-slicemgr initscript
+
 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
 - tear down omf-related aspects as this is no longer needed with omfv6