turn off wsdl generation for now as this requires PyXML that was dropped in f19
[plcapi.git] / plcapi.spec
index 3424620..3d63efc 100644 (file)
@@ -1,6 +1,6 @@
 %define name plcapi
-%define version 5.1
-%define taglevel 6
+%define version 5.3
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -54,7 +54,9 @@ Conflicts: MyPLC <= 4.3
 # BuildRequires: postgresql-devel
 
 # Standard xmlrpc.so that ships with PHP does not marshal NULL
-BuildRequires: php-devel PyXML python-simplejson
+# for building the wsdl interface we used to require PyXML
+# but this has gone with f20 so turning this off for now
+BuildRequires: php-devel python-simplejson
 Obsoletes: php-xmlrpc
 Provides: php-xmlrpc
 
@@ -81,7 +83,8 @@ through Apache mod_python.
 # 
 # Build __init__.py metafiles and PHP API. 
 %{__make} %{?_smp_mflags}
-%{__make} -C wsdl
+## turning off wsdl generation for now
+#%{__make} -C wsdl
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -108,16 +111,19 @@ mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 
-# Install wsdl
-echo "* Installing wsdl"
-install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
+## turning off wsdl generation for now
+## Install wsdl
+#echo "* Installing wsdl"
+#install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
 
-# Install omf_slicemgr.py
-install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
-install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
-mkdir -p $RPM_BUILD_ROOT/var/log/omf
+## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
+## Install omf_slicemgr.py
+#install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
+#install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
+#mkdir -p $RPM_BUILD_ROOT/var/log/omf
 
 # Install ratelimit log
+mkdir -p $RPM_BUILD_ROOT/var/log
 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
 
@@ -129,7 +135,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root,-)
 %dir %{_datadir}/plc_api
-%dir /var/log/omf/
+#%dir /var/log/omf/
 %{_datadir}/plc_api/*
 %{_bindir}/plcsh
 %{php_extension_dir}/xmlrpc.so
@@ -137,13 +143,61 @@ rm -rf $RPM_BUILD_ROOT
 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
 /etc/plc.d
 /etc/planetlab/db-config.d
-/var/www/html/wsdl/plcapi.wsdl
-/usr/bin/omf_slicemgr.py*
-/usr/bin/reset_xmpp_pubsub_nodes.py*
+## turning off wsdl generation for now
+#/var/www/html/wsdl/plcapi.wsdl
+#/usr/bin/omf_slicemgr.py*
+#/usr/bin/reset_xmpp_pubsub_nodes.py*
 /var/log/plc_api_ratelimit.log
 
 
 %changelog
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
+- create accessor 'hrn' for site as well
+- create accessors 'sfa_created' for site/slice/person
+- AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
+- UpdatePerson() updates Person HRN according to updated email.
+- UpdateSite() updates Site HRN according to updated login_base.
+- Fix AddPersonToSite().
+- GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
+- RefreshPeer() manages Site*Person and Person*Role relationships.
+
+* Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
+- provide a slicename_to_hrn function
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
+- add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
+
+* Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
+- fix for wsgi-based deployments, each thread has its own api()
+
+* Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
+- also cleanup omf-slicemgr initscript
+
+* Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
+- tear down omf-related aspects as this is no longer needed with omfv6
+
+* Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
+- also expose 'expires' in ResolveSlices
+
+* Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
+- drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
+
+* Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
+- enable netconfig aspects if PLC_NETCONFIG_ENABLED
+
+* Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
+- use SFA code for computing hrn's when available
+
+* Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
+- new slice tag 'interface' for configuring a virtual interface
+- new builtin 030-interface_tags
+- new node accessor and tag 'virt' for mixing lxc & vs nodes
+- also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
+- moved ModPypthon and plc.wsgi in the apache/ subdir
+- renamed PLCAPI.spec into plcapi.spec
+- removed old and unused tag 'type' on slices(!) - original intention seemed like virt
+- support for php-5.4
+
 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
 - implement PLC_VSYS_DEFAULTS in AddSlice
 
@@ -291,8 +345,8 @@ rm -rf $RPM_BUILD_ROOT
 - use hrn in pubsub groups
 
 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
-- Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
-- OMF fixes
+- Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
+- OMF fixes
 
 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
 - automatically set vsys tag for omf controlled slices