noreal change, just nicer requires
[plcapi.git] / plcapi.spec
index 3d63efc..714943e 100644 (file)
@@ -21,15 +21,17 @@ URL: %{SCMURL}
 Provides: PLCAPI
 Obsoletes: PLCAPI
 
+# requirement to mod_python or mod_wsgi: deferred to myplc
+Requires: httpd mod_ssl
+Requires: Django
+Requires: postgresql >= 8.2, postgresql-server >= 8.2
 # We use set everywhere
 Requires: python >= 2.4
-Requires: postgresql >= 8.2, postgresql-server >= 8.2
 Requires: postgresql-python
 Requires: python-psycopg2
 Requires: python-pycurl
-Requires: httpd
-# requirement to mod_python or mod_wsgi: deferred to myplc
-Requires: mod_ssl
+# used in GPG.py as a replacement to PyXML's Canonicalize
+Requires: python-lxml
 Requires: SOAPpy
 Requires: python-simplejson
 # for the RebootNodeWithPCU method
@@ -41,9 +43,7 @@ Requires: python-twisted-web
 # ldap
 Requires: python-ldap
 # for memcache
-Requires: python-memcached
-Requires: memcached
-Requires: Django
+Requires: memcached python-memcached
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/api
 Conflicts: MyPLC <= 4.3
@@ -83,8 +83,7 @@ through Apache mod_python.
 # 
 # Build __init__.py metafiles and PHP API. 
 %{__make} %{?_smp_mflags}
-## turning off wsdl generation for now
-#%{__make} -C wsdl
+%{__make} -C wsdl
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -111,10 +110,9 @@ mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 
-## turning off wsdl generation for now
-## Install wsdl
-#echo "* Installing wsdl"
-#install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
+# Install wsdl
+echo "* Installing wsdl"
+install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
 
 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
 ## Install omf_slicemgr.py
@@ -143,8 +141,7 @@ rm -rf $RPM_BUILD_ROOT
 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
 /etc/plc.d
 /etc/planetlab/db-config.d
-## turning off wsdl generation for now
-#/var/www/html/wsdl/plcapi.wsdl
+/var/www/html/wsdl/plcapi.wsdl
 #/usr/bin/omf_slicemgr.py*
 #/usr/bin/reset_xmpp_pubsub_nodes.py*
 /var/log/plc_api_ratelimit.log