leasefilter: use f-strings instead of format()
[plcapi.git] / plcapi.spec
index ac4016e..a3e1aea 100644 (file)
@@ -1,5 +1,5 @@
 %define name plcapi
-%define version 5.4
+%define version 7.1
 %define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -19,13 +19,13 @@ Distribution: PlanetLab %{plrelease}
 URL: %{SCMURL}
 
 Provides: PLCAPI
-Obsoletes: PLCAPI
+Obsoletes: PLCAPI
 
 # requirement to mod_python or mod_wsgi: deferred to myplc
 Requires: httpd mod_ssl
 # f29 does not come with an rpm for that; use pip instead
 # Requires: Django
-Requires: postgresql >= 8.2, postgresql-server >= 8.2
+Requires: postgresql, postgresql-server
 # We use set everywhere
 Requires: python3
 Requires: python3-postgresql
@@ -34,14 +34,12 @@ Requires: python3-pycurl
 # used in GPG.py as a replacement to PyXML's Canonicalize
 Requires: python3-lxml
 # for the RebootNodeWithPCU method
-Requires: pcucontrol >= 1.0-6
-# for OMF integration - xxx aspects needs porting too
-Requires: pyaspects >= 0.4
+#Requires: pcucontrol >= 1.0-6
 # for memcache
 Requires: memcached python3-memcached
 
 ####################
-# obsolete
+# phpxmlrpc
 ####################
 # standard xmlrpc.so that ships with PHP does not marshal NULL
 # prior to May 2017 we used to ship our own brew of xmlrpc but
@@ -99,12 +97,6 @@ mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 
-## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
-## Install omf_slicemgr.py
-#install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
-#install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
-#mkdir -p $RPM_BUILD_ROOT/var/log/omf
-
 # Create log file for plcapi
 mkdir -p $RPM_BUILD_ROOT/var/log
 touch $RPM_BUILD_ROOT/var/log/plcapi.log
@@ -135,6 +127,27 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Tue Feb 06 2024 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-0
+- allow GetLeases 'clip' and 'alive' parameters to use lists
+  as tuples cannot be marshalled by the xmlrpc layer
+- packaging modified for f37
+- support for pgsql14/f37
+- use a configurable email as the From: when sending emails
+
+* Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-0
+- for php8 in f35:
+- * the phpxmlrpc layer has been upgraded to recent 4.6.1 that is php8-ready
+- * classes to use __construct() to define a constructor
+- * curl_setopt with verifyhost being 1 is no longer allowed
+- also other older changes related to pgsql 12
+
+* Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.0-0
+- based on python3, runs on f27 and f29
+- removed dependency to aspects, and so to rate limits
+- remove dependency to the Django rpm that is no longer available in f29
+- remove deps to python-twisted
+- use systemctl rather than service to manage postgresql
+
 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs