list available nodes and users even if there is none added to the slice.
[plewww.git] / plewww.spec
index 7cc1133..ab14682 100644 (file)
@@ -4,7 +4,7 @@
 
 # what the myplc rpm requires
 %define name plewww
-%define version 5.0
+%define version 4.3
 %define taglevel 0
 
 # no need to mention pldistro as this module differs in both distros
@@ -30,7 +30,7 @@ URL: http://svn.one-lab.org/svn/new_plc_www/
 #Requires: httpd >= 2.0
 Requires: php >= 5.0
 Requires: postgresql >= 8.0
-Requires: PLCAPI >= 5.0
+Requires: PLCAPI >= 4.3
 Requires: drupal = 4.7
 Requires: plewww-plekit
 
@@ -43,13 +43,16 @@ Provides: PLCWWW
 AutoReqProv: no
 
 %package plekit
-Summary: Utilities for building the plewww pages, for the benefit of other PL-related UI components.
+Summary: Utilities used by the plewww pages
 Group: Applications/Systems
 
 %description
 The plewww package is made of the web pages that run on top of the 
 PLCAPI component to provide the Web Interface to MyPLC users.
 
+%description plekit
+This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
+
 %prep
 %setup -q
 
@@ -66,11 +69,12 @@ rm -rf $RPM_BUILD_ROOT
 
 echo "* PLEWWW: Installing web pages"
 mkdir -p $RPM_BUILD_ROOT/var/www/html
-# let's be conservative and exclude codebase files, though there should not be any
-rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
+# exclude codebase just in case
+rsync -a --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
 
-echo "* PLEWWW: Installing config for httpd"
-install -D -m 644 httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/plcwww.conf
+echo "* PLEWWW: Installing conf files for httpd"
+mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
+install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
 
 %post
 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
@@ -112,7 +116,7 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab
 /var/www/html/googlemap
 /var/www/html/drupal-hacks
-/etc/httpd/conf.d/plcwww.conf
+/etc/httpd/conf.d
 
 %files plekit
 /var/www/html/plekit