plekittable knows how to turn off sort-on-load, and the admin users pages do
[plewww.git] / plewww.spec
index cc3a8cd..bda2388 100644 (file)
@@ -4,8 +4,8 @@
 
 # what the myplc rpm requires
 %define name plewww
-%define version 5.0
-%define taglevel 0
+%define version 4.3
+%define taglevel 15
 
 # no need to mention pldistro as this module differs in both distros
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -30,7 +30,7 @@ URL: http://svn.one-lab.org/svn/new_plc_www/
 #Requires: httpd >= 2.0
 Requires: php >= 5.0
 Requires: postgresql >= 8.0
-Requires: PLCAPI >= 5.0
+Requires: PLCAPI >= 4.3
 Requires: drupal = 4.7
 Requires: plewww-plekit
 
@@ -64,16 +64,18 @@ echo "All files just need to be installed as is from the codebase"
 rm -rf $RPM_BUILD_ROOT
 
 #
-# plcwww
+# plewww
+# xxx : uninstall should undo this
 #
 
 echo "* PLEWWW: Installing web pages"
 mkdir -p $RPM_BUILD_ROOT/var/www/html
-# let's be conservative and exclude codebase files, though there should not be any
-rsync -a --exclude \*.spec --exclude .svn --exclude CVS --exclude Makefile --exclude httpd.conf ./ $RPM_BUILD_ROOT/var/www/html/
+# exclude codebase just in case
+rsync -a --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
 
-echo "* PLEWWW: Installing config for httpd"
-install -D -m 644 httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/plewww.conf
+echo "* PLEWWW: Installing conf files for httpd"
+mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
+install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
 
 %post
 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
@@ -115,12 +117,64 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab
 /var/www/html/googlemap
 /var/www/html/drupal-hacks
-/etc/httpd/conf.d/plewww.conf
+/etc/httpd/conf.d
 
 %files plekit
 /var/www/html/plekit
 
 %changelog
+* Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
+- plekittable knows how to turn off sort-on-load, and the admin users pages do
+- + various cosmetic fixes
+
+* Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
+- a few minor improvements pushed on PLE
+
+* Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
+- fix for sites that were displayed as not public
+- improvements to the python interface to sortable tables for monitor
+
+* Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
+- various improvements
+
+* Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
+- sliver page now correctly shows sliver tags
+- support for download-node-usb-partition and various other improvements
+
+* Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
+- a few tweaks and typos fixed on PLE
+
+* Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
+- slice_add & node_download dialogs use plekit
+- slice_add can add people in the slice
+- various improvements after rollout on PLE
+
+* Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
+- cosmetic fixes to be in 4.3-rc2
+- also a first (unpackaged) draft of the plekit table in python
+
+* Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
+- search in tables more robust
+
+* Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
+- performance improvements
+
+* Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
+- detect expired session and redirect to the login page
+
+* Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
+- improve browser health - was using too many cycles
+
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
+- more consistency between views, and cosmetic changes
+
+* Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
+- area for managing slice tags
+
+* Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
+- first checkpoint tag for PLEWWW
+- mostly functionally complete, probably a lot of tweaks still needed
+
 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
 - everyone is welcome to add nodes