Setting tag PLEWWW-4.3-44
[plewww.git] / plewww.spec
index 8df35b0..e278345 100644 (file)
@@ -5,7 +5,7 @@
 # what the myplc rpm requires
 %define name plewww
 %define version 4.3
-%define taglevel 37
+%define taglevel 44
 
 # no need to mention pldistro as this module differs in both distros
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -103,10 +103,12 @@ fi
 popd
 # hack the welcome page for MyPLC
 pushd /var/www/html/modules
-if [ ! -f node.module.drupal ] ; then
-    cp node.module node.module.drupal
-    [ -f /var/www/html/drupal-hacks/node.module ] && cp -f /var/www/html/drupal-hacks/node.module /var/www/html/modules/node.module
-fi
+for module in user node; do
+    # backup only once
+    [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
+    # always update so a change in our file can make through
+    cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
+done
 popd
 
 %clean
@@ -124,6 +126,36 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/plekit
 
 %changelog
+* Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
+- Use readfile() function to reduce the memory footprint
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
+- removed all deprecated functions for PHP-5.3 on fedora 12
+
+* Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
+- * exclude DNS from subnet checking
+- * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
+- * allow longer abbreviated names
+- * don't let empty strings kill the server (postgresql and apache)
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
+- disable drupal user registration (hard: patching the user module)
+
+* Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
+- * show error messages for update interface
+- * 'Add Node' is admin only
+- * add site selector for 'Add Node'
+
+* Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
+- new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
+- this affects the settings of ifname and alias that were formerly set unconditionally
+- review the interface-checking javascript code
+- changed the interface to plekitform, method is now optional and part of an options hash
+
+* Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
+- can't use php objects for showing node status, this is too slow
+- fix interface add page
+
 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
 - consistency in the way nodes status is displayed in the node and slice areas
 - extra tags columns show up on the nodes page as well, tweaked in the process