Make the plnet module a script that uses plcsh to get info for a node.
[pyplnet.git] / pyplnet.spec
index fbecd49..8b0965d 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name pyplnet
 %define version 4.2
-%define taglevel 1
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -41,12 +41,15 @@ python setup.py build
 %install
 rm -rf $RPM_BUILD_ROOT
 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
+chmod +x %{python_sitearch}/plnet.py
+ln -s %{python_sitearch}/plnet.py %{_bindir}/plnet
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root,-)
+%{_bindir}/plnet
 %{python_sitearch}/*
 
 %changelog