Now compiles cleanly on f17 and f12
[rvm-ruby.git] / rpm / rvm-ruby.spec
index 10dc1d0..efbdd18 100644 (file)
@@ -11,13 +11,13 @@ Release: 1.20.9
 License: ASL 2.0
 URL: http://rvm.beginrescueend.com/
 Group: Applications/System
-
+#Source: %{name}-%{version}.tar
 #BuildArch: noarch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 
 BuildRequires: bash curl git
 BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
-BuildRequires: sed grep tar gzip bzip2 make file
+BuildRequires: sed grep tar gzip bzip2 make file ruby
 
 Requires(pre): shadow-utils
 # For rvm
@@ -40,9 +40,6 @@ ensure correct permissions for the shared RVM content.
 RVM is activated for all logins by default. To disable remove
 %{_sysconfdir}/profile.d/rvm.sh and source rvm from each users shell.
 
-%prep
-%setup -q
-
 %build
 
 %install
@@ -53,6 +50,7 @@ for i in `env | grep ^rvm_ | cut -d"=" -f1`; do
   unset $i;
 done
 
+(
 # Install everything into one directory
 export rvm_ignore_rvmrc=1 \
   rvm_user_install_flag=0 \
@@ -60,9 +58,9 @@ export rvm_ignore_rvmrc=1 \
   rvm_bin_path="%{buildroot}%{_bindir}" \
   rvm_man_path="%{buildroot}%{_mandir}" \
   HOME=%{buildroot}
-
 \curl -L https://get.rvm.io | bash -s stable --version %{release}
   #./install
+)
 
 # So members of the rvm group can write to it
 find %{buildroot}%{rvm_dir} -exec chmod ug+w {} \;
@@ -134,6 +132,8 @@ export br=%{buildroot}
 
 # Remove sources
 rm -rf $br/usr/lib/rvm/src
+# Remove logs
+rm -rf $br/usr/lib/rvm/log/*
 
 # Strip binaries
 #find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep 'not stripped' |cut -f1 -d: |xargs -r strip
@@ -152,6 +152,17 @@ done
 find $br -type f \( -name \*.log -o -name \*.la \) -print0 |xargs -0 -r sed -i "s,$br,,g"
 find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': .* text' |cut -f1 -d: |xargs -r sed -i "s,$br,,g"
 
+# some Ruby code to replace library paths in binary files
+# should work with Ruby 1.9 and 1.8
+! read -d '' fixpath <<"EOF"
+if String.method_defined?(:encode)
+  $_.encode!("UTF-8", "UTF-8", :invalid => :replace)
+end
+$_.gsub!(/#{ENV["br"]}(.*?)\0/) do |s|
+  $1 + ( "\0" * ENV["br"].size ) + "\0"
+end
+EOF
+
 # Strip object files in ar archives from bad path strings
 for f in `find $br -type f -name \*.a`; do
   td=`mktemp -d`
@@ -163,11 +174,7 @@ for f in `find $br -type f -name \*.a`; do
     grep "$br" $g || continue
 
     # Replace the bad path with the good one, padded by nulls
-    ruby -p -i -e '
-      $_.encode!("UTF-8", "UTF-8", :invalid => :replace).gsub!(/#{ENV["br"]}(.*?)\0/) do |s|
-      $1 + ( "\0" * ENV["br"].size ) + "\0"
-      end
-    ' $g
+    ruby -p -i -e "$fixpath" $g
   done
 
   ar r $f *
@@ -180,11 +187,7 @@ for f in `find $br/usr/lib/rvm/rubies -type f -print0 |xargs -0 file --no-derefe
   grep "$br" $f || continue
 
   # Replace the bad path with the good one, padded by nulls
-  ruby -p -i -e '
-    $_.encode!("UTF-8", "UTF-8", :invalid => :replace).gsub!(/#{ENV["br"]}(.*?)\0/) do |s|
-    $1 + ( "\0" * ENV["br"].size ) + "\0"
-    end
-  ' $f
+  ruby -p -i -e "$fixpath" $f
 done
 
 # Fix symlinks with bad path
@@ -193,6 +196,7 @@ for f in `find $br -type l |grep "$br"`; do
 done
 
 find $br -maxdepth 1 -name '.*' -exec rm -rf {} \;
+rm $br/usr/share/man/man1/rvm.1.gz
 
 %clean
 rm -rf %{buildroot}