In BuildKernel() update from
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
index 5a57955..70aa3df 100644 (file)
@@ -17,10 +17,10 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # that the kernel isn't the stock distribution kernel, for example by
 # adding some text to the end of the version number.
 #
-%define sublevel 17
+%define sublevel 20
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}
-%define release 1.2187_FC5.0%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release 1.2949.fc6.vs2.2.0.1.0%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define signmodules 0
 %define make_target bzImage
 
@@ -294,7 +294,7 @@ BuildKernel() {
     # create a clean copy in BUILD/ (for backward compatibility with
     # other RPMs that bootstrap off of the kernel build)
     cd $RPM_BUILD_DIR
-    rm -rf linux-%{kversion}$Flavour
+    rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
     cp -rl kernel-%{kversion}/vanilla linux-%{_target_cpu}-%{kversion}$Flavour
     cd linux-%{_target_cpu}-%{kversion}$Flavour