accidentally imported -- do not belong on repository
[linux-2.6.git] / scripts / kernel-2.6-planetlab.spec
index 2ddbaca..ca2935d 100644 (file)
@@ -18,23 +18,18 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # that the kernel isn't the stock distribution kernel, for example by
 # adding some text to the end of the version number.
 #
-%define sublevel 7
+%define sublevel 10
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}
 %define rhbsys  %([ -r /etc/beehive-root ] && echo  || echo .`whoami`)
-%define release 1.planetlab%{?date:.%{date}}
+%define release 1.14_FC2.1.planetlab%{?date:.%{date}}
 %define signmodules 0
 
 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
 
-# groups of related archs
-%define all_x86 i586 i686
-
 # Override generic defaults with per-arch defaults 
 
-%ifarch %{all_x86}
 %define image_install_path boot
-%endif
 
 #
 # Three sets of minimum package version requirements in the form of Conflicts:
@@ -67,6 +62,11 @@ Summary: The Linux kernel (the core of the Linux operating system)
 #
 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
 
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab 3.0
+URL: http://cvs.planet-lab.org/cvs/linux-2.6
+
 Name: kernel
 Group: System Environment/Kernel
 License: GPLv2
@@ -88,11 +88,11 @@ AutoReqProv: no
 # List the packages used during the kernel build
 #
 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
-BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, kernel-utils >= 2.4-12.1.139
-# temporary req since modutils changed output format 
-#BuildPreReq: modutils >= 2.4.26-14
+BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg
+#BuildPreReq: kernel-utils >= 1:2.4-12.1.142
 BuildRequires: gcc >= 2.96-98, binutils >= 2.12, redhat-rpm-config
 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
+BuildArchitectures: i686
 
 
 
@@ -178,6 +178,19 @@ Group: System Environment/Kernel
 %description uml
 This package includes a user mode version of the Linux kernel.
 
+%package vserver
+Summary: A placeholder RPM that provides kernel and kernel-drm
+
+Group: System Environment/Kernel
+Provides: kernel = %{version}
+Provides: kernel-drm = 4.3.0
+
+%description vserver
+VServers do not require and cannot use kernels, but some RPMs have
+implicit or explicit dependencies on the "kernel" package
+(e.g. tcpdump). This package installs no files but provides the
+necessary dependencies to make rpm and yum happy.
+
 %prep
 
 %setup -n linux-%{kversion}
@@ -201,13 +214,13 @@ BuildKernel() {
 
     # Pick the right config file for the kernel we're building
     if [ -n "$1" ] ; then
-       Config=kernel-%{kversion}-i686-$1-planetlab.config
+       Config=kernel-%{kversion}-%{_target_cpu}-$1-planetlab.config
     else
-       Config=kernel-%{kversion}-i686-planetlab.config
+       Config=kernel-%{kversion}-%{_target_cpu}-planetlab.config
     fi
 
     KernelVer=%{version}-%{release}$1
-    echo BUILDING A KERNEL FOR $1 i686...
+    echo BUILDING A KERNEL FOR $1 %{_target_cpu}...
 
     # make sure EXTRAVERSION says what we want it to say
     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}$1/" Makefile
@@ -245,6 +258,7 @@ BuildKernel() {
         grep "__crc_$i\$" System.map >> $RPM_BUILD_ROOT/boot/System.map-$KernelVer ||:
     done
     rm -f exported
+#    install -m 644 init/kerntypes.o $RPM_BUILD_ROOT/boot/Kerntypes-$KernelVer
     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
     rm -f System.map
     cp arch/*/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
@@ -391,7 +405,19 @@ exit 0
 exit 0
 
 %post 
+# trick mkinitrd in case the current environment does not have device mapper
+rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
+if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
+    if [ ! -f $rootdev ]; then
+       fake_root_lvm=1
+       mkdir -p $(dirname $rootdev)
+       touch $rootdev
+    fi
+fi
 [ -x /sbin/new-kernel-pkg ] && /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
+if [ -n "$fake_root_lvm" ]; then
+    rm -f $rootdev
+fi
 if [ -x /usr/sbin/hardlink ] ; then
 pushd /lib/modules/%{KVERREL}/build > /dev/null ; {
        cd /lib/modules/%{KVERREL}/build
@@ -403,6 +429,8 @@ fi
 # make some useful links
 pushd /boot > /dev/null ; {
        ln -sf System.map-%{KVERREL} System.map
+#      ln -sf Kerntypes-%{KVERREL} Kerntypes
+       ln -sf config-%{KVERREL} config
        ln -sf initrd-%{KVERREL}.img initrd-boot
        ln -sf vmlinuz-%{KVERREL} kernel-boot
 }
@@ -440,6 +468,7 @@ fi
 %files 
 %defattr(-,root,root)
 /%{image_install_path}/vmlinuz-%{KVERREL}
+#/boot/Kerntypes-%{KVERREL}
 /boot/System.map-%{KVERREL}
 /boot/config-%{KVERREL}
 %dir /lib/modules/%{KVERREL}
@@ -452,6 +481,7 @@ fi
 %files smp
 %defattr(-,root,root)
 /%{image_install_path}/vmlinuz-%{KVERREL}smp
+#/boot/Kerntypes-%{KVERREL}smp
 /boot/System.map-%{KVERREL}smp
 /boot/config-%{KVERREL}smp
 %dir /lib/modules/%{KVERREL}smp
@@ -481,11 +511,75 @@ fi
 /usr/share/doc/kernel-doc-%{kversion}/Documentation/*
 %endif
 
+
+%files vserver
+%defattr(-,root,root)
+# no files
+
 %changelog
+* Thu Feb 17 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
+- merge to Fedora Core 2 2.6.10-1.14_FC2
+
+* Tue Feb 8 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
+- merge to Fedora Core 2 2.6.10-1.12_FC2
+
+* Tue Jan 18 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
+- merge to Fedora Core 2 2.6.9-1.11_FC2
+
+* Thu Sep 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
+- merge to Fedora Core 2 2.6.8-1.521
+
+* Tue Aug 31 2004 Arjan van de Ven <arjanv@redhat.com>
+- fix execshield buglet with legacy binaries
+- 2.6.9-rc1-bk7
+
+* Mon Aug 30 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.9-rc1-bk6
+
+* Sat Aug 28 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.9-rc1-bk4, now with i915 DRM driver
+
+* Fri Aug 27 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.9-rc1-bk2 
+
+* Mon Aug 23 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.8.1-bk2
+
+* Sat Aug 21 2004 Arjan van de Ven <arjanv@redhat.com>
+- attempt to fix early-udev bug
+
+* Fri Aug 13 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.8-rc4-bk3
+- split execshield up some more
+
+* Fri Aug 13 2004 Dave Jones <davej@redhat.com>
+- Update SCSI whitelist again with some more card readers.
+
+* Mon Aug 9 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.8-rc3-bk3
+
 * Thu Aug  5 2004 Mark Huang <mlhuang@cs.princeton.edu>
 - adapt for Fedora Core 2 based PlanetLab 3.0 (remove Source and Patch
   sections, most non-x86 sections, and GPG sections)
 
+* Wed Aug 4 2004 Arjan van de Ven <arjanv@redhat.com>
+- Add the flex-mmap bits for s390/s390x (Pete Zaitcev)
+- Add flex-mmap for x86-64 32 bit emulation
+- 2.6.8-rc3
+
+* Mon Aug 2 2004 Arjan van de Ven <arjanv@redhat.com>
+- Add Rik's token trashing control patch
+
+* Sun Aug 1 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.8-rc2-bk11
+
+* Fri Jul 30 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.8-rc2-bk8
+
+* Wed Jul 28 2004 Arjan van de Ven <arjanv@redhat.com>
+- 2.6.8-rc2-bk6
+- make a start at splitting up the execshield patchkit
+
 * Fri Jul 16 2004 Arjan van de Ven <arjanv@redhat.com>
 - ppc32 embedded updates