be a bit more discriptive about db error
[sfa.git] / sfa.spec
index ec4d81e..311e4a5 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -28,18 +28,20 @@ Summary: the SFA python libraries
 Group: Applications/System
 
 BuildRequires: make
-Requires: python
+Requires: python >= 2.5
 Requires: m2crypto
 Requires: libxslt-python
 Requires: python-ZSI
+# xmlbuilder depends on  lxml
+Requires: python-lxml
 
 # python 2.5 has uuid module added, for python 2.4 we still need it.
 # we can't really check for if we can load uuid as a python module,
 # it'll be installed by "devel.pkgs". we have the epel repository so
 # python-uuid will be provided. but we can test for the python
 # version.
-%define has_py24 %(`python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $?`)
-%if has_py24
+%define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
+%if %has_py24
 Requires: python-uuid
 %endif
 
@@ -103,13 +105,14 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 # sfa and sfatables depend each other.
+%{_bindir}/sfa-server.py*
 /etc/sfatables/*
 %{python_sitelib}/*
 /usr/bin/keyconvert
 /var/www/html/wsdl/*.wsdl
 
 %files cm
-/etc/init.d/sfa_cm
+/etc/init.d/sfa-cm
 %{_bindir}/sfa_component_setup.py*
 # cron jobs here 
 
@@ -123,7 +126,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/sfa-import-plc.py*
 %{_bindir}/sfa-clean-peer-records.py*
 %{_bindir}/sfa-nuke-plc.py*
-%{_bindir}/sfa-server.py*
 %{_bindir}/gen-sfa-cm-config.py*
 
 %files client
@@ -141,13 +143,13 @@ rm -rf $RPM_BUILD_ROOT
 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
 
 %pre cm
-[ -f %{_sysconfdir}/init.d/sfacm ] && service sfacm stop ||:
+[ -f %{_sysconfdir}/init.d/sfa-cm ] && service sfa-cm stop ||:
 
 %post plc
 chkconfig --add sfa
 
 %post cm
-chkconfig --add sfacm
+chkconfig --add sfa-cm
 %changelog
 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are: