remove dependency of Config module from TrustedRoots class
[sfa.git] / sfa.spec
index 0182527..6d02854 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,8 +1,13 @@
-%define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
+
+#
+# $Id$
+#
+
+%define url $URL$
 
 %define name sfa
 %define version 0.9
-%define taglevel 1
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -20,6 +25,8 @@ Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
+Summary: the SFA python libraries
+Group: Applications/System
 
 BuildRequires: make
 Requires: python
@@ -27,8 +34,11 @@ Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 Requires: libxslt-python
 
-Summary: the SFA python libraries
-Group: Applications/System
+# python 2.5 has uuid module added, for python 2.4 we still need it 
+%define uuid_missing %(`python -c "import uuid" 2> /dev/null ; echo $?`)
+%if uuid_missing
+Requires: python-uuid
+%endif
 
 %package plc
 Summary: the SFA wrapper arounf MyPLC
@@ -95,6 +105,13 @@ rm -rf $RPM_BUILD_ROOT
 chkconfig --add sfa
 
 %changelog
+* Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
+- compatibility with RefreshPeer
+- incremental mechanism for importing PLC records into SFA tables
+- unified single database (still inside the underlying PLC db postgresql server)
+- includes/improves call traceability and logging features
+- several bug fixes
+
 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
 - added libxslt-python dependency