remove unexistent rpms from BuildRequires:
[sfa.git] / sfa.spec
index 79773cb..7f2773b 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -24,17 +24,24 @@ URL: %{SCMURL}
 Summary: Server-side for SFA, generic implementation derived from PlanetLab
 Group: Applications/System
 BuildRequires: make
+%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "29"
 BuildRequires: python2-dateutil
 BuildRequires: python2-lxml
+%endif
 
 # for uuidgen - used in db password generation
 Requires: util-linux-ng
 # for the registry
 Requires: postgresql >= 8.2, postgresql-server >= 8.2
-Requires: postgresql-python
+# these are no longer supported in f33, use pip2 instead
+%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "31"
+Requires: python2-pygresql
+%endif
 Requires: python2-psycopg2
 Requires: python2-sqlalchemy
+%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "29"
 Requires: python2-migrate
+%endif
 # and of course the bulk of it
 Requires: sfa-common
 
@@ -49,8 +56,10 @@ Requires: python2-lxml
 %if "%{distro}" == "Fedora" && "%{distrorelease}" <= "27"
 Requires: python-ZSI
 %else
+%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "29"
 Requires: python2-zsi
 %endif
+%endif
 Requires: libxslt-python
 Requires: xmlsec1-openssl-devel