more tweaks for f31/py2
[sfa.git] / sfa.spec
index 65c3190..bd374c0 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,10 +1,10 @@
 %define name sfa
 %define version 4.0
-%define taglevel 1
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
-%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+%global python_sitearch        %( python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+%{!?python_sitelib: %define python_sitelib %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 Name: %{name}
 Version: %{version}
@@ -24,6 +24,8 @@ URL: %{SCMURL}
 Summary: Server-side for SFA, generic implementation derived from PlanetLab
 Group: Applications/System
 BuildRequires: make
+BuildRequires: python2-dateutil
+BuildRequires: python2-lxml
 
 # for uuidgen - used in db password generation
 Requires: util-linux-ng
@@ -198,6 +200,7 @@ rm -rf $RPM_BUILD_ROOT
 %post
 systemctl enable sfa-aggregate
 systemctl enable sfa-registry
+true
 
 %preun
 if [ "$1" = 0 ] ; then
@@ -206,6 +209,7 @@ if [ "$1" = 0 ] ; then
         systemctl is-active $service && systemctl stop $service
     done
 fi
+true
 
 %postun
 if [ "$1" -ge "1" ] ; then
@@ -213,8 +217,18 @@ if [ "$1" -ge "1" ] ; then
         systemctl is-active $service && systemctl restart $service
     done
 fi
+true
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - sfa-4.0-2
+- have shebangs mention python2 since it is what this version runs on
+- use rpm names in python2-something for expressing dependencies
+- remove build dependency to python-setuptools
+- Handle C-BAS hrn format with "\" (Loic)
+- sfa-start does not daemonize anymore (this is handled by systemd)
+- a little nicer logs when troubleshooting auth issues
+- use systemctl in Makefile when syncing
+
 * Wed May 30 2018 Thierry <Parmentelat> - sfa-4.0-1
 - systemd service files install in /lib instead of /usr/lib for ubuntus
 - removed all features relating to slice manager