Merge branch 'master' of ssh://git.onelab.eu/git/sfa
[sfa.git] / sfa.spec
index fb176da..eb23ec4 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,6 +1,3 @@
-
-%define url $URL$
-
 %define name sfa
 %define version 1.0
 %define taglevel 6
@@ -20,7 +17,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %SCMURL}
 Summary: the SFA python libraries
 Group: Applications/System
 
@@ -105,11 +102,11 @@ Provides some binary unit tests in /usr/share/sfa/tests
 %setup -q
 
 %build
-make VERSION=%{version}-%{taglevel}
+make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make install VERSION=%{version}-%{taglevel} DESTDIR="$RPM_BUILD_ROOT"
+make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
 
 %clean
 rm -rf $RPM_BUILD_ROOT