xenserver: Create network.conf before running interface-reconfigure.
[sliver-openvswitch.git] / xenserver / openvswitch-xen.spec
index 67dd26d..debb2fd 100644 (file)
@@ -172,8 +172,15 @@ if test "$PRODUCT_VERSION" = "5.5.0"; then
     fi
     rm -f $XSS
     ln -s $RNU $XSS
+
+    # If /etc/xensource/network.conf doesn't exist (it was added in 5.6.0),
+    # then interface-reconfigure will be unhappy when we run it below.
+    if test ! -e /etc/xensource/network.conf; then
+        echo bridge > /etc/xensource/network.conf
+    fi
 fi
 
+
 if test ! -e /var/xapi/network.dbcache; then
     if test "$1" = 1; then
         printf "Creating xapi database cache...  "