this sounds better although it does not fix anything
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 5.2
6 %define taglevel 4
7
8 # pldistro already in the rpm name
9 %define release %{taglevel}%{?date:.%{date}}
10
11 # structure - this results in 2 packages
12 # bootcd-initscripts - has the plc.d/ scripts
13 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %{SCMURL}
19
20 Summary: Boot CD material for %{nodefamily}
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: BSD
25 Group: System Environment/Base
26 Source0: %{name}-%{version}.tar.gz
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 # other archs must be able to install this
29 BuildArch: noarch
30
31 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
32 # yumdownloader is needed in bootcd-kernel
33 Requires: yum-utils
34 # mkdiskimage is used for USB-partitioned mode
35 # but it now comes in a separate rpm
36 %if "%{distro}" == "Fedora" && %{distrorelease} >= 14
37 Requires: syslinux-perl
38 %endif
39
40 Requires: pyplnet
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: bootcd-%{obsolete_nodefamily}
45
46 AutoReqProv: no
47 %define debug_package %{nil}
48
49 %description
50 The Boot CD securely boots PlanetLab nodes into an immutable
51 environment. This package is designed to be installed on a MyPLC
52 installation and provide the basics for the PLC to able to compute
53 BootCDs for its attached nodes. 
54 See http://svn.planet-lab.org/wiki/NodeFamily
55
56
57 %package -n bootcd-initscripts
58 Summary: initscripts for the MyPLC installation
59 Group: System Environment/Base
60 %description -n bootcd-initscripts
61 This package contains the init scripts that get fired when the PLC is
62 restarted.
63
64 ### avoid having yum complain about updates, as stuff is moving around
65 # plc.d/bootcd*
66 Conflicts: MyPLC <= 4.3
67
68 %prep
69 %setup -q
70
71 %build
72 [ -d bootcd ] || ln -s BootCD bootcd
73
74 pushd bootcd
75
76 # Build the reference image - pass 3-fold version number to go in version.txt
77 ./prep.sh %{pldistro} %{nodefamily} %{version}
78
79 popd
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 pushd bootcd
85
86 # Install the reference image and build scripts
87 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
88 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
89 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
90 tar cpf - \
91     build/isofs/bootcd.img \
92     build/isofs/kernel \
93     build/passwd \
94     build/version.txt \
95     build/nodefamily \
96     configurations | \
97     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
98
99 for script in bootcd bootcd-kernel; do 
100     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
101 done
102
103 popd
104     
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(-,root,root,-)
110 %{_datadir}/%{name}
111
112 %files -n bootcd-initscripts
113 %defattr(-,root,root,-)
114 /etc/plc.d
115
116 %changelog
117 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-4
118 - no change, only some internal comments were changed
119
120 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-3
121 - attempt to make node take off more reliable with pl_wrapper
122
123 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-2
124 - fix version number as it shows up in version.txt (was empty)
125
126 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-1
127 - turn off systemd traces at boot-time
128
129 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-5
130 - fix console on tty2: this broke the build on fedora14
131 - even though f14 doesn't use systemd by defaults there is /etc/systemd in there
132
133 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-4
134 - turn on getty/console on tty2
135
136 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-3
137 - reviewed for systemd & f18
138
139 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-2
140 - turn off selinux, turns out needed with some combinations like lxc/f14
141
142 * Wed Apr 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-1
143 - compatible with pre- and post- f16
144 - add systemd friendlyness to bootcd
145 - also add biosdevname=0 tp kernel args so ethernet devices are still named in eth<x>
146
147 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
148 - add requires: to syslinux-perl on fedora14
149
150 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
151 - blacklisted mdules
152 - requires yum-utils for yumdownloader in bootcd-kernel
153
154 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
155 - Handle /dev/rtc name change for newer kernels
156
157 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
158 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
159
160 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
161 - changes for booting off fedora14
162 - displays some sanity checks in case bm can's get downloaded
163 - virtio devices in /dev/vd* also considered
164 - start service rsyslog if found
165 - hack for kernel-firmware with 2.6.32
166 - use $() instead of ``
167
168 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
169 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
170
171 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
172 - remove remainging reference to planet-lab.org
173
174 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
175 - module name changes
176
177 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
178 - nicer initscript now uses 'action' from /etc/init.d/functions
179
180 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
181 - obsolete old bootcd versions
182
183 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
184 - First working version of 5.0:
185 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
186 - nodefamily is 3-fold with pldistro-fcdistro-arch
187 - new module bootcd-inistscripts
188
189 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
190 - support for fedora 12
191
192 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
193 - fix build on fedora12
194
195 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
196 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
197 - repeated in the bootmanager to handle all CDs without this operation
198
199 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
200 - Daniel''s update to generalize the kvariant support.
201
202 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
203 - robust to node config file specified with a relative path
204
205 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
206 - fix specfile - 4.2-11 would not build
207
208 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
209 - Added support for handling kernel variants
210 - http://svn.planet-lab.org/wiki/BootcdVariant
211
212 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
213 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
214
215 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
216 - Added kupdate.sh
217
218 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
219 - Use pyplnet.
220 - Add a site_admin account to the BootCD.
221 - Add some explanations for common errors.
222
223 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
224 - Allow multiple -k options to the build.sh script.
225 - Probe devices in PCI bus order.
226
227 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
228 - add support for fedora9 images - compliant with upstart
229 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
230
231 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
232 - cosmetic - pl_boot to display timestamps
233
234 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
235 - adds -k as an argument to build.sh to pass additional kernel parameters to the
236 - bootcd and kexec kernel.
237
238 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
239 - rpm release tag does not need pldistro as it is already part of the rpm name
240
241 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
242 - change location of nodefamily in /etc/planetlab/
243
244 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
245 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
246 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
247 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
248
249 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
250 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
251 - build.sh cleaned up in the process
252 - actual location of selected node config file displayed
253 - import pypci rather than pypciscan
254
255 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
256 - build.sh support for -s <console_spec> (recommended vs using type)
257 - build.sh cleanup - usage clearer wrt types - removed old code
258 - fixed modprobe with args in pl_hwinit
259
260 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
261 - load floppy with modprobe flags
262 - support for creating a usb partition
263 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
264
265 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
266 - added biginitrd usb image
267
268 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
269 - Initial build.
270
271 %define module_current_branch 4.2