have pl_netinit source pl_functions, for messages to show up as expected
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 5.4
6 %define taglevel 1
7
8 # pldistro already in the rpm name
9 %define release %{taglevel}%{?date:.%{date}}
10
11 # structure - this results in 2 packages
12 # bootcd-initscripts - has the plc.d/ scripts
13 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %{SCMURL}
19
20 Summary: Boot CD material for %{nodefamily}
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: BSD
25 Group: System Environment/Base
26 Source0: %{name}-%{version}.tar.gz
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 # other archs must be able to install this
29 BuildArch: noarch
30
31 Requires: dosfstools, genisoimage, gzip, mtools, syslinux
32 # yumdownloader is needed in bootcd-kernel
33 Requires: yum-utils
34 # mkdiskimage is used for USB-partitioned mode
35 # but it now comes in a separate rpm
36 %if "%{distro}" == "Fedora" && %{distrorelease} >= 14
37 Requires: syslinux-perl
38 %endif
39
40 Requires: pyplnet
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: bootcd-%{obsolete_nodefamily}
45
46 AutoReqProv: no
47 %define debug_package %{nil}
48
49 %description
50 The Boot CD securely boots PlanetLab nodes into an immutable
51 environment. This package is designed to be installed on a MyPLC
52 installation and provide the basics for the PLC to able to compute
53 BootCDs for its attached nodes. 
54 See http://svn.planet-lab.org/wiki/NodeFamily
55
56
57 %package -n bootcd-initscripts
58 Summary: initscripts for the MyPLC installation
59 Group: System Environment/Base
60 %description -n bootcd-initscripts
61 This package contains the init scripts that get fired when the PLC is
62 restarted.
63
64 ### avoid having yum complain about updates, as stuff is moving around
65 # plc.d/bootcd*
66 Conflicts: MyPLC <= 4.3
67
68 %prep
69 %setup -q
70
71 %build
72 [ -d bootcd ] || ln -s BootCD bootcd
73
74 pushd bootcd
75
76 # Build the reference image - pass 3-fold version number to go in version.txt
77 ./prep.sh %{pldistro} %{nodefamily} %{version}
78
79 popd
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 pushd bootcd
85
86 # Install the reference image and build scripts
87 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
88 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
89 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
90 tar cpf - \
91     build/isofs/bootcd.img \
92     build/isofs/kernel \
93     build/passwd \
94     build/version.txt \
95     build/nodefamily \
96     configurations | \
97     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
98
99 for script in bootcd bootcd-kernel; do 
100     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
101 done
102
103 popd
104     
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(-,root,root,-)
110 %{_datadir}/%{name}
111
112 %files -n bootcd-initscripts
113 %defattr(-,root,root,-)
114 /etc/plc.d
115
116 %changelog
117 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.4-1
118 - use 8.8.8.8 s a DNS server if nothing else works
119 - more consistent and verbose forensics system
120
121 * Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-3
122 - patch for f23 as of dec. 2015 where kernel and initrd show up in
123 - a new location under /boot
124
125 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-2
126 - various fixes for resolv.conf
127
128 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-1
129 - use TLSv1 instead of SSLv3
130 - on systemd distros, do not try to replace the whole boot sequence
131 - as older bootCDs did; pl_boot is now just one more service, not the single
132 - service to run; this solves f21 bootCDs not starting up properly
133
134 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-6
135 - remove default kargs systemd.log_target=console console=ttyS0,115200
136 - simpler bootcd layout (no memdisk nor isolinux-debug.bin)
137 - keep track of actual kargs in log file for build.sh
138
139 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-5
140 - changes for fedora 21 and its new release of syslinux
141
142 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-4
143 - no change, only some internal comments were changed
144
145 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-3
146 - attempt to make node take off more reliable with pl_wrapper
147
148 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-2
149 - fix version number as it shows up in version.txt (was empty)
150
151 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-1
152 - turn off systemd traces at boot-time
153
154 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-5
155 - fix console on tty2: this broke the build on fedora14
156 - even though f14 doesn't use systemd by defaults there is /etc/systemd in there
157
158 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-4
159 - turn on getty/console on tty2
160
161 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-3
162 - reviewed for systemd & f18
163
164 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-2
165 - turn off selinux, turns out needed with some combinations like lxc/f14
166
167 * Wed Apr 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-1
168 - compatible with pre- and post- f16
169 - add systemd friendlyness to bootcd
170 - also add biosdevname=0 tp kernel args so ethernet devices are still named in eth<x>
171
172 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
173 - add requires: to syslinux-perl on fedora14
174
175 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
176 - blacklisted mdules
177 - requires yum-utils for yumdownloader in bootcd-kernel
178
179 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
180 - Handle /dev/rtc name change for newer kernels
181
182 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
183 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
184
185 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
186 - changes for booting off fedora14
187 - displays some sanity checks in case bm can's get downloaded
188 - virtio devices in /dev/vd* also considered
189 - start service rsyslog if found
190 - hack for kernel-firmware with 2.6.32
191 - use $() instead of ``
192
193 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
194 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
195
196 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
197 - remove remainging reference to planet-lab.org
198
199 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
200 - module name changes
201
202 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
203 - nicer initscript now uses 'action' from /etc/init.d/functions
204
205 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
206 - obsolete old bootcd versions
207
208 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
209 - First working version of 5.0:
210 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
211 - nodefamily is 3-fold with pldistro-fcdistro-arch
212 - new module bootcd-inistscripts
213
214 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
215 - support for fedora 12
216
217 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
218 - fix build on fedora12
219
220 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
221 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
222 - repeated in the bootmanager to handle all CDs without this operation
223
224 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
225 - Daniel''s update to generalize the kvariant support.
226
227 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
228 - robust to node config file specified with a relative path
229
230 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
231 - fix specfile - 4.2-11 would not build
232
233 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
234 - Added support for handling kernel variants
235 - http://svn.planet-lab.org/wiki/BootcdVariant
236
237 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
238 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
239
240 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
241 - Added kupdate.sh
242
243 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
244 - Use pyplnet.
245 - Add a site_admin account to the BootCD.
246 - Add some explanations for common errors.
247
248 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
249 - Allow multiple -k options to the build.sh script.
250 - Probe devices in PCI bus order.
251
252 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
253 - add support for fedora9 images - compliant with upstart
254 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
255
256 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
257 - cosmetic - pl_boot to display timestamps
258
259 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
260 - adds -k as an argument to build.sh to pass additional kernel parameters to the
261 - bootcd and kexec kernel.
262
263 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
264 - rpm release tag does not need pldistro as it is already part of the rpm name
265
266 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
267 - change location of nodefamily in /etc/planetlab/
268
269 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
270 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
271 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
272 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
273
274 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
275 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
276 - build.sh cleaned up in the process
277 - actual location of selected node config file displayed
278 - import pypci rather than pypciscan
279
280 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
281 - build.sh support for -s <console_spec> (recommended vs using type)
282 - build.sh cleanup - usage clearer wrt types - removed old code
283 - fixed modprobe with args in pl_hwinit
284
285 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
286 - load floppy with modprobe flags
287 - support for creating a usb partition
288 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
289
290 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
291 - added biginitrd usb image
292
293 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
294 - Initial build.
295
296 %define module_current_branch 4.2