676d6cf49f6ffba07fbd9da0dea2da53e7f8bce4
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 4.2
10 %define taglevel 24
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33 # yumdownloader is needed in bootcd-kernel
34 Requires: yum-utils
35
36 Requires: pyplnet
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The Boot CD securely boots PlanetLab nodes into an immutable
43 environment.
44
45 %prep
46 %setup -q
47
48 %build
49 [ -d BootCD ] || ln -s bootcd BootCD
50 pushd BootCD
51
52 # Build the reference image
53 ./prep.sh %{pldistro} %{nodefamily}
54
55 popd
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 pushd  BootCD
61
62 # Install the reference image and build scripts
63 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
64 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
65 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
66 tar cpf - \
67     build/isofs/bootcd.img \
68     build/isofs/kernel \
69     build/passwd \
70     build/version.txt \
71     build/nodefamily \
72     configurations | \
73     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
74
75 popd
76     
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 # If run under sudo
81 if [ -n "$SUDO_USER" ] ; then
82     # Allow user to delete the build directory
83     chown -h -R $SUDO_USER .
84     # Some temporary cdroot files like /var/empty/sshd and
85     # /usr/bin/sudo get created with non-readable permissions.
86     find . -not -perm +0600 -exec chmod u+rw {} \;
87     # Allow user to delete the built RPM(s)
88     chown -h -R $SUDO_USER %{_rpmdir}/*
89 fi
90
91 %files
92 %defattr(-,root,root,-)
93 %{_datadir}/%{name}
94
95 %post
96 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
97
98 %changelog
99 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-24
100 - Remove hardcoded file list
101
102 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-23
103 - cherry-pick changesets from master to support SL6
104
105 * Tue Mar 08 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-22
106 - Support virtio block devices
107
108 * Tue Mar 01 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-21
109 - do not try to load blacklisted modules
110 - handle /dev/rtc name change for newer kernels
111
112 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-20
113 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
114
115 * Tue Jan 18 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-19
116 - Introduce a quick hack for 2.6.32 based BootCD
117
118 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-18
119 - handle directory name changes
120
121 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
122 - support for fedora 12
123
124 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
125 - fix build on fedora12
126
127 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
128 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
129 - repeated in the bootmanager to handle all CDs without this operation
130
131 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
132 - Daniel's update to generalize the kvariant support.
133
134 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
135 - robust to node config file specified with a relative path
136
137 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
138 - fix specfile - 4.2-11 would not build
139
140 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
141 - Added support for handling kernel variants
142 - http://svn.planet-lab.org/wiki/BootcdVariant
143
144 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
145 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
146
147 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
148 - Added kupdate.sh
149
150 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
151 - Use pyplnet.
152 - Add a site_admin account to the BootCD.
153 - Add some explanations for common errors.
154
155 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
156 - Allow multiple -k options to the build.sh script.
157 - Probe devices in PCI bus order.
158
159 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
160 - add support for fedora9 images - compliant with upstart
161 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
162
163 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
164 - cosmetic - pl_boot to display timestamps
165
166 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
167 - adds -k as an argument to build.sh to pass additional kernel parameters to the
168 - bootcd and kexec kernel.
169
170 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
171 - rpm release tag does not need pldistro as it is already part of the rpm name
172
173 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
174 - change location of nodefamily in /etc/planetlab/
175
176 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
177 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
178 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
179 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
180
181 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
182 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
183 - build.sh cleaned up in the process
184 - actual location of selected node config file displayed
185 - import pypci rather than pypciscan
186
187 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
188 - build.sh support for -s <console_spec> (recommended vs using type)
189 - build.sh cleanup - usage clearer wrt types - removed old code
190 - fixed modprobe with args in pl_hwinit
191
192 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
193 - load floppy with modprobe flags
194 - support for creating a usb partition
195 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
196
197 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
198 - added biginitrd usb image
199
200 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
201 - Initial build.
202
203 %define module_current_branch 3.4