Setting tag bootcd-4.2-20
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 4.2
10 %define taglevel 20
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33
34 Requires: pyplnet
35
36 AutoReqProv: no
37 %define debug_package %{nil}
38
39 %description
40 The Boot CD securely boots PlanetLab nodes into an immutable
41 environment.
42
43 %prep
44 %setup -q
45
46 %build
47 [ -d BootCD ] || ln -s bootcd BootCD
48 pushd BootCD
49
50 # Build the reference image
51 ./prep.sh %{pldistro} %{nodefamily}
52
53 popd
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 pushd  BootCD
59
60 # Install the reference image and build scripts
61 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
62 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
63 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
64 tar cpf - \
65     build/isofs/bootcd.img \
66     build/isofs/kernel \
67     build/passwd \
68     build/version.txt \
69     build/nodefamily \
70     configurations | \
71     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
72
73 popd
74     
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 # If run under sudo
79 if [ -n "$SUDO_USER" ] ; then
80     # Allow user to delete the build directory
81     chown -h -R $SUDO_USER .
82     # Some temporary cdroot files like /var/empty/sshd and
83     # /usr/bin/sudo get created with non-readable permissions.
84     find . -not -perm +0600 -exec chmod u+rw {} \;
85     # Allow user to delete the built RPM(s)
86     chown -h -R $SUDO_USER %{_rpmdir}/*
87 fi
88
89 %files
90 %defattr(-,root,root,-)
91 %{_datadir}/%{name}
92
93 %post
94 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
95
96 %changelog
97 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-20
98 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
99
100 * Tue Jan 18 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-19
101 - Introduce a quick hack for 2.6.32 based BootCD
102
103 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-18
104 - handle directory name changes
105
106 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
107 - support for fedora 12
108
109 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
110 - fix build on fedora12
111
112 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
113 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
114 - repeated in the bootmanager to handle all CDs without this operation
115
116 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
117 - Daniel's update to generalize the kvariant support.
118
119 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
120 - robust to node config file specified with a relative path
121
122 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
123 - fix specfile - 4.2-11 would not build
124
125 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
126 - Added support for handling kernel variants
127 - http://svn.planet-lab.org/wiki/BootcdVariant
128
129 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
130 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
131
132 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
133 - Added kupdate.sh
134
135 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
136 - Use pyplnet.
137 - Add a site_admin account to the BootCD.
138 - Add some explanations for common errors.
139
140 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
141 - Allow multiple -k options to the build.sh script.
142 - Probe devices in PCI bus order.
143
144 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
145 - add support for fedora9 images - compliant with upstart
146 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
147
148 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
149 - cosmetic - pl_boot to display timestamps
150
151 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
152 - adds -k as an argument to build.sh to pass additional kernel parameters to the
153 - bootcd and kexec kernel.
154
155 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
156 - rpm release tag does not need pldistro as it is already part of the rpm name
157
158 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
159 - change location of nodefamily in /etc/planetlab/
160
161 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
162 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
163 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
164 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
165
166 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
167 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
168 - build.sh cleaned up in the process
169 - actual location of selected node config file displayed
170 - import pypci rather than pypciscan
171
172 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
173 - build.sh support for -s <console_spec> (recommended vs using type)
174 - build.sh cleanup - usage clearer wrt types - removed old code
175 - fixed modprobe with args in pl_hwinit
176
177 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
178 - load floppy with modprobe flags
179 - support for creating a usb partition
180 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
181
182 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
183 - added biginitrd usb image
184
185 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
186 - Initial build.
187
188 %define module_current_branch 3.4