remove hardcoded file list which won't match with SL6
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 4.2
10 %define taglevel 23
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33
34 Requires: pyplnet
35
36 AutoReqProv: no
37 %define debug_package %{nil}
38
39 %description
40 The Boot CD securely boots PlanetLab nodes into an immutable
41 environment.
42
43 %prep
44 %setup -q
45
46 %build
47 [ -d BootCD ] || ln -s bootcd BootCD
48 pushd BootCD
49
50 # Build the reference image
51 ./prep.sh %{pldistro} %{nodefamily}
52
53 popd
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 pushd  BootCD
59
60 # Install the reference image and build scripts
61 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
62 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
63 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
64 tar cpf - \
65     build/isofs/bootcd.img \
66     build/isofs/kernel \
67     build/passwd \
68     build/version.txt \
69     build/nodefamily \
70     configurations | \
71     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
72
73 popd
74     
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 # If run under sudo
79 if [ -n "$SUDO_USER" ] ; then
80     # Allow user to delete the build directory
81     chown -h -R $SUDO_USER .
82     # Some temporary cdroot files like /var/empty/sshd and
83     # /usr/bin/sudo get created with non-readable permissions.
84     find . -not -perm +0600 -exec chmod u+rw {} \;
85     # Allow user to delete the built RPM(s)
86     chown -h -R $SUDO_USER %{_rpmdir}/*
87 fi
88
89 %files
90 %defattr(-,root,root,-)
91 %{_datadir}/%{name}
92
93 %post
94 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
95
96 %changelog
97 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-23
98 - cherry-pick changesets from master to support SL6
99
100 * Tue Mar 08 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-22
101 - Support virtio block devices
102
103 * Tue Mar 01 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-21
104 - do not try to load blacklisted modules
105 - handle /dev/rtc name change for newer kernels
106
107 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-20
108 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
109
110 * Tue Jan 18 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-19
111 - Introduce a quick hack for 2.6.32 based BootCD
112
113 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-18
114 - handle directory name changes
115
116 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
117 - support for fedora 12
118
119 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
120 - fix build on fedora12
121
122 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
123 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
124 - repeated in the bootmanager to handle all CDs without this operation
125
126 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
127 - Daniel's update to generalize the kvariant support.
128
129 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
130 - robust to node config file specified with a relative path
131
132 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
133 - fix specfile - 4.2-11 would not build
134
135 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
136 - Added support for handling kernel variants
137 - http://svn.planet-lab.org/wiki/BootcdVariant
138
139 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
140 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
141
142 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
143 - Added kupdate.sh
144
145 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
146 - Use pyplnet.
147 - Add a site_admin account to the BootCD.
148 - Add some explanations for common errors.
149
150 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
151 - Allow multiple -k options to the build.sh script.
152 - Probe devices in PCI bus order.
153
154 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
155 - add support for fedora9 images - compliant with upstart
156 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
157
158 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
159 - cosmetic - pl_boot to display timestamps
160
161 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
162 - adds -k as an argument to build.sh to pass additional kernel parameters to the
163 - bootcd and kexec kernel.
164
165 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
166 - rpm release tag does not need pldistro as it is already part of the rpm name
167
168 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
169 - change location of nodefamily in /etc/planetlab/
170
171 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
172 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
173 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
174 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
175
176 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
177 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
178 - build.sh cleaned up in the process
179 - actual location of selected node config file displayed
180 - import pypci rather than pypciscan
181
182 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
183 - build.sh support for -s <console_spec> (recommended vs using type)
184 - build.sh cleanup - usage clearer wrt types - removed old code
185 - fixed modprobe with args in pl_hwinit
186
187 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
188 - load floppy with modprobe flags
189 - support for creating a usb partition
190 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
191
192 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
193 - added biginitrd usb image
194
195 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
196 - Initial build.
197
198 %define module_current_branch 3.4