Setting tag BootCD-5.0-4
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 5.0
10 %define taglevel 4
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 # structure - this results in 2 packages
17 # bootcd-initscripts - has the plc.d/ scripts
18 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %(echo %{url} | cut -d ' ' -f 2)
24
25 Summary: Boot CD material for %{nodefamily}
26 Name: %{name}
27 Version: %{version}
28 Release: %{release}
29 License: BSD
30 Group: System Environment/Base
31 Source0: %{name}-%{version}.tar.gz
32 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33 # other archs must be able to install this
34 BuildArch: noarch
35
36 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
37
38 Requires: pyplnet
39
40 # 5.0 now has 3-fold nodefamily
41 %define obsolete_nodefamily %{pldistro}-%{_arch}
42 Obsoletes: bootcd-%{obsolete_nodefamily}
43
44 AutoReqProv: no
45 %define debug_package %{nil}
46
47 %description
48 The Boot CD securely boots PlanetLab nodes into an immutable
49 environment. This package is designed to be installed on a MyPLC
50 installation and provide the basics for the PLC to able to compute
51 BootCDs for its attached nodes. 
52 See http://svn.planet-lab.org/wiki/NodeFamily
53
54
55 %package -n bootcd-initscripts
56 Summary: initscripts for the MyPLC installation
57 Group: System Environment/Base
58 %description -n bootcd-initscripts
59 This package contains the init scripts that get fired when the PLC is
60 restarted.
61
62 ### avoid having yum complain about updates, as stuff is moving around
63 # plc.d/bootcd*
64 Conflicts: MyPLC <= 4.3
65
66 %prep
67 %setup -q
68
69 %build
70 [ -d bootcd ] || ln -s BootCD bootcd
71
72 pushd bootcd
73
74 # Build the reference image
75 ./prep.sh %{pldistro} %{nodefamily}
76
77 popd
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 pushd bootcd
83
84 # Install the reference image and build scripts
85 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
86 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
87 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
88 tar cpf - \
89     build/isofs/bootcd.img \
90     build/isofs/kernel \
91     build/passwd \
92     build/version.txt \
93     build/nodefamily \
94     configurations | \
95     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
96
97 for script in bootcd bootcd-kernel; do 
98     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
99 done
100 popd
101     
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(-,root,root,-)
107 %{_datadir}/%{name}
108
109 %files -n bootcd-initscripts
110 %defattr(-,root,root,-)
111 /etc/plc.d
112
113 %changelog
114 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
115 - module name changes
116
117 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
118 - nicer initscript now uses 'action' from /etc/init.d/functions
119
120 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
121 - obsolete old bootcd versions
122
123 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
124 - First working version of 5.0:
125 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
126 - nodefamily is 3-fold with pldistro-fcdistro-arch
127 - new module bootcd-inistscripts
128
129 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
130 - support for fedora 12
131
132 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
133 - fix build on fedora12
134
135 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
136 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
137 - repeated in the bootmanager to handle all CDs without this operation
138
139 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
140 - Daniel''s update to generalize the kvariant support.
141
142 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
143 - robust to node config file specified with a relative path
144
145 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
146 - fix specfile - 4.2-11 would not build
147
148 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
149 - Added support for handling kernel variants
150 - http://svn.planet-lab.org/wiki/BootcdVariant
151
152 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
153 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
154
155 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
156 - Added kupdate.sh
157
158 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
159 - Use pyplnet.
160 - Add a site_admin account to the BootCD.
161 - Add some explanations for common errors.
162
163 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
164 - Allow multiple -k options to the build.sh script.
165 - Probe devices in PCI bus order.
166
167 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
168 - add support for fedora9 images - compliant with upstart
169 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
170
171 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
172 - cosmetic - pl_boot to display timestamps
173
174 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
175 - adds -k as an argument to build.sh to pass additional kernel parameters to the
176 - bootcd and kexec kernel.
177
178 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
179 - rpm release tag does not need pldistro as it is already part of the rpm name
180
181 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
182 - change location of nodefamily in /etc/planetlab/
183
184 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
185 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
186 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
187 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
188
189 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
190 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
191 - build.sh cleaned up in the process
192 - actual location of selected node config file displayed
193 - import pypci rather than pypciscan
194
195 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
196 - build.sh support for -s <console_spec> (recommended vs using type)
197 - build.sh cleanup - usage clearer wrt types - removed old code
198 - fixed modprobe with args in pl_hwinit
199
200 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
201 - load floppy with modprobe flags
202 - support for creating a usb partition
203 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
204
205 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
206 - added biginitrd usb image
207
208 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
209 - Initial build.
210
211 %define module_current_branch 4.2