Tagging module BootCD - BootCD-4.2-4
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 4.2
10 %define taglevel 4
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33
34 AutoReqProv: no
35 %define debug_package %{nil}
36
37 %description
38 The Boot CD securely boots PlanetLab nodes into an immutable
39 environment.
40
41 %prep
42 %setup -q
43
44 %build
45 pushd BootCD
46
47 # Build the reference image
48 ./prep.sh %{pldistro} %{nodefamily}
49
50 popd
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 pushd  BootCD
56
57 # Install the reference image and build scripts
58 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
59 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
60 tar cpf - \
61     build/isofs/bootcd.img \
62     build/isofs/kernel \
63     build/passwd \
64     build/version.txt \
65     build/nodefamily \
66     configurations | \
67     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
68
69 popd
70     
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 # If run under sudo
75 if [ -n "$SUDO_USER" ] ; then
76     # Allow user to delete the build directory
77     chown -h -R $SUDO_USER .
78     # Some temporary cdroot files like /var/empty/sshd and
79     # /usr/bin/sudo get created with non-readable permissions.
80     find . -not -perm +0600 -exec chmod u+rw {} \;
81     # Allow user to delete the built RPM(s)
82     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
83 fi
84
85 %files
86 %defattr(-,root,root,-)
87 %{_datadir}/%{name}
88
89 %post
90 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
91
92 %changelog
93 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
94 - adds -k as an argument to build.sh to pass additional kernel parameters to the
95 - bootcd and kexec kernel.
96
97 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
98 - rpm release tag does not need pldistro as it is already part of the rpm name
99
100 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
101 - change location of nodefamily in /etc/planetlab/
102
103 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
104 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
105 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
106 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
107
108 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
109 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
110 - build.sh cleaned up in the process
111 - actual location of selected node config file displayed
112 - import pypci rather than pypciscan
113
114 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
115 - build.sh support for -s <console_spec> (recommended vs using type)
116 - build.sh cleanup - usage clearer wrt types - removed old code
117 - fixed modprobe with args in pl_hwinit
118
119 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
120 - load floppy with modprobe flags
121 - support for creating a usb partition
122 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
123
124 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
125 - added biginitrd usb image
126
127 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
128 - Initial build.
129
130 %define module_current_branch 3.4