Setting tag bootcd-5.0-10
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 5.0
6 %define taglevel 10
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # structure - this results in 2 packages
13 # bootcd-initscripts - has the plc.d/ scripts
14 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33 # yumdownloader is needed in bootcd-kernel
34 Requires: yum-utils
35
36 Requires: pyplnet
37
38 # 5.0 now has 3-fold nodefamily
39 %define obsolete_nodefamily %{pldistro}-%{_arch}
40 Obsoletes: bootcd-%{obsolete_nodefamily}
41
42 AutoReqProv: no
43 %define debug_package %{nil}
44
45 %description
46 The Boot CD securely boots PlanetLab nodes into an immutable
47 environment. This package is designed to be installed on a MyPLC
48 installation and provide the basics for the PLC to able to compute
49 BootCDs for its attached nodes. 
50 See http://svn.planet-lab.org/wiki/NodeFamily
51
52
53 %package -n bootcd-initscripts
54 Summary: initscripts for the MyPLC installation
55 Group: System Environment/Base
56 %description -n bootcd-initscripts
57 This package contains the init scripts that get fired when the PLC is
58 restarted.
59
60 ### avoid having yum complain about updates, as stuff is moving around
61 # plc.d/bootcd*
62 Conflicts: MyPLC <= 4.3
63
64 %prep
65 %setup -q
66
67 %build
68 [ -d bootcd ] || ln -s BootCD bootcd
69
70 pushd bootcd
71
72 # Build the reference image
73 ./prep.sh %{pldistro} %{nodefamily}
74
75 popd
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 pushd bootcd
81
82 # Install the reference image and build scripts
83 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
84 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
85 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
86 tar cpf - \
87     build/isofs/bootcd.img \
88     build/isofs/kernel \
89     build/passwd \
90     build/version.txt \
91     build/nodefamily \
92     configurations | \
93     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
94
95 for script in bootcd bootcd-kernel; do 
96     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
97 done
98 popd
99     
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(-,root,root,-)
105 %{_datadir}/%{name}
106
107 %files -n bootcd-initscripts
108 %defattr(-,root,root,-)
109 /etc/plc.d
110
111 %changelog
112 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
113 - blacklisted mdules
114 - requires yum-utils for yumdownloader in bootcd-kernel
115
116 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
117 - Handle /dev/rtc name change for newer kernels
118
119 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
120 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
121
122 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
123 - changes for booting off fedora14
124 - displays some sanity checks in case bm can's get downloaded
125 - virtio devices in /dev/vd* also considered
126 - start service rsyslog if found
127 - hack for kernel-firmware with 2.6.32
128 - use $() instead of ``
129
130 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
131 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
132
133 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
134 - remove remainging reference to planet-lab.org
135
136 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
137 - module name changes
138
139 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
140 - nicer initscript now uses 'action' from /etc/init.d/functions
141
142 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
143 - obsolete old bootcd versions
144
145 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
146 - First working version of 5.0:
147 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
148 - nodefamily is 3-fold with pldistro-fcdistro-arch
149 - new module bootcd-inistscripts
150
151 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
152 - support for fedora 12
153
154 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
155 - fix build on fedora12
156
157 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
158 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
159 - repeated in the bootmanager to handle all CDs without this operation
160
161 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
162 - Daniel''s update to generalize the kvariant support.
163
164 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
165 - robust to node config file specified with a relative path
166
167 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
168 - fix specfile - 4.2-11 would not build
169
170 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
171 - Added support for handling kernel variants
172 - http://svn.planet-lab.org/wiki/BootcdVariant
173
174 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
175 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
176
177 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
178 - Added kupdate.sh
179
180 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
181 - Use pyplnet.
182 - Add a site_admin account to the BootCD.
183 - Add some explanations for common errors.
184
185 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
186 - Allow multiple -k options to the build.sh script.
187 - Probe devices in PCI bus order.
188
189 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
190 - add support for fedora9 images - compliant with upstart
191 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
192
193 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
194 - cosmetic - pl_boot to display timestamps
195
196 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
197 - adds -k as an argument to build.sh to pass additional kernel parameters to the
198 - bootcd and kexec kernel.
199
200 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
201 - rpm release tag does not need pldistro as it is already part of the rpm name
202
203 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
204 - change location of nodefamily in /etc/planetlab/
205
206 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
207 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
208 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
209 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
210
211 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
212 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
213 - build.sh cleaned up in the process
214 - actual location of selected node config file displayed
215 - import pypci rather than pypciscan
216
217 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
218 - build.sh support for -s <console_spec> (recommended vs using type)
219 - build.sh cleanup - usage clearer wrt types - removed old code
220 - fixed modprobe with args in pl_hwinit
221
222 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
223 - load floppy with modprobe flags
224 - support for creating a usb partition
225 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
226
227 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
228 - added biginitrd usb image
229
230 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
231 - Initial build.
232
233 %define module_current_branch 4.2