fixes harmless error message in logs - somehow the specfile seems to
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 5.0
6 %define taglevel 11
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # structure - this results in 2 packages
13 # bootcd-initscripts - has the plc.d/ scripts
14 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33 # yumdownloader is needed in bootcd-kernel
34 Requires: yum-utils
35 # mkdiskimage is used for USB-partitioned mode
36 # but it now comes in a separate rpm
37 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= 14
38 Requires: syslinux-perl
39 %endif
40
41 Requires: pyplnet
42
43 # 5.0 now has 3-fold nodefamily
44 %define obsolete_nodefamily %{pldistro}-%{_arch}
45 Obsoletes: bootcd-%{obsolete_nodefamily}
46
47 AutoReqProv: no
48 %define debug_package %{nil}
49
50 %description
51 The Boot CD securely boots PlanetLab nodes into an immutable
52 environment. This package is designed to be installed on a MyPLC
53 installation and provide the basics for the PLC to able to compute
54 BootCDs for its attached nodes. 
55 See http://svn.planet-lab.org/wiki/NodeFamily
56
57
58 %package -n bootcd-initscripts
59 Summary: initscripts for the MyPLC installation
60 Group: System Environment/Base
61 %description -n bootcd-initscripts
62 This package contains the init scripts that get fired when the PLC is
63 restarted.
64
65 ### avoid having yum complain about updates, as stuff is moving around
66 # plc.d/bootcd*
67 Conflicts: MyPLC <= 4.3
68
69 %prep
70 %setup -q
71
72 %build
73 [ -d bootcd ] || ln -s BootCD bootcd
74
75 pushd bootcd
76
77 # Build the reference image
78 ./prep.sh %{pldistro} %{nodefamily}
79
80 popd
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 pushd bootcd
86
87 # Install the reference image and build scripts
88 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
89 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
90 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
91 tar cpf - \
92     build/isofs/bootcd.img \
93     build/isofs/kernel \
94     build/passwd \
95     build/version.txt \
96     build/nodefamily \
97     configurations | \
98     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
99
100 for script in bootcd bootcd-kernel; do 
101     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
102 done
103 popd
104     
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(-,root,root,-)
110 %{_datadir}/%{name}
111
112 %files -n bootcd-initscripts
113 %defattr(-,root,root,-)
114 /etc/plc.d
115
116 %changelog
117 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
118 - add requires: to syslinux-perl on fedora14
119
120 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
121 - blacklisted mdules
122 - requires yum-utils for yumdownloader in bootcd-kernel
123
124 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
125 - Handle /dev/rtc name change for newer kernels
126
127 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
128 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
129
130 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
131 - changes for booting off fedora14
132 - displays some sanity checks in case bm can's get downloaded
133 - virtio devices in /dev/vd* also considered
134 - start service rsyslog if found
135 - hack for kernel-firmware with 2.6.32
136 - use $() instead of ``
137
138 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
139 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
140
141 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
142 - remove remainging reference to planet-lab.org
143
144 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
145 - module name changes
146
147 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
148 - nicer initscript now uses 'action' from /etc/init.d/functions
149
150 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
151 - obsolete old bootcd versions
152
153 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
154 - First working version of 5.0:
155 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
156 - nodefamily is 3-fold with pldistro-fcdistro-arch
157 - new module bootcd-inistscripts
158
159 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
160 - support for fedora 12
161
162 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
163 - fix build on fedora12
164
165 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
166 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
167 - repeated in the bootmanager to handle all CDs without this operation
168
169 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
170 - Daniel''s update to generalize the kvariant support.
171
172 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
173 - robust to node config file specified with a relative path
174
175 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
176 - fix specfile - 4.2-11 would not build
177
178 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
179 - Added support for handling kernel variants
180 - http://svn.planet-lab.org/wiki/BootcdVariant
181
182 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
183 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
184
185 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
186 - Added kupdate.sh
187
188 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
189 - Use pyplnet.
190 - Add a site_admin account to the BootCD.
191 - Add some explanations for common errors.
192
193 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
194 - Allow multiple -k options to the build.sh script.
195 - Probe devices in PCI bus order.
196
197 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
198 - add support for fedora9 images - compliant with upstart
199 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
200
201 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
202 - cosmetic - pl_boot to display timestamps
203
204 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
205 - adds -k as an argument to build.sh to pass additional kernel parameters to the
206 - bootcd and kexec kernel.
207
208 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
209 - rpm release tag does not need pldistro as it is already part of the rpm name
210
211 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
212 - change location of nodefamily in /etc/planetlab/
213
214 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
215 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
216 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
217 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
218
219 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
220 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
221 - build.sh cleaned up in the process
222 - actual location of selected node config file displayed
223 - import pypci rather than pypciscan
224
225 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
226 - build.sh support for -s <console_spec> (recommended vs using type)
227 - build.sh cleanup - usage clearer wrt types - removed old code
228 - fixed modprobe with args in pl_hwinit
229
230 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
231 - load floppy with modprobe flags
232 - support for creating a usb partition
233 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
234
235 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
236 - added biginitrd usb image
237
238 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
239 - Initial build.
240
241 %define module_current_branch 4.2