fixed and moved the server-side yum scripts, from nodeconfig/yum to BootstrapFS/nodec...
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 5.0
10 %define taglevel 0
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 # structure - this results in 2 packages
17 # bootcd-initscripts - has the plc.d/ scripts
18 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %(echo %{url} | cut -d ' ' -f 2)
24
25 Summary: Boot CD material for %{nodefamily}
26 Name: %{name}
27 Version: %{version}
28 Release: %{release}
29 License: BSD
30 Group: System Environment/Base
31 Source0: %{name}-%{version}.tar.gz
32 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33 # other archs must be able to install this
34 BuildArch: noarch
35
36 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
37
38 Requires: pyplnet
39
40 AutoReqProv: no
41 %define debug_package %{nil}
42
43 %description
44 The Boot CD securely boots PlanetLab nodes into an immutable
45 environment. This package is designed to be installed on a MyPLC
46 installation and provide the basics for the PLC to able to compute
47 BootCDs for its attached nodes. 
48 See http://svn.planet-lab.org/wiki/NodeFamily
49
50
51 %package -n bootcd-initscripts
52 Summary: initscripts for the MyPLC installation
53 Group: System Environment/Base
54 %description -n bootcd-initscripts
55 This package contains the init scripts that get fired when the PLC is
56 restarted.
57
58 ### avoid having yum complain about updates, as stuff is moving around
59 # plc.d/bootcd*
60 Conflicts: MyPLC <= 4.3
61
62 %prep
63 %setup -q
64
65 %build
66 pushd BootCD
67
68 # Build the reference image
69 ./prep.sh %{pldistro} %{nodefamily}
70
71 popd
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 pushd  BootCD
77
78 # Install the reference image and build scripts
79 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
80 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
81 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
82 tar cpf - \
83     build/isofs/bootcd.img \
84     build/isofs/kernel \
85     build/passwd \
86     build/version.txt \
87     build/nodefamily \
88     configurations | \
89     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
90
91 for script in bootcd bootcd-kernel; do 
92     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
93 done
94 popd
95     
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(-,root,root,-)
101 %{_datadir}/%{name}
102
103 %files -n bootcd-initscripts
104 %defattr(-,root,root,-)
105 /etc/plc.d
106
107 %changelog
108 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
109 - support for fedora 12
110
111 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
112 - fix build on fedora12
113
114 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
115 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
116 - repeated in the bootmanager to handle all CDs without this operation
117
118 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
119 - Daniel''s update to generalize the kvariant support.
120
121 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
122 - robust to node config file specified with a relative path
123
124 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
125 - fix specfile - 4.2-11 would not build
126
127 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
128 - Added support for handling kernel variants
129 - http://svn.planet-lab.org/wiki/BootcdVariant
130
131 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
132 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
133
134 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
135 - Added kupdate.sh
136
137 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
138 - Use pyplnet.
139 - Add a site_admin account to the BootCD.
140 - Add some explanations for common errors.
141
142 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
143 - Allow multiple -k options to the build.sh script.
144 - Probe devices in PCI bus order.
145
146 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
147 - add support for fedora9 images - compliant with upstart
148 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
149
150 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
151 - cosmetic - pl_boot to display timestamps
152
153 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
154 - adds -k as an argument to build.sh to pass additional kernel parameters to the
155 - bootcd and kexec kernel.
156
157 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
158 - rpm release tag does not need pldistro as it is already part of the rpm name
159
160 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
161 - change location of nodefamily in /etc/planetlab/
162
163 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
164 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
165 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
166 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
167
168 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
169 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
170 - build.sh cleaned up in the process
171 - actual location of selected node config file displayed
172 - import pypci rather than pypciscan
173
174 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
175 - build.sh support for -s <console_spec> (recommended vs using type)
176 - build.sh cleanup - usage clearer wrt types - removed old code
177 - fixed modprobe with args in pl_hwinit
178
179 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
180 - load floppy with modprobe flags
181 - support for creating a usb partition
182 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
183
184 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
185 - added biginitrd usb image
186
187 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
188 - Initial build.
189
190 %define module_current_branch 4.2