Setting tag bootcd-5.0-7
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 5.0
6 %define taglevel 7
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # structure - this results in 2 packages
13 # bootcd-initscripts - has the plc.d/ scripts
14 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33
34 Requires: pyplnet
35
36 # 5.0 now has 3-fold nodefamily
37 %define obsolete_nodefamily %{pldistro}-%{_arch}
38 Obsoletes: bootcd-%{obsolete_nodefamily}
39
40 AutoReqProv: no
41 %define debug_package %{nil}
42
43 %description
44 The Boot CD securely boots PlanetLab nodes into an immutable
45 environment. This package is designed to be installed on a MyPLC
46 installation and provide the basics for the PLC to able to compute
47 BootCDs for its attached nodes. 
48 See http://svn.planet-lab.org/wiki/NodeFamily
49
50
51 %package -n bootcd-initscripts
52 Summary: initscripts for the MyPLC installation
53 Group: System Environment/Base
54 %description -n bootcd-initscripts
55 This package contains the init scripts that get fired when the PLC is
56 restarted.
57
58 ### avoid having yum complain about updates, as stuff is moving around
59 # plc.d/bootcd*
60 Conflicts: MyPLC <= 4.3
61
62 %prep
63 %setup -q
64
65 %build
66 [ -d bootcd ] || ln -s BootCD bootcd
67
68 pushd bootcd
69
70 # Build the reference image
71 ./prep.sh %{pldistro} %{nodefamily}
72
73 popd
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 pushd bootcd
79
80 # Install the reference image and build scripts
81 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
82 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
83 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
84 tar cpf - \
85     build/isofs/bootcd.img \
86     build/isofs/kernel \
87     build/passwd \
88     build/version.txt \
89     build/nodefamily \
90     configurations | \
91     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
92
93 for script in bootcd bootcd-kernel; do 
94     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
95 done
96 popd
97     
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(-,root,root,-)
103 %{_datadir}/%{name}
104
105 %files -n bootcd-initscripts
106 %defattr(-,root,root,-)
107 /etc/plc.d
108
109 %changelog
110 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
111 - changes for booting off fedora14
112 - displays some sanity checks in case bm can's get downloaded
113 - virtio devices in /dev/vd* also considered
114 - start service rsyslog if found
115 - hack for kernel-firmware with 2.6.32
116 - use $() instead of ``
117
118 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
119 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
120
121 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
122 - remove remainging reference to planet-lab.org
123
124 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
125 - module name changes
126
127 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
128 - nicer initscript now uses 'action' from /etc/init.d/functions
129
130 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
131 - obsolete old bootcd versions
132
133 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
134 - First working version of 5.0:
135 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
136 - nodefamily is 3-fold with pldistro-fcdistro-arch
137 - new module bootcd-inistscripts
138
139 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
140 - support for fedora 12
141
142 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
143 - fix build on fedora12
144
145 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
146 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
147 - repeated in the bootmanager to handle all CDs without this operation
148
149 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
150 - Daniel''s update to generalize the kvariant support.
151
152 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
153 - robust to node config file specified with a relative path
154
155 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
156 - fix specfile - 4.2-11 would not build
157
158 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
159 - Added support for handling kernel variants
160 - http://svn.planet-lab.org/wiki/BootcdVariant
161
162 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
163 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
164
165 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
166 - Added kupdate.sh
167
168 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
169 - Use pyplnet.
170 - Add a site_admin account to the BootCD.
171 - Add some explanations for common errors.
172
173 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
174 - Allow multiple -k options to the build.sh script.
175 - Probe devices in PCI bus order.
176
177 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
178 - add support for fedora9 images - compliant with upstart
179 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
180
181 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
182 - cosmetic - pl_boot to display timestamps
183
184 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
185 - adds -k as an argument to build.sh to pass additional kernel parameters to the
186 - bootcd and kexec kernel.
187
188 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
189 - rpm release tag does not need pldistro as it is already part of the rpm name
190
191 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
192 - change location of nodefamily in /etc/planetlab/
193
194 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
195 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
196 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
197 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
198
199 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
200 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
201 - build.sh cleaned up in the process
202 - actual location of selected node config file displayed
203 - import pypci rather than pypciscan
204
205 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
206 - build.sh support for -s <console_spec> (recommended vs using type)
207 - build.sh cleanup - usage clearer wrt types - removed old code
208 - fixed modprobe with args in pl_hwinit
209
210 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
211 - load floppy with modprobe flags
212 - support for creating a usb partition
213 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
214
215 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
216 - added biginitrd usb image
217
218 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
219 - Initial build.
220
221 %define module_current_branch 4.2