symlinks should point into install image not rpm build image
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 5.0
6 %define taglevel 11
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # structure - this results in 2 packages
13 # bootcd-initscripts - has the plc.d/ scripts
14 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33 # yumdownloader is needed in bootcd-kernel
34 Requires: yum-utils
35 # mkdiskimage is used for USB-partitioned mode
36 # but it now comes in a separate rpm
37 Requires: syslinux-perl
38
39 Requires: pyplnet
40
41 # 5.0 now has 3-fold nodefamily
42 %define obsolete_nodefamily %{pldistro}-%{_arch}
43 Obsoletes: bootcd-%{obsolete_nodefamily}
44
45 AutoReqProv: no
46 %define debug_package %{nil}
47
48 %description
49 The Boot CD securely boots PlanetLab nodes into an immutable
50 environment. This package is designed to be installed on a MyPLC
51 installation and provide the basics for the PLC to able to compute
52 BootCDs for its attached nodes. 
53 See http://svn.planet-lab.org/wiki/NodeFamily
54
55
56 %package -n bootcd-initscripts
57 Summary: initscripts for the MyPLC installation
58 Group: System Environment/Base
59 %description -n bootcd-initscripts
60 This package contains the init scripts that get fired when the PLC is
61 restarted.
62
63 ### avoid having yum complain about updates, as stuff is moving around
64 # plc.d/bootcd*
65 Conflicts: MyPLC <= 4.3
66
67 %prep
68 %setup -q
69
70 %build
71 [ -d bootcd ] || ln -s BootCD bootcd
72
73 pushd bootcd
74
75 # Build the reference image
76 ./prep.sh %{pldistro} %{nodefamily}
77
78 popd
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 pushd bootcd
84
85 # Install the reference image and build scripts
86 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
87 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
88 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
89 tar cpf - \
90     build/isofs/bootcd.img \
91     build/isofs/kernel \
92     build/passwd \
93     build/version.txt \
94     build/nodefamily \
95     configurations | \
96     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
97
98 for script in bootcd bootcd-kernel; do 
99     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
100 done
101
102 #systemd files
103 mkdir -p $RPM_BUILD_ROOT/lib/systemd/system
104 mkdir -p $RPM_BUILD_ROOT/etc/systemd/system
105 cp -pr systemd/* $RPM_BUILD_ROOT/lib/systemd/system
106 ln -sf /lib/systemd/system/pl_boot.target $RPM_BUILD_ROOT/etc/systemd/system/default.target
107 mkdir -p $RPM_BUILD_ROOT/lib/systemd/system/pl_boot.target.wants
108 mkdir -p $RPM_BUILD_ROOT/lib/systemd/system/pl_sysinit.target.wants
109 ln -sf /lib/systemd/system/pl_boot.service $RPM_BUILD_ROOT/lib/systemd/system/pl_boot.target.wants/pl_boot.service
110 ln -sf /lib/systemd/system/pl_sysinit.service $RPM_BUILD_ROOT/lib/systemd/system/pl_sysinit.target.wants/pl_sysinit.service
111 popd
112     
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 %{_datadir}/%{name}
119
120 %files -n bootcd-initscripts
121 %defattr(-,root,root,-)
122 /etc/plc.d
123 /lib/systemd/system
124 /etc/systemd/system
125
126 %changelog
127 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
128 - add requires: to syslinux-perl on fedora14
129
130 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
131 - blacklisted mdules
132 - requires yum-utils for yumdownloader in bootcd-kernel
133
134 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
135 - Handle /dev/rtc name change for newer kernels
136
137 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
138 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
139
140 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
141 - changes for booting off fedora14
142 - displays some sanity checks in case bm can's get downloaded
143 - virtio devices in /dev/vd* also considered
144 - start service rsyslog if found
145 - hack for kernel-firmware with 2.6.32
146 - use $() instead of ``
147
148 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
149 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
150
151 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
152 - remove remainging reference to planet-lab.org
153
154 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
155 - module name changes
156
157 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
158 - nicer initscript now uses 'action' from /etc/init.d/functions
159
160 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
161 - obsolete old bootcd versions
162
163 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
164 - First working version of 5.0:
165 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
166 - nodefamily is 3-fold with pldistro-fcdistro-arch
167 - new module bootcd-inistscripts
168
169 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
170 - support for fedora 12
171
172 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
173 - fix build on fedora12
174
175 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
176 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
177 - repeated in the bootmanager to handle all CDs without this operation
178
179 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
180 - Daniel''s update to generalize the kvariant support.
181
182 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
183 - robust to node config file specified with a relative path
184
185 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
186 - fix specfile - 4.2-11 would not build
187
188 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
189 - Added support for handling kernel variants
190 - http://svn.planet-lab.org/wiki/BootcdVariant
191
192 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
193 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
194
195 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
196 - Added kupdate.sh
197
198 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
199 - Use pyplnet.
200 - Add a site_admin account to the BootCD.
201 - Add some explanations for common errors.
202
203 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
204 - Allow multiple -k options to the build.sh script.
205 - Probe devices in PCI bus order.
206
207 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
208 - add support for fedora9 images - compliant with upstart
209 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
210
211 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
212 - cosmetic - pl_boot to display timestamps
213
214 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
215 - adds -k as an argument to build.sh to pass additional kernel parameters to the
216 - bootcd and kexec kernel.
217
218 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
219 - rpm release tag does not need pldistro as it is already part of the rpm name
220
221 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
222 - change location of nodefamily in /etc/planetlab/
223
224 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
225 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
226 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
227 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
228
229 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
230 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
231 - build.sh cleaned up in the process
232 - actual location of selected node config file displayed
233 - import pypci rather than pypciscan
234
235 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
236 - build.sh support for -s <console_spec> (recommended vs using type)
237 - build.sh cleanup - usage clearer wrt types - removed old code
238 - fixed modprobe with args in pl_hwinit
239
240 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
241 - load floppy with modprobe flags
242 - support for creating a usb partition
243 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
244
245 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
246 - added biginitrd usb image
247
248 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
249 - Initial build.
250
251 %define module_current_branch 4.2