Setting tag BootCD-5.0-3
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 5.0
10 %define taglevel 3
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 # structure - this results in 2 packages
17 # bootcd-initscripts - has the plc.d/ scripts
18 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %(echo %{url} | cut -d ' ' -f 2)
24
25 Summary: Boot CD material for %{nodefamily}
26 Name: %{name}
27 Version: %{version}
28 Release: %{release}
29 License: BSD
30 Group: System Environment/Base
31 Source0: %{name}-%{version}.tar.gz
32 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33 # other archs must be able to install this
34 BuildArch: noarch
35
36 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
37
38 Requires: pyplnet
39
40 # 5.0 now has 3-fold nodefamily
41 %define obsolete_nodefamily %{pldistro}-%{_arch}
42 Obsoletes: bootcd-%{obsolete_nodefamily}
43
44 AutoReqProv: no
45 %define debug_package %{nil}
46
47 %description
48 The Boot CD securely boots PlanetLab nodes into an immutable
49 environment. This package is designed to be installed on a MyPLC
50 installation and provide the basics for the PLC to able to compute
51 BootCDs for its attached nodes. 
52 See http://svn.planet-lab.org/wiki/NodeFamily
53
54
55 %package -n bootcd-initscripts
56 Summary: initscripts for the MyPLC installation
57 Group: System Environment/Base
58 %description -n bootcd-initscripts
59 This package contains the init scripts that get fired when the PLC is
60 restarted.
61
62 ### avoid having yum complain about updates, as stuff is moving around
63 # plc.d/bootcd*
64 Conflicts: MyPLC <= 4.3
65
66 %prep
67 %setup -q
68
69 %build
70 pushd BootCD
71
72 # Build the reference image
73 ./prep.sh %{pldistro} %{nodefamily}
74
75 popd
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 pushd  BootCD
81
82 # Install the reference image and build scripts
83 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
84 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
85 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
86 tar cpf - \
87     build/isofs/bootcd.img \
88     build/isofs/kernel \
89     build/passwd \
90     build/version.txt \
91     build/nodefamily \
92     configurations | \
93     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
94
95 for script in bootcd bootcd-kernel; do 
96     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
97 done
98 popd
99     
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(-,root,root,-)
105 %{_datadir}/%{name}
106
107 %files -n bootcd-initscripts
108 %defattr(-,root,root,-)
109 /etc/plc.d
110
111 %changelog
112 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
113 - nicer initscript now uses 'action' from /etc/init.d/functions
114
115 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
116 - obsolete old bootcd versions
117
118 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
119 - First working version of 5.0:
120 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
121 - nodefamily is 3-fold with pldistro-fcdistro-arch
122 - new module bootcd-inistscripts
123
124 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
125 - support for fedora 12
126
127 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
128 - fix build on fedora12
129
130 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
131 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
132 - repeated in the bootmanager to handle all CDs without this operation
133
134 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
135 - Daniel''s update to generalize the kvariant support.
136
137 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
138 - robust to node config file specified with a relative path
139
140 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
141 - fix specfile - 4.2-11 would not build
142
143 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
144 - Added support for handling kernel variants
145 - http://svn.planet-lab.org/wiki/BootcdVariant
146
147 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
148 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
149
150 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
151 - Added kupdate.sh
152
153 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
154 - Use pyplnet.
155 - Add a site_admin account to the BootCD.
156 - Add some explanations for common errors.
157
158 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
159 - Allow multiple -k options to the build.sh script.
160 - Probe devices in PCI bus order.
161
162 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
163 - add support for fedora9 images - compliant with upstart
164 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
165
166 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
167 - cosmetic - pl_boot to display timestamps
168
169 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
170 - adds -k as an argument to build.sh to pass additional kernel parameters to the
171 - bootcd and kexec kernel.
172
173 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
174 - rpm release tag does not need pldistro as it is already part of the rpm name
175
176 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
177 - change location of nodefamily in /etc/planetlab/
178
179 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
180 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
181 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
182 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
183
184 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
185 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
186 - build.sh cleaned up in the process
187 - actual location of selected node config file displayed
188 - import pypci rather than pypciscan
189
190 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
191 - build.sh support for -s <console_spec> (recommended vs using type)
192 - build.sh cleanup - usage clearer wrt types - removed old code
193 - fixed modprobe with args in pl_hwinit
194
195 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
196 - load floppy with modprobe flags
197 - support for creating a usb partition
198 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
199
200 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
201 - added biginitrd usb image
202
203 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
204 - Initial build.
205
206 %define module_current_branch 4.2