Setting tag BootCD-4.2-15
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 4.2
10 %define taglevel 15
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33
34 Requires: pyplnet
35
36 AutoReqProv: no
37 %define debug_package %{nil}
38
39 %description
40 The Boot CD securely boots PlanetLab nodes into an immutable
41 environment.
42
43 %prep
44 %setup -q
45
46 %build
47 pushd BootCD
48
49 # Build the reference image
50 ./prep.sh %{pldistro} %{nodefamily}
51
52 popd
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 pushd  BootCD
58
59 # Install the reference image and build scripts
60 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
61 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
62 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
63 tar cpf - \
64     build/isofs/bootcd.img \
65     build/isofs/kernel \
66     build/passwd \
67     build/version.txt \
68     build/nodefamily \
69     configurations | \
70     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
71
72 popd
73     
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 # If run under sudo
78 if [ -n "$SUDO_USER" ] ; then
79     # Allow user to delete the build directory
80     chown -h -R $SUDO_USER .
81     # Some temporary cdroot files like /var/empty/sshd and
82     # /usr/bin/sudo get created with non-readable permissions.
83     find . -not -perm +0600 -exec chmod u+rw {} \;
84     # Allow user to delete the built RPM(s)
85     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
86 fi
87
88 %files
89 %defattr(-,root,root,-)
90 %{_datadir}/%{name}
91
92 %post
93 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
94
95 %changelog
96 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
97 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
98 - repeated in the bootmanager to handle all CDs without this operation
99
100 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
101 - Daniel's update to generalize the kvariant support.
102
103 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
104 - robust to node config file specified with a relative path
105
106 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
107 - fix specfile - 4.2-11 would not build
108
109 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
110 - Added support for handling kernel variants
111 - http://svn.planet-lab.org/wiki/BootcdVariant
112
113 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
114 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
115
116 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
117 - Added kupdate.sh
118
119 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
120 - Use pyplnet.
121 - Add a site_admin account to the BootCD.
122 - Add some explanations for common errors.
123
124 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
125 - Allow multiple -k options to the build.sh script.
126 - Probe devices in PCI bus order.
127
128 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
129 - add support for fedora9 images - compliant with upstart
130 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
131
132 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
133 - cosmetic - pl_boot to display timestamps
134
135 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
136 - adds -k as an argument to build.sh to pass additional kernel parameters to the
137 - bootcd and kexec kernel.
138
139 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
140 - rpm release tag does not need pldistro as it is already part of the rpm name
141
142 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
143 - change location of nodefamily in /etc/planetlab/
144
145 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
146 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
147 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
148 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
149
150 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
151 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
152 - build.sh cleaned up in the process
153 - actual location of selected node config file displayed
154 - import pypci rather than pypciscan
155
156 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
157 - build.sh support for -s <console_spec> (recommended vs using type)
158 - build.sh cleanup - usage clearer wrt types - removed old code
159 - fixed modprobe with args in pl_hwinit
160
161 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
162 - load floppy with modprobe flags
163 - support for creating a usb partition
164 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
165
166 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
167 - added biginitrd usb image
168
169 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
170 - Initial build.
171
172 %define module_current_branch 3.4