Don't depend on pyplnet.
[bootcd.git] / bootcd.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define nodefamily %{pldistro}-%{_arch}
7
8 %define name bootcd-%{nodefamily}
9 %define version 4.2
10 %define taglevel 9
11
12 # pldistro already in the rpm name
13 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14 %define release %{taglevel}%{?date:.%{date}}
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %(echo %{url} | cut -d ' ' -f 2)
20
21 Summary: Boot CD material for %{nodefamily}
22 Name: %{name}
23 Version: %{version}
24 Release: %{release}
25 License: BSD
26 Group: System Environment/Base
27 Source0: %{name}-%{version}.tar.gz
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 # other archs must be able to install this
30 BuildArch: noarch
31
32 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
33
34 AutoReqProv: no
35 %define debug_package %{nil}
36
37 %description
38 The Boot CD securely boots PlanetLab nodes into an immutable
39 environment.
40
41 %prep
42 %setup -q
43
44 %build
45 pushd BootCD
46
47 # Build the reference image
48 ./prep.sh %{pldistro} %{nodefamily}
49
50 popd
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 pushd  BootCD
56
57 # Install the reference image and build scripts
58 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
59 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
60 install -m 755 kupdate.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
61 tar cpf - \
62     build/isofs/bootcd.img \
63     build/isofs/kernel \
64     build/passwd \
65     build/version.txt \
66     build/nodefamily \
67     configurations | \
68     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
69
70 popd
71     
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 # If run under sudo
76 if [ -n "$SUDO_USER" ] ; then
77     # Allow user to delete the build directory
78     chown -h -R $SUDO_USER .
79     # Some temporary cdroot files like /var/empty/sshd and
80     # /usr/bin/sudo get created with non-readable permissions.
81     find . -not -perm +0600 -exec chmod u+rw {} \;
82     # Allow user to delete the built RPM(s)
83     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
84 fi
85
86 %files
87 %defattr(-,root,root,-)
88 %{_datadir}/%{name}
89
90 %post
91 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
92
93 %changelog
94 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
95 - Added kupdate.sh
96
97 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
98 - Use pyplnet.
99 - Add a site_admin account to the BootCD.
100 - Add some explanations for common errors.
101
102 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
103 - Allow multiple -k options to the build.sh script.
104 - Probe devices in PCI bus order.
105
106 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
107 - add support for fedora9 images - compliant with upstart
108 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
109
110 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
111 - cosmetic - pl_boot to display timestamps
112
113 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
114 - adds -k as an argument to build.sh to pass additional kernel parameters to the
115 - bootcd and kexec kernel.
116
117 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
118 - rpm release tag does not need pldistro as it is already part of the rpm name
119
120 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
121 - change location of nodefamily in /etc/planetlab/
122
123 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
124 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
125 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
126 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
127
128 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
129 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
130 - build.sh cleaned up in the process
131 - actual location of selected node config file displayed
132 - import pypci rather than pypciscan
133
134 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
135 - build.sh support for -s <console_spec> (recommended vs using type)
136 - build.sh cleanup - usage clearer wrt types - removed old code
137 - fixed modprobe with args in pl_hwinit
138
139 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
140 - load floppy with modprobe flags
141 - support for creating a usb partition
142 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
143
144 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
145 - added biginitrd usb image
146
147 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
148 - Initial build.
149
150 %define module_current_branch 3.4