syslinux-3.08-2 sources from FC4
[bootcd.git] / syslinux / syslinux.spec
1 # -*- rpm -*-
2 %define RPMVERSION 3.08
3 %define VERSION    3.08
4 Summary: Kernel loader which uses a FAT or iso9660 filesystem or a PXE network
5 Name: syslinux
6 Version: %{RPMVERSION}
7 Release: 1
8 License: GPL
9 Group: Applications/System
10 Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{VERSION}.tar.gz
11 ExclusiveArch: i386 x86_64
12 Packager: H. Peter Anvin <hpa@zytor.com>
13 Buildroot: %{_tmppath}/%{name}-%{VERSION}-root
14 BuildPrereq: nasm >= 0.98.38, perl
15 Autoreq: 0
16 %ifarch i386
17 Requires: mtools, libc.so.6
18 %endif
19 %ifarch x86_64
20 Requires: mtools, libc.so.6()(64bit)
21 %endif
22
23 # NOTE: extlinux belongs in /sbin, not in /usr/sbin, since it is typically
24 # a system bootloader, and may be necessary for system recovery.
25 %define _sbindir /sbin
26
27 %package devel
28 Summary: Development environment for SYSLINUX add-on modules
29 Group: Development/Libraries
30
31 %description
32 SYSLINUX is a suite of bootloaders, currently supporting DOS FAT
33 filesystems, Linux ext2/ext3 filesystems (EXTLINUX), PXE network boots
34 (PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX).  It also includes a tool,
35 MEMDISK, which loads legacy operating systems from these media.
36
37 %description devel
38 The SYSLINUX boot loader contains an API, called COM32, for writing
39 sophisticated add-on modules.  This package contains the libraries
40 necessary to compile such modules.
41
42 %prep
43 %setup -q -n syslinux-%{VERSION}
44
45 %build
46 make clean
47 make installer
48 make -C sample tidy
49
50 %install
51 rm -rf %{buildroot}
52 mkdir -p %{buildroot}%{_bindir}
53 mkdir -p %{buildroot}%{_sbindir}
54 mkdir -p %{buildroot}%{_libdir}/syslinux
55 mkdir -p %{buildroot}%{_includedir}
56 make install-all \
57         INSTALLROOT=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_sbindir} \
58         LIBDIR=%{_libdir} INCDIR=%{_includedir}
59 make -C sample tidy
60 cp mkdiskimage sys2ansi.pl keytab-lilo.pl %{buildroot}%{_libdir}/syslinux
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %doc NEWS README* *.doc memdisk/*.doc COPYING
68 %doc sample
69 %{_bindir}/syslinux
70 %{_sbindir}/extlinux
71 %{_bindir}/ppmtolss16
72 %{_bindir}/lss16toppm
73 %{_bindir}/gethostip
74 %{_libdir}/syslinux/*.com
75 %{_libdir}/syslinux/*.exe
76 %{_libdir}/syslinux/*.c32
77 %{_libdir}/syslinux/*.bin
78 %{_libdir}/syslinux/*.0
79 %{_libdir}/syslinux/memdisk
80 %{_libdir}/syslinux/*.pl
81 %{_libdir}/syslinux/mkdiskimage
82
83 %files devel
84 %{_libdir}/syslinux/com32
85
86 %post
87
88 %postun
89
90 %changelog
91 * Thu Dec 30 2004 H. Peter Anvin <hpa@zytor.com>
92 - libsyslinux dropped in syslinux 3.00.
93 - Additional documentation.
94 - Add extlinux.
95
96 * Tue Dec 14 2004 H. Peter Anvin <hpa@zytor.com>
97 - Add a devel package for the com32 library added in 2.12.
98
99 * Wed Apr 16 2003 H. Peter Anvin <hpa@zytor.com> 2.04-1
100 - 2.04 release
101 - Add support for libsyslinux.so*
102 - Templatize for inclusion in CVS tree
103
104 * Thu Apr 10 2003 H. Peter Anvin <hpa@zytor.com>
105 - 2.03 release
106 - Add support for libsyslinux.a
107 - Add keytab-lilo.pl to the /usr/lib/syslinux directory
108 - Modernize syntax
109 - Support building on x86-64
110
111 * Thu Feb 13 2003 H. Peter Anvin <hpa@zytor.com>
112 - 2.02 release; no longer setuid
113
114 * Thu Jan 30 2003 H. Peter Anvin <hpa@zytor.com>
115 - Prepare for 2.01 release; make /usr/bin/syslinux setuid root
116
117 * Fri Oct 25 2002 H. Peter Anvin <hpa@zytor.com>
118 - Upgrade to 2.00.
119
120 * Tue Aug 27 2002 H. Peter Anvin <hpa@zytor.com>
121 - Upgrade to 1.76.
122
123 * Fri Jun 14 2002 H. Peter Anvin <hpa@zytor.com>
124 - Upgrade to 1.75.
125
126 * Sat Jun  1 2002 H. Peter Anvin <hpa@zytor.com>
127 - Upgrade to 1.74.
128
129 * Sun May 26 2002 H. Peter Anvin <hpa@zytor.com>
130 - Upgrade to 1.73.
131
132 * Tue Apr 23 2002 H. Peter Anvin <hpa@zytor.com>
133 - Upgrade to 1.72.
134
135 * Wed Apr 17 2002 H. Peter Anvin <hpa@zytor.com>
136 - Upgrade to 1.71.
137 - Update the title.
138
139 * Wed Apr 17 2002 H. Peter Anvin <hpa@zytor.com>
140 - Upgrade to 1.70.
141
142 * Sat Feb  3 2002 H. Peter Anvin <hpa@zytor.com>
143 - Upgrade to 1.67.
144
145 * Tue Jan  1 2002 H. Peter Anvin <hpa@zytor.com>
146 - Upgrade to 1.66.
147
148 * Sat Dec 15 2001 H. Peter Anvin <hpa@zytor.com>
149 - Upgrade to 1.65; make appropriate changes.
150
151 * Sat Aug 24 2001 H. Peter Anvin <hpa@zytor.com>
152 - Upgrade to 1.64.
153
154 * Mon Aug  6 2001 H. Peter Anvin <hpa@zytor.com>
155 - Upgrade to 1.63.
156 - Use make install since the stock SYSLINUX distribution now supports
157   INSTALLROOT.
158
159 * Sat Apr 24 2001 H. Peter Anvin <hpa@zytor.com>
160 - Upgrade to 1.62.
161
162 * Sat Apr 14 2001 H. Peter Anvin <hpa@zytor.com>
163 - Fix missing %files; correct modes.
164
165 * Fri Apr 13 2001 H. Peter Anvin <hpa@zytor.com>
166 - Upgrade to 1.61
167 - Install auxilliary programs in /usr/lib/syslinux
168
169 * Sat Feb 10 2001 Matt Wilson <msw@redhat.com>
170 - 1.52
171
172 * Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
173 - 1.51pre7
174
175 * Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
176 - 1.51pre5
177
178 * Fri Jan 19 2001 Matt Wilson <msw@redhat.com>
179 - 1.51pre3, with e820 detection
180
181 * Tue Dec 12 2000 Than Ngo <than@redhat.com>
182 - rebuilt with fixed fileutils
183
184 * Thu Nov 9 2000 Than Ngo <than@redhat.com>
185 - update to 1.49
186 - update ftp site
187 - clean up specfile
188 - add some useful documents
189
190 * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
191 - add %%defattr (release 4)
192
193 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
194 - automatic rebuild
195
196 * Thu Jul 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
197 - use %%{_tmppath}
198 - change application group (Applications/Internet doesn't seem
199   right to me)
200 - added BuildRequires
201
202 * Tue Apr 04 2000 Erik Troan <ewt@redhat.com>
203 - initial packaging