Setting tag bootmanager-5.3-3
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.3
4 %define taglevel 3
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 # in theory this should be a noarch rpm
22 # however because of libc-opendir-hack (which apparently targets f12 bootCDs)
23 # this is not true anymore and fedora23 won't let us build this as noarch anymore
24 # BuildArch: noarch
25
26 Requires: tar, gnupg, sharutils, bzip2
27 # need the apache user at install-time
28 Requires: httpd 
29
30 Requires: plcapi >= 5.2
31 # we need to install these on the myplc side too, although this is suboptimal
32 # b/c this python code gets shipped on the nodes as well
33 Requires: pypcilib pyplnet
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 %files
80 %defattr(-,root,root,-)
81 %{_datadir}/%{name}
82 /var/www/html/boot/index.php
83 /var/www/html/boot/upload-bmlog.php
84 /var/www/html/boot/getnodeid.php
85 /etc/plc.d/bootmanager
86
87 %changelog
88 * Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-3
89 - patch for f23 as of dec. 2015 where kernel and initrd show up in
90 - a new location under /boot
91 - plus bugfix with format and single { and } for awk args
92
93 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-2
94 - not a noarch package anymore (indeed it does come with binaries)
95 - fix ssl connection for runlevelagent for recent pythons
96 - for fedora23, ignore if rsa1 key generation fails
97
98 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
99 - Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
100 - Can implement 'upgrade' in addition to 'reinstall' boot state
101 - upgrade does essentially the same as reinstall except that slices are preserved
102 - upgrade works only on nodes already running containers
103 - because /vservers/ needs to be a btrfs filesystem
104 - pycurl is now a strong requirement (old curl-based code removed)
105 - bugfix for ssh key generation (were all typed rsa1)
106 - a lot of prettification
107
108 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
109 - runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
110 - introduces the ONE_PARTITION configuration variable
111 - some suport for chainbooting ubuntu
112
113 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
114 - no functional change, only tweaks in Makefile for interating with test environment
115
116 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
117 - some old f18 bootCDs do not support mkfs.btrfs -f
118 - so invoke this option only when supported
119
120 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
121 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
122 - smarter for locating initrd, for f20
123 - add -f to mkfs.btrfs - sometimes hangs otherwise
124
125 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
126 - merged the branches for vserver and lxc
127 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
128 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
129 - also note that fsck management for btrfs/lxc is still weak
130 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
131 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
132 - expects ntpd to be turned on in the nodeimage
133
134 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
135 - fix for heterogeneous bootimage/nodeimage
136
137 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
138 - Turn off WriteModprobeConfig for f18
139 - enable btrfs quota
140 - fix very old ssh DSA key generation
141
142 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
143 - run parted with --script to keep it from hanging
144
145 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
146 - run parted with --script to avoid it to hang
147
148 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
149 - pour the 5.0-22 and 5.0-23 features into the lxc mix
150
151 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
152 - added support for disks larger than 2Tb using gpt instead of msdos
153
154 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
155 - bootmanager log clearly states duration of download and extraction of node image
156
157 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
158 - first working draft for dealing with f16 nodes
159 - not expected to work with mainline nodes (use 5.0 for that for now)
160
161 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
162 - no significant change, just checkpoint as 5.1 is addressing lxc
163
164 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
165 - be more explicit on the node conf_file actually used
166 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
167
168 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
169 - nicer log - was intended for previous tag
170
171 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
172 - {Start,Stop,}RunLevelAgent now ship with bootmanager
173 - new UpdateLastBootOnce
174 - root_size bumped to 14Gb which is more in line with modern h/w
175 - more safely tries to umount /dev/ and /sys
176 - support for raid partitions
177 - mkswap -f
178 - blacklist files from /etc/modprobe.conf/* instead
179
180 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
181 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
182
183 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
184 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
185 - fix for chosing version of parted - for f14
186 - added support for virtio deveices in /dev/vd
187 - fixed scanning of new disks
188 - slightly reviewed logs - default mode is verbose
189 - removed deprecated mkinitrd.sh
190
191 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
192 - Fix problems caused by shell redirection
193
194 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
195 - tag 5.0-13 is broken
196
197 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
198 - Add support for uploading bash_history to a central server for failboot nodes.
199 - Start to use subprocess instead of deprecated popen2 module
200 - Fix typo for VSERVERS_SIZE
201 - Add --allow-missing parameter to support different kernel configs with mkinitrd
202
203 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
204 - Revert "replace deprecated popen2 with subprocess"
205
206 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
207 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
208
209 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
210 - Fix typo
211
212 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
213 - fix typo
214
215 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
216 - disable time/count based filesystem checks
217
218 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
219 - Fix new disk additions to LVM array
220
221 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
222 - bugfix for centos5/python2.4 missing hashlib
223
224 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
225 - check sha1sum of downloaded bootstrapfs
226 - try recovering filesystem errors
227
228 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
229 - nicer initscript now uses 'action' from /etc/init.d/functions
230 - bugfix for nodes with extensions
231
232 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
233 - create /etc/planetlab if missing
234 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
235
236 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
237 - caglar's change to run MkInitrd right before kexec
238 - plus clean up old code
239
240 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
241 - first working version of 5.0:
242 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
243 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
244 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
245
246 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
247 - support for fedora 12
248
249 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
250 - - support for when the node is behind a NAT
251 - - clean up RUN_LEVEL support
252 - - support for early sshd
253
254 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
255 - Add NAT model option for nodes which don't resolve properly.
256
257 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
258 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
259 - BootServerRequest takes the 'VARS' variable to read these values.
260 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
261 - (or any other interface that accepts a POST file)
262 - build.sh bundles cacerts for boot and monitor servers (if present) to
263 - authenticate the UPLOAD_LOG_SCRIPT.
264 - Previously, these certs were re-used from the bootcd, now they are bundled
265 - with BM.  This allows the BM to point to a completely different myplc if
266 - desired, and it is still secure, because the original download is
267 - authenticated.
268
269 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
270 - raise a single exception for nodes with authentication errors
271 - fix syntax error in MakeInitrd.py
272
273 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
274 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
275 - Removed failboot and install from forced states.
276 - Removed checks for initrd in Validate
277 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
278 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
279
280 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
281 - Special handling for "forcedeth" ethernet NIC.
282
283 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
284 - include a fix for public pl dealing with old/new boot images and root
285 - environments
286
287 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
288 - review selection nodefamily at bootstrapfs install-time
289 - now based on (1) tags (2) nodefamily and (3) defaults
290 - this is required on very old bootcd
291
292 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
293 - Use modprobe module to write out /etc/modprobe.conf.
294
295 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
296 - minor updates - using the new modprobe module *not* in this tag
297
298 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
299 - load device mapper if needed, for centos5-based bootcd variant
300
301 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
302 - renumbered 4.3
303 - New step StartRunLevelAgent
304 - various other tweaks
305
306 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
307 - most of the actual network config job moved to (py)plnet
308 - support for RAWDISK
309 - network interfaces deterministically sorted
310 - does not use nodegroups anymore for getting node arch and other extensions
311 - drop yum-based extensions
312 - debug sshd started as early as possible
313 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
314 - cleaned up (drop support for bootcdv2)
315 - still needs testing
316
317 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
318 - reflects new names from the data model
319
320 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
321 - dont unload cpqphp
322
323 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
324 - changes in the state automaton logic 
325 - root+swap = 7G
326 - usb-key threshhold increased to 17 G
327 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
328
329 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
330 - renamed step InstallBootstrapRPM into InstallBootstrapFS
331 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
332 - import pypcimap rather than pypciscan
333 - initial downlaoding of plc_config made more robust
334 - root and /vservers file systems mounted ext3
335 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
336 - also seems to be using session-based authentication rather than former hmac-based one
337
338 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
339 - usage of wireless attributes fixed and tested
340 - breakpoints cleaned up (no change for production)
341 - less alarming message when floppy does not get unloaded
342
343 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
344 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
345 - removes legacy calls to PlanetLabConf.py 
346 - refrains from unloading floppy 
347 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
348
349 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
350 - Initial build.
351