Thomas's fix about calling mkfs.btrfs with the -f option
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.2
4 %define taglevel 1
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: plcapi >= 5.2
28 # we need to install these on the myplc side too, although this is suboptimal
29 # b/c this python code gets shipped on the nodes as well
30 Requires: pypcilib pyplnet
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
63
64 # formerly in the MyPLC module
65 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 # initialize the boot manager upload area
72 mkdir -p /var/log/bm
73 chown apache:apache /var/log/bm
74 chmod 700 /var/log/bm
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 /var/www/html/boot/index.php
80 /var/www/html/boot/upload-bmlog.php
81 /var/www/html/boot/getnodeid.php
82 /etc/plc.d/bootmanager
83
84 %changelog
85 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
86 - merged the branches for vserver and lxc
87 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
88 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
89 - also note that fsck management for btrfs/lxc is still weak
90 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
91 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
92 - expects ntpd to be turned on in the nodeimage
93
94 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
95 - fix for heterogeneous bootimage/nodeimage
96
97 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
98 - Turn off WriteModprobeConfig for f18
99 - enable btrfs quota
100 - fix very old ssh DSA key generation
101
102 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
103 - run parted with --script to keep it from hanging
104
105 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
106 - run parted with --script to avoid it to hang
107
108 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
109 - pour the 5.0-22 and 5.0-23 features into the lxc mix
110
111 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
112 - added support for disks larger than 2Tb using gpt instead of msdos
113
114 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
115 - bootmanager log clearly states duration of download and extraction of node image
116
117 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
118 - first working draft for dealing with f16 nodes
119 - not expected to work with mainline nodes (use 5.0 for that for now)
120
121 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
122 - no significant change, just checkpoint as 5.1 is addressing lxc
123
124 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
125 - be more explicit on the node conf_file actually used
126 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
127
128 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
129 - nicer log - was intended for previous tag
130
131 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
132 - {Start,Stop,}RunLevelAgent now ship with bootmanager
133 - new UpdateLastBootOnce
134 - root_size bumped to 14Gb which is more in line with modern h/w
135 - more safely tries to umount /dev/ and /sys
136 - support for raid partitions
137 - mkswap -f
138 - blacklist files from /etc/modprobe.conf/* instead
139
140 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
141 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
142
143 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
144 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
145 - fix for chosing version of parted - for f14
146 - added support for virtio deveices in /dev/vd
147 - fixed scanning of new disks
148 - slightly reviewed logs - default mode is verbose
149 - removed deprecated mkinitrd.sh
150
151 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
152 - Fix problems caused by shell redirection
153
154 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
155 - tag 5.0-13 is broken
156
157 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
158 - Add support for uploading bash_history to a central server for failboot nodes.
159 - Start to use subprocess instead of deprecated popen2 module
160 - Fix typo for VSERVERS_SIZE
161 - Add --allow-missing parameter to support different kernel configs with mkinitrd
162
163 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
164 - Revert "replace deprecated popen2 with subprocess"
165
166 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
167 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
168
169 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
170 - Fix typo
171
172 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
173 - fix typo
174
175 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
176 - disable time/count based filesystem checks
177
178 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
179 - Fix new disk additions to LVM array
180
181 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
182 - bugfix for centos5/python2.4 missing hashlib
183
184 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
185 - check sha1sum of downloaded bootstrapfs
186 - try recovering filesystem errors
187
188 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
189 - nicer initscript now uses 'action' from /etc/init.d/functions
190 - bugfix for nodes with extensions
191
192 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
193 - create /etc/planetlab if missing
194 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
195
196 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
197 - caglar's change to run MkInitrd right before kexec
198 - plus clean up old code
199
200 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
201 - first working version of 5.0:
202 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
203 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
204 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
205
206 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
207 - support for fedora 12
208
209 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
210 - - support for when the node is behind a NAT
211 - - clean up RUN_LEVEL support
212 - - support for early sshd
213
214 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
215 - Add NAT model option for nodes which don't resolve properly.
216
217 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
218 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
219 - BootServerRequest takes the 'VARS' variable to read these values.
220 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
221 - (or any other interface that accepts a POST file)
222 - build.sh bundles cacerts for boot and monitor servers (if present) to
223 - authenticate the UPLOAD_LOG_SCRIPT.
224 - Previously, these certs were re-used from the bootcd, now they are bundled
225 - with BM.  This allows the BM to point to a completely different myplc if
226 - desired, and it is still secure, because the original download is
227 - authenticated.
228
229 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
230 - raise a single exception for nodes with authentication errors
231 - fix syntax error in MakeInitrd.py
232
233 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
234 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
235 - Removed failboot and install from forced states.
236 - Removed checks for initrd in Validate
237 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
238 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
239
240 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
241 - Special handling for "forcedeth" ethernet NIC.
242
243 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
244 - include a fix for public pl dealing with old/new boot images and root
245 - environments
246
247 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
248 - review selection nodefamily at bootstrapfs install-time
249 - now based on (1) tags (2) nodefamily and (3) defaults
250 - this is required on very old bootcd
251
252 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
253 - Use modprobe module to write out /etc/modprobe.conf.
254
255 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
256 - minor updates - using the new modprobe module *not* in this tag
257
258 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
259 - load device mapper if needed, for centos5-based bootcd variant
260
261 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
262 - renumbered 4.3
263 - New step StartRunLevelAgent
264 - various other tweaks
265
266 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
267 - most of the actual network config job moved to (py)plnet
268 - support for RAWDISK
269 - network interfaces deterministically sorted
270 - does not use nodegroups anymore for getting node arch and other extensions
271 - drop yum-based extensions
272 - debug sshd started as early as possible
273 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
274 - cleaned up (drop support for bootcdv2)
275 - still needs testing
276
277 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
278 - reflects new names from the data model
279
280 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
281 - dont unload cpqphp
282
283 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
284 - changes in the state automaton logic 
285 - root+swap = 7G
286 - usb-key threshhold increased to 17 G
287 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
288
289 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
290 - renamed step InstallBootstrapRPM into InstallBootstrapFS
291 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
292 - import pypcimap rather than pypciscan
293 - initial downlaoding of plc_config made more robust
294 - root and /vservers file systems mounted ext3
295 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
296 - also seems to be using session-based authentication rather than former hmac-based one
297
298 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
299 - usage of wireless attributes fixed and tested
300 - breakpoints cleaned up (no change for production)
301 - less alarming message when floppy does not get unloaded
302
303 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
304 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
305 - removes legacy calls to PlanetLabConf.py 
306 - refrains from unloading floppy 
307 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
308
309 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
310 - Initial build.
311