merge master into lxc_devel
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.1
4 %define taglevel 1
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
85 - bootmanager log clearly states duration of download and extraction of node image
86
87 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
88 - first working draft for dealing with f16 nodes
89 - not expected to work with mainline nodes (use 5.0 for that for now)
90
91 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
92 - no significant change, just checkpoint as 5.1 is addressing lxc
93
94 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
95 - be more explicit on the node conf_file actually used
96 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
97
98 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
99 - nicer log - was intended for previous tag
100
101 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
102 - {Start,Stop,}RunLevelAgent now ship with bootmanager
103 - new UpdateLastBootOnce
104 - root_size bumped to 14Gb which is more in line with modern h/w
105 - more safely tries to umount /dev/ and /sys
106 - support for raid partitions
107 - mkswap -f
108 - blacklist files from /etc/modprobe.conf/* instead
109
110 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
111 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
112
113 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
114 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
115 - fix for chosing version of parted - for f14
116 - added support for virtio deveices in /dev/vd
117 - fixed scanning of new disks
118 - slightly reviewed logs - default mode is verbose
119 - removed deprecated mkinitrd.sh
120
121 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
122 - Fix problems caused by shell redirection
123
124 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
125 - tag 5.0-13 is broken
126
127 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
128 - Add support for uploading bash_history to a central server for failboot nodes.
129 - Start to use subprocess instead of deprecated popen2 module
130 - Fix typo for VSERVERS_SIZE
131 - Add --allow-missing parameter to support different kernel configs with mkinitrd
132
133 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
134 - Revert "replace deprecated popen2 with subprocess"
135
136 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
137 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
138
139 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
140 - Fix typo
141
142 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
143 - fix typo
144
145 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
146 - disable time/count based filesystem checks
147
148 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
149 - Fix new disk additions to LVM array
150
151 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
152 - bugfix for centos5/python2.4 missing hashlib
153
154 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
155 - check sha1sum of downloaded bootstrapfs
156 - try recovering filesystem errors
157
158 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
159 - nicer initscript now uses 'action' from /etc/init.d/functions
160 - bugfix for nodes with extensions
161
162 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
163 - create /etc/planetlab if missing
164 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
165
166 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
167 - caglar's change to run MkInitrd right before kexec
168 - plus clean up old code
169
170 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
171 - first working version of 5.0:
172 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
173 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
174 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
175
176 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
177 - support for fedora 12
178
179 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
180 - - support for when the node is behind a NAT
181 - - clean up RUN_LEVEL support
182 - - support for early sshd
183
184 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
185 - Add NAT model option for nodes which don't resolve properly.
186
187 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
188 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
189 - BootServerRequest takes the 'VARS' variable to read these values.
190 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
191 - (or any other interface that accepts a POST file)
192 - build.sh bundles cacerts for boot and monitor servers (if present) to
193 - authenticate the UPLOAD_LOG_SCRIPT.
194 - Previously, these certs were re-used from the bootcd, now they are bundled
195 - with BM.  This allows the BM to point to a completely different myplc if
196 - desired, and it is still secure, because the original download is
197 - authenticated.
198
199 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
200 - raise a single exception for nodes with authentication errors
201 - fix syntax error in MakeInitrd.py
202
203 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
204 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
205 - Removed failboot and install from forced states.
206 - Removed checks for initrd in Validate
207 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
208 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
209
210 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
211 - Special handling for "forcedeth" ethernet NIC.
212
213 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
214 - include a fix for public pl dealing with old/new boot images and root
215 - environments
216
217 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
218 - review selection nodefamily at bootstrapfs install-time
219 - now based on (1) tags (2) nodefamily and (3) defaults
220 - this is required on very old bootcd
221
222 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
223 - Use modprobe module to write out /etc/modprobe.conf.
224
225 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
226 - minor updates - using the new modprobe module *not* in this tag
227
228 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
229 - load device mapper if needed, for centos5-based bootcd variant
230
231 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
232 - renumbered 4.3
233 - New step StartRunLevelAgent
234 - various other tweaks
235
236 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
237 - most of the actual network config job moved to (py)plnet
238 - support for RAWDISK
239 - network interfaces deterministically sorted
240 - does not use nodegroups anymore for getting node arch and other extensions
241 - drop yum-based extensions
242 - debug sshd started as early as possible
243 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
244 - cleaned up (drop support for bootcdv2)
245 - still needs testing
246
247 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
248 - reflects new names from the data model
249
250 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
251 - dont unload cpqphp
252
253 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
254 - changes in the state automaton logic 
255 - root+swap = 7G
256 - usb-key threshhold increased to 17 G
257 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
258
259 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
260 - renamed step InstallBootstrapRPM into InstallBootstrapFS
261 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
262 - import pypcimap rather than pypciscan
263 - initial downlaoding of plc_config made more robust
264 - root and /vservers file systems mounted ext3
265 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
266 - also seems to be using session-based authentication rather than former hmac-based one
267
268 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
269 - usage of wireless attributes fixed and tested
270 - breakpoints cleaned up (no change for production)
271 - less alarming message when floppy does not get unloaded
272
273 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
274 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
275 - removes legacy calls to PlanetLabConf.py 
276 - refrains from unloading floppy 
277 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
278
279 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
280 - Initial build.
281
282 %define module_current_branch 4.3