Setting tag bootmanager-5.0-24
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.0
4 %define taglevel 24
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
85 - run parted with --script to avoid it to hang
86
87 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
88 - added support for disks larger than 2Tb using gpt instead of msdos
89
90 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
91 - bootmanager log clearly states duration of download and extraction of node image
92
93 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
94 - no significant change, just checkpoint as 5.1 is addressing lxc
95
96 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
97 - be more explicit on the node conf_file actually used
98 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
99
100 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
101 - nicer log - was intended for previous tag
102
103 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
104 - {Start,Stop,}RunLevelAgent now ship with bootmanager
105 - new UpdateLastBootOnce
106 - root_size bumped to 14Gb which is more in line with modern h/w
107 - more safely tries to umount /dev/ and /sys
108 - support for raid partitions
109 - mkswap -f
110 - blacklist files from /etc/modprobe.conf/* instead
111
112 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
113 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
114
115 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
116 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
117 - fix for chosing version of parted - for f14
118 - added support for virtio deveices in /dev/vd
119 - fixed scanning of new disks
120 - slightly reviewed logs - default mode is verbose
121 - removed deprecated mkinitrd.sh
122
123 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
124 - Fix problems caused by shell redirection
125
126 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
127 - tag 5.0-13 is broken
128
129 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
130 - Add support for uploading bash_history to a central server for failboot nodes.
131 - Start to use subprocess instead of deprecated popen2 module
132 - Fix typo for VSERVERS_SIZE
133 - Add --allow-missing parameter to support different kernel configs with mkinitrd
134
135 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
136 - Revert "replace deprecated popen2 with subprocess"
137
138 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
139 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
140
141 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
142 - Fix typo
143
144 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
145 - fix typo
146
147 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
148 - disable time/count based filesystem checks
149
150 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
151 - Fix new disk additions to LVM array
152
153 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
154 - bugfix for centos5/python2.4 missing hashlib
155
156 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
157 - check sha1sum of downloaded bootstrapfs
158 - try recovering filesystem errors
159
160 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
161 - nicer initscript now uses 'action' from /etc/init.d/functions
162 - bugfix for nodes with extensions
163
164 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
165 - create /etc/planetlab if missing
166 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
167
168 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
169 - caglar's change to run MkInitrd right before kexec
170 - plus clean up old code
171
172 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
173 - first working version of 5.0:
174 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
175 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
176 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
177
178 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
179 - support for fedora 12
180
181 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
182 - - support for when the node is behind a NAT
183 - - clean up RUN_LEVEL support
184 - - support for early sshd
185
186 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
187 - Add NAT model option for nodes which don't resolve properly.
188
189 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
190 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
191 - BootServerRequest takes the 'VARS' variable to read these values.
192 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
193 - (or any other interface that accepts a POST file)
194 - build.sh bundles cacerts for boot and monitor servers (if present) to
195 - authenticate the UPLOAD_LOG_SCRIPT.
196 - Previously, these certs were re-used from the bootcd, now they are bundled
197 - with BM.  This allows the BM to point to a completely different myplc if
198 - desired, and it is still secure, because the original download is
199 - authenticated.
200
201 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
202 - raise a single exception for nodes with authentication errors
203 - fix syntax error in MakeInitrd.py
204
205 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
206 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
207 - Removed failboot and install from forced states.
208 - Removed checks for initrd in Validate
209 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
210 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
211
212 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
213 - Special handling for "forcedeth" ethernet NIC.
214
215 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
216 - include a fix for public pl dealing with old/new boot images and root
217 - environments
218
219 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
220 - review selection nodefamily at bootstrapfs install-time
221 - now based on (1) tags (2) nodefamily and (3) defaults
222 - this is required on very old bootcd
223
224 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
225 - Use modprobe module to write out /etc/modprobe.conf.
226
227 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
228 - minor updates - using the new modprobe module *not* in this tag
229
230 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
231 - load device mapper if needed, for centos5-based bootcd variant
232
233 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
234 - renumbered 4.3
235 - New step StartRunLevelAgent
236 - various other tweaks
237
238 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
239 - most of the actual network config job moved to (py)plnet
240 - support for RAWDISK
241 - network interfaces deterministically sorted
242 - does not use nodegroups anymore for getting node arch and other extensions
243 - drop yum-based extensions
244 - debug sshd started as early as possible
245 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
246 - cleaned up (drop support for bootcdv2)
247 - still needs testing
248
249 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
250 - reflects new names from the data model
251
252 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
253 - dont unload cpqphp
254
255 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
256 - changes in the state automaton logic 
257 - root+swap = 7G
258 - usb-key threshhold increased to 17 G
259 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
260
261 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
262 - renamed step InstallBootstrapRPM into InstallBootstrapFS
263 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
264 - import pypcimap rather than pypciscan
265 - initial downlaoding of plc_config made more robust
266 - root and /vservers file systems mounted ext3
267 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
268 - also seems to be using session-based authentication rather than former hmac-based one
269
270 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
271 - usage of wireless attributes fixed and tested
272 - breakpoints cleaned up (no change for production)
273 - less alarming message when floppy does not get unloaded
274
275 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
276 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
277 - removes legacy calls to PlanetLabConf.py 
278 - refrains from unloading floppy 
279 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
280
281 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
282 - Initial build.
283
284 %define module_current_branch 4.3