Setting tag bootmanager-5.3-2
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.3
4 %define taglevel 2
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 # in theory this should be a noarch rpm
22 # however because of libc-opendir-hack (which apparently targets f12 bootCDs)
23 # this is not true anymore and fedora23 won't let us build this as noarch anymore
24 # BuildArch: noarch
25
26 Requires: tar, gnupg, sharutils, bzip2
27 # need the apache user at install-time
28 Requires: httpd 
29
30 Requires: plcapi >= 5.2
31 # we need to install these on the myplc side too, although this is suboptimal
32 # b/c this python code gets shipped on the nodes as well
33 Requires: pypcilib pyplnet
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 %files
80 %defattr(-,root,root,-)
81 %{_datadir}/%{name}
82 /var/www/html/boot/index.php
83 /var/www/html/boot/upload-bmlog.php
84 /var/www/html/boot/getnodeid.php
85 /etc/plc.d/bootmanager
86
87 %changelog
88 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-2
89 - not a noarch package anymore (indeed it does come with binaries)
90 - fix ssl connection for runlevelagent for recent pythons
91 - for fedora23, ignore if rsa1 key generation fails
92
93 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
94 - Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
95 - Can implement 'upgrade' in addition to 'reinstall' boot state
96 - upgrade does essentially the same as reinstall except that slices are preserved
97 - upgrade works only on nodes already running containers
98 - because /vservers/ needs to be a btrfs filesystem
99 - pycurl is now a strong requirement (old curl-based code removed)
100 - bugfix for ssh key generation (were all typed rsa1)
101 - a lot of prettification
102
103 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
104 - runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
105 - introduces the ONE_PARTITION configuration variable
106 - some suport for chainbooting ubuntu
107
108 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
109 - no functional change, only tweaks in Makefile for interating with test environment
110
111 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
112 - some old f18 bootCDs do not support mkfs.btrfs -f
113 - so invoke this option only when supported
114
115 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
116 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
117 - smarter for locating initrd, for f20
118 - add -f to mkfs.btrfs - sometimes hangs otherwise
119
120 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
121 - merged the branches for vserver and lxc
122 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
123 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
124 - also note that fsck management for btrfs/lxc is still weak
125 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
126 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
127 - expects ntpd to be turned on in the nodeimage
128
129 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
130 - fix for heterogeneous bootimage/nodeimage
131
132 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
133 - Turn off WriteModprobeConfig for f18
134 - enable btrfs quota
135 - fix very old ssh DSA key generation
136
137 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
138 - run parted with --script to keep it from hanging
139
140 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
141 - run parted with --script to avoid it to hang
142
143 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
144 - pour the 5.0-22 and 5.0-23 features into the lxc mix
145
146 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
147 - added support for disks larger than 2Tb using gpt instead of msdos
148
149 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
150 - bootmanager log clearly states duration of download and extraction of node image
151
152 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
153 - first working draft for dealing with f16 nodes
154 - not expected to work with mainline nodes (use 5.0 for that for now)
155
156 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
157 - no significant change, just checkpoint as 5.1 is addressing lxc
158
159 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
160 - be more explicit on the node conf_file actually used
161 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
162
163 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
164 - nicer log - was intended for previous tag
165
166 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
167 - {Start,Stop,}RunLevelAgent now ship with bootmanager
168 - new UpdateLastBootOnce
169 - root_size bumped to 14Gb which is more in line with modern h/w
170 - more safely tries to umount /dev/ and /sys
171 - support for raid partitions
172 - mkswap -f
173 - blacklist files from /etc/modprobe.conf/* instead
174
175 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
176 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
177
178 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
179 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
180 - fix for chosing version of parted - for f14
181 - added support for virtio deveices in /dev/vd
182 - fixed scanning of new disks
183 - slightly reviewed logs - default mode is verbose
184 - removed deprecated mkinitrd.sh
185
186 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
187 - Fix problems caused by shell redirection
188
189 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
190 - tag 5.0-13 is broken
191
192 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
193 - Add support for uploading bash_history to a central server for failboot nodes.
194 - Start to use subprocess instead of deprecated popen2 module
195 - Fix typo for VSERVERS_SIZE
196 - Add --allow-missing parameter to support different kernel configs with mkinitrd
197
198 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
199 - Revert "replace deprecated popen2 with subprocess"
200
201 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
202 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
203
204 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
205 - Fix typo
206
207 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
208 - fix typo
209
210 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
211 - disable time/count based filesystem checks
212
213 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
214 - Fix new disk additions to LVM array
215
216 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
217 - bugfix for centos5/python2.4 missing hashlib
218
219 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
220 - check sha1sum of downloaded bootstrapfs
221 - try recovering filesystem errors
222
223 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
224 - nicer initscript now uses 'action' from /etc/init.d/functions
225 - bugfix for nodes with extensions
226
227 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
228 - create /etc/planetlab if missing
229 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
230
231 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
232 - caglar's change to run MkInitrd right before kexec
233 - plus clean up old code
234
235 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
236 - first working version of 5.0:
237 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
238 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
239 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
240
241 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
242 - support for fedora 12
243
244 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
245 - - support for when the node is behind a NAT
246 - - clean up RUN_LEVEL support
247 - - support for early sshd
248
249 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
250 - Add NAT model option for nodes which don't resolve properly.
251
252 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
253 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
254 - BootServerRequest takes the 'VARS' variable to read these values.
255 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
256 - (or any other interface that accepts a POST file)
257 - build.sh bundles cacerts for boot and monitor servers (if present) to
258 - authenticate the UPLOAD_LOG_SCRIPT.
259 - Previously, these certs were re-used from the bootcd, now they are bundled
260 - with BM.  This allows the BM to point to a completely different myplc if
261 - desired, and it is still secure, because the original download is
262 - authenticated.
263
264 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
265 - raise a single exception for nodes with authentication errors
266 - fix syntax error in MakeInitrd.py
267
268 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
269 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
270 - Removed failboot and install from forced states.
271 - Removed checks for initrd in Validate
272 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
273 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
274
275 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
276 - Special handling for "forcedeth" ethernet NIC.
277
278 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
279 - include a fix for public pl dealing with old/new boot images and root
280 - environments
281
282 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
283 - review selection nodefamily at bootstrapfs install-time
284 - now based on (1) tags (2) nodefamily and (3) defaults
285 - this is required on very old bootcd
286
287 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
288 - Use modprobe module to write out /etc/modprobe.conf.
289
290 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
291 - minor updates - using the new modprobe module *not* in this tag
292
293 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
294 - load device mapper if needed, for centos5-based bootcd variant
295
296 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
297 - renumbered 4.3
298 - New step StartRunLevelAgent
299 - various other tweaks
300
301 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
302 - most of the actual network config job moved to (py)plnet
303 - support for RAWDISK
304 - network interfaces deterministically sorted
305 - does not use nodegroups anymore for getting node arch and other extensions
306 - drop yum-based extensions
307 - debug sshd started as early as possible
308 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
309 - cleaned up (drop support for bootcdv2)
310 - still needs testing
311
312 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
313 - reflects new names from the data model
314
315 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
316 - dont unload cpqphp
317
318 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
319 - changes in the state automaton logic 
320 - root+swap = 7G
321 - usb-key threshhold increased to 17 G
322 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
323
324 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
325 - renamed step InstallBootstrapRPM into InstallBootstrapFS
326 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
327 - import pypcimap rather than pypciscan
328 - initial downlaoding of plc_config made more robust
329 - root and /vservers file systems mounted ext3
330 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
331 - also seems to be using session-based authentication rather than former hmac-based one
332
333 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
334 - usage of wireless attributes fixed and tested
335 - breakpoints cleaned up (no change for production)
336 - less alarming message when floppy does not get unloaded
337
338 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
339 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
340 - removes legacy calls to PlanetLabConf.py 
341 - refrains from unloading floppy 
342 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
343
344 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
345 - Initial build.
346