Fixed path to Ubuntus initrd
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.2
4 %define taglevel 3
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: plcapi >= 5.2
28 # we need to install these on the myplc side too, although this is suboptimal
29 # b/c this python code gets shipped on the nodes as well
30 Requires: pypcilib pyplnet
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
63
64 # formerly in the MyPLC module
65 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 # initialize the boot manager upload area
72 mkdir -p /var/log/bm
73 chown apache:apache /var/log/bm
74 chmod 700 /var/log/bm
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 /var/www/html/boot/index.php
80 /var/www/html/boot/upload-bmlog.php
81 /var/www/html/boot/getnodeid.php
82 /etc/plc.d/bootmanager
83
84 %changelog
85 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
86 - some old f18 bootCDs do not support mkfs.btrfs -f
87 - so invoke this option only when supported
88
89 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
90 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
91 - smarter for locating initrd, for f20
92 - add -f to mkfs.btrfs - sometimes hangs otherwise
93
94 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
95 - merged the branches for vserver and lxc
96 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
97 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
98 - also note that fsck management for btrfs/lxc is still weak
99 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
100 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
101 - expects ntpd to be turned on in the nodeimage
102
103 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
104 - fix for heterogeneous bootimage/nodeimage
105
106 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
107 - Turn off WriteModprobeConfig for f18
108 - enable btrfs quota
109 - fix very old ssh DSA key generation
110
111 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
112 - run parted with --script to keep it from hanging
113
114 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
115 - run parted with --script to avoid it to hang
116
117 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
118 - pour the 5.0-22 and 5.0-23 features into the lxc mix
119
120 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
121 - added support for disks larger than 2Tb using gpt instead of msdos
122
123 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
124 - bootmanager log clearly states duration of download and extraction of node image
125
126 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
127 - first working draft for dealing with f16 nodes
128 - not expected to work with mainline nodes (use 5.0 for that for now)
129
130 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
131 - no significant change, just checkpoint as 5.1 is addressing lxc
132
133 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
134 - be more explicit on the node conf_file actually used
135 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
136
137 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
138 - nicer log - was intended for previous tag
139
140 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
141 - {Start,Stop,}RunLevelAgent now ship with bootmanager
142 - new UpdateLastBootOnce
143 - root_size bumped to 14Gb which is more in line with modern h/w
144 - more safely tries to umount /dev/ and /sys
145 - support for raid partitions
146 - mkswap -f
147 - blacklist files from /etc/modprobe.conf/* instead
148
149 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
150 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
151
152 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
153 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
154 - fix for chosing version of parted - for f14
155 - added support for virtio deveices in /dev/vd
156 - fixed scanning of new disks
157 - slightly reviewed logs - default mode is verbose
158 - removed deprecated mkinitrd.sh
159
160 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
161 - Fix problems caused by shell redirection
162
163 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
164 - tag 5.0-13 is broken
165
166 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
167 - Add support for uploading bash_history to a central server for failboot nodes.
168 - Start to use subprocess instead of deprecated popen2 module
169 - Fix typo for VSERVERS_SIZE
170 - Add --allow-missing parameter to support different kernel configs with mkinitrd
171
172 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
173 - Revert "replace deprecated popen2 with subprocess"
174
175 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
176 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
177
178 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
179 - Fix typo
180
181 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
182 - fix typo
183
184 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
185 - disable time/count based filesystem checks
186
187 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
188 - Fix new disk additions to LVM array
189
190 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
191 - bugfix for centos5/python2.4 missing hashlib
192
193 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
194 - check sha1sum of downloaded bootstrapfs
195 - try recovering filesystem errors
196
197 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
198 - nicer initscript now uses 'action' from /etc/init.d/functions
199 - bugfix for nodes with extensions
200
201 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
202 - create /etc/planetlab if missing
203 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
204
205 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
206 - caglar's change to run MkInitrd right before kexec
207 - plus clean up old code
208
209 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
210 - first working version of 5.0:
211 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
212 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
213 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
214
215 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
216 - support for fedora 12
217
218 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
219 - - support for when the node is behind a NAT
220 - - clean up RUN_LEVEL support
221 - - support for early sshd
222
223 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
224 - Add NAT model option for nodes which don't resolve properly.
225
226 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
227 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
228 - BootServerRequest takes the 'VARS' variable to read these values.
229 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
230 - (or any other interface that accepts a POST file)
231 - build.sh bundles cacerts for boot and monitor servers (if present) to
232 - authenticate the UPLOAD_LOG_SCRIPT.
233 - Previously, these certs were re-used from the bootcd, now they are bundled
234 - with BM.  This allows the BM to point to a completely different myplc if
235 - desired, and it is still secure, because the original download is
236 - authenticated.
237
238 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
239 - raise a single exception for nodes with authentication errors
240 - fix syntax error in MakeInitrd.py
241
242 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
243 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
244 - Removed failboot and install from forced states.
245 - Removed checks for initrd in Validate
246 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
247 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
248
249 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
250 - Special handling for "forcedeth" ethernet NIC.
251
252 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
253 - include a fix for public pl dealing with old/new boot images and root
254 - environments
255
256 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
257 - review selection nodefamily at bootstrapfs install-time
258 - now based on (1) tags (2) nodefamily and (3) defaults
259 - this is required on very old bootcd
260
261 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
262 - Use modprobe module to write out /etc/modprobe.conf.
263
264 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
265 - minor updates - using the new modprobe module *not* in this tag
266
267 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
268 - load device mapper if needed, for centos5-based bootcd variant
269
270 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
271 - renumbered 4.3
272 - New step StartRunLevelAgent
273 - various other tweaks
274
275 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
276 - most of the actual network config job moved to (py)plnet
277 - support for RAWDISK
278 - network interfaces deterministically sorted
279 - does not use nodegroups anymore for getting node arch and other extensions
280 - drop yum-based extensions
281 - debug sshd started as early as possible
282 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
283 - cleaned up (drop support for bootcdv2)
284 - still needs testing
285
286 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
287 - reflects new names from the data model
288
289 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
290 - dont unload cpqphp
291
292 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
293 - changes in the state automaton logic 
294 - root+swap = 7G
295 - usb-key threshhold increased to 17 G
296 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
297
298 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
299 - renamed step InstallBootstrapRPM into InstallBootstrapFS
300 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
301 - import pypcimap rather than pypciscan
302 - initial downlaoding of plc_config made more robust
303 - root and /vservers file systems mounted ext3
304 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
305 - also seems to be using session-based authentication rather than former hmac-based one
306
307 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
308 - usage of wireless attributes fixed and tested
309 - breakpoints cleaned up (no change for production)
310 - less alarming message when floppy does not get unloaded
311
312 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
313 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
314 - removes legacy calls to PlanetLabConf.py 
315 - refrains from unloading floppy 
316 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
317
318 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
319 - Initial build.
320