make debugmode can push this code on board a node in debug mode (aka safeboot)
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.3
4 %define taglevel 1
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: plcapi >= 5.2
28 # we need to install these on the myplc side too, although this is suboptimal
29 # b/c this python code gets shipped on the nodes as well
30 Requires: pypcilib pyplnet
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
63
64 # formerly in the MyPLC module
65 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 # initialize the boot manager upload area
72 mkdir -p /var/log/bm
73 chown apache:apache /var/log/bm
74 chmod 700 /var/log/bm
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 /var/www/html/boot/index.php
80 /var/www/html/boot/upload-bmlog.php
81 /var/www/html/boot/getnodeid.php
82 /etc/plc.d/bootmanager
83
84 %changelog
85 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
86 - Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
87 - Can implement 'upgrade' in addition to 'reinstall' boot state
88 - upgrade does essentially the same as reinstall except that slices are preserved
89 - upgrade works only on nodes already running containers
90 - because /vservers/ needs to be a btrfs filesystem
91 - pycurl is now a strong requirement (old curl-based code removed)
92 - bugfix for ssh key generation (were all typed rsa1)
93 - a lot of prettification
94
95 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
96 - runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
97 - introduces the ONE_PARTITION configuration variable
98 - some suport for chainbooting ubuntu
99
100 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
101 - no functional change, only tweaks in Makefile for interating with test environment
102
103 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
104 - some old f18 bootCDs do not support mkfs.btrfs -f
105 - so invoke this option only when supported
106
107 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
108 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
109 - smarter for locating initrd, for f20
110 - add -f to mkfs.btrfs - sometimes hangs otherwise
111
112 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
113 - merged the branches for vserver and lxc
114 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
115 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
116 - also note that fsck management for btrfs/lxc is still weak
117 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
118 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
119 - expects ntpd to be turned on in the nodeimage
120
121 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
122 - fix for heterogeneous bootimage/nodeimage
123
124 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
125 - Turn off WriteModprobeConfig for f18
126 - enable btrfs quota
127 - fix very old ssh DSA key generation
128
129 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
130 - run parted with --script to keep it from hanging
131
132 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
133 - run parted with --script to avoid it to hang
134
135 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
136 - pour the 5.0-22 and 5.0-23 features into the lxc mix
137
138 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
139 - added support for disks larger than 2Tb using gpt instead of msdos
140
141 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
142 - bootmanager log clearly states duration of download and extraction of node image
143
144 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
145 - first working draft for dealing with f16 nodes
146 - not expected to work with mainline nodes (use 5.0 for that for now)
147
148 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
149 - no significant change, just checkpoint as 5.1 is addressing lxc
150
151 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
152 - be more explicit on the node conf_file actually used
153 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
154
155 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
156 - nicer log - was intended for previous tag
157
158 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
159 - {Start,Stop,}RunLevelAgent now ship with bootmanager
160 - new UpdateLastBootOnce
161 - root_size bumped to 14Gb which is more in line with modern h/w
162 - more safely tries to umount /dev/ and /sys
163 - support for raid partitions
164 - mkswap -f
165 - blacklist files from /etc/modprobe.conf/* instead
166
167 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
168 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
169
170 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
171 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
172 - fix for chosing version of parted - for f14
173 - added support for virtio deveices in /dev/vd
174 - fixed scanning of new disks
175 - slightly reviewed logs - default mode is verbose
176 - removed deprecated mkinitrd.sh
177
178 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
179 - Fix problems caused by shell redirection
180
181 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
182 - tag 5.0-13 is broken
183
184 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
185 - Add support for uploading bash_history to a central server for failboot nodes.
186 - Start to use subprocess instead of deprecated popen2 module
187 - Fix typo for VSERVERS_SIZE
188 - Add --allow-missing parameter to support different kernel configs with mkinitrd
189
190 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
191 - Revert "replace deprecated popen2 with subprocess"
192
193 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
194 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
195
196 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
197 - Fix typo
198
199 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
200 - fix typo
201
202 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
203 - disable time/count based filesystem checks
204
205 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
206 - Fix new disk additions to LVM array
207
208 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
209 - bugfix for centos5/python2.4 missing hashlib
210
211 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
212 - check sha1sum of downloaded bootstrapfs
213 - try recovering filesystem errors
214
215 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
216 - nicer initscript now uses 'action' from /etc/init.d/functions
217 - bugfix for nodes with extensions
218
219 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
220 - create /etc/planetlab if missing
221 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
222
223 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
224 - caglar's change to run MkInitrd right before kexec
225 - plus clean up old code
226
227 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
228 - first working version of 5.0:
229 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
230 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
231 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
232
233 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
234 - support for fedora 12
235
236 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
237 - - support for when the node is behind a NAT
238 - - clean up RUN_LEVEL support
239 - - support for early sshd
240
241 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
242 - Add NAT model option for nodes which don't resolve properly.
243
244 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
245 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
246 - BootServerRequest takes the 'VARS' variable to read these values.
247 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
248 - (or any other interface that accepts a POST file)
249 - build.sh bundles cacerts for boot and monitor servers (if present) to
250 - authenticate the UPLOAD_LOG_SCRIPT.
251 - Previously, these certs were re-used from the bootcd, now they are bundled
252 - with BM.  This allows the BM to point to a completely different myplc if
253 - desired, and it is still secure, because the original download is
254 - authenticated.
255
256 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
257 - raise a single exception for nodes with authentication errors
258 - fix syntax error in MakeInitrd.py
259
260 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
261 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
262 - Removed failboot and install from forced states.
263 - Removed checks for initrd in Validate
264 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
265 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
266
267 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
268 - Special handling for "forcedeth" ethernet NIC.
269
270 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
271 - include a fix for public pl dealing with old/new boot images and root
272 - environments
273
274 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
275 - review selection nodefamily at bootstrapfs install-time
276 - now based on (1) tags (2) nodefamily and (3) defaults
277 - this is required on very old bootcd
278
279 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
280 - Use modprobe module to write out /etc/modprobe.conf.
281
282 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
283 - minor updates - using the new modprobe module *not* in this tag
284
285 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
286 - load device mapper if needed, for centos5-based bootcd variant
287
288 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
289 - renumbered 4.3
290 - New step StartRunLevelAgent
291 - various other tweaks
292
293 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
294 - most of the actual network config job moved to (py)plnet
295 - support for RAWDISK
296 - network interfaces deterministically sorted
297 - does not use nodegroups anymore for getting node arch and other extensions
298 - drop yum-based extensions
299 - debug sshd started as early as possible
300 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
301 - cleaned up (drop support for bootcdv2)
302 - still needs testing
303
304 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
305 - reflects new names from the data model
306
307 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
308 - dont unload cpqphp
309
310 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
311 - changes in the state automaton logic 
312 - root+swap = 7G
313 - usb-key threshhold increased to 17 G
314 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
315
316 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
317 - renamed step InstallBootstrapRPM into InstallBootstrapFS
318 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
319 - import pypcimap rather than pypciscan
320 - initial downlaoding of plc_config made more robust
321 - root and /vservers file systems mounted ext3
322 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
323 - also seems to be using session-based authentication rather than former hmac-based one
324
325 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
326 - usage of wireless attributes fixed and tested
327 - breakpoints cleaned up (no change for production)
328 - less alarming message when floppy does not get unloaded
329
330 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
331 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
332 - removes legacy calls to PlanetLabConf.py 
333 - refrains from unloading floppy 
334 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
335
336 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
337 - Initial build.
338