89f5f8f833791c085af0500e55e6b25b4abb3f0c
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 6.0
4 %define taglevel 0
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 # in theory this should be a noarch rpm
22 # however because of libc-opendir-hack (which apparently targets f12 bootCDs)
23 # this is not true anymore and fedora23 won't let us build this as noarch anymore
24 # BuildArch: noarch
25
26 Requires: tar, gnupg, sharutils, bzip2
27 # need the apache user at install-time
28 Requires: httpd 
29
30 Requires: plcapi >= 5.2
31 # we need to install these on the myplc side too, although this is suboptimal
32 # b/c this python code gets shipped on the nodes as well
33 Requires: pypcilib pyplnet
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 %files
80 %defattr(-,root,root,-)
81 %{_datadir}/%{name}
82 /var/www/html/boot/index.php
83 /var/www/html/boot/upload-bmlog.php
84 /var/www/html/boot/getnodeid.php
85 /etc/plc.d/bootmanager
86
87 %changelog
88 * Mon Jan 07 2019 Thierry <Parmentelat> - bootmanager-6.0-0
89 - * this is STILL BASED ON PYTHON2, but relies on 2 accessory libraries that are pypcilib and pyplnet
90 - for this reason, the relevant files are COPIED at packaging time
91 - * new settings lxc_ROOT_SIZE=12G (was 70G) and SWAP_SIZE=4G (was 1G)
92 - and lxc_TOTAL_MINIMUM_DISK_SIZE=50 (was 120)
93 - * invoke conf_files.py as a plain script (i.e. expects a shebang) since we ideally can still
94 - use this code against a python2 nodemanager
95 - * skip nodeupdate step, will be redone later anyway
96 - * rely on NetworkManager utilities when ifconfig can't be found
97 - * tear down patch for very old 2.6.12 kernels
98 - * a little closer to python3 though
99
100 * Sun Jan 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-4
101 - runlevelagent was not able to reach myplc because of
102 - server verification that is now implicit in python 2.7.9
103
104 * Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-3
105 - patch for f23 as of dec. 2015 where kernel and initrd show up in
106 - a new location under /boot
107 - plus bugfix with format and single { and } for awk args
108
109 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-2
110 - not a noarch package anymore (indeed it does come with binaries)
111 - fix ssl connection for runlevelagent for recent pythons
112 - for fedora23, ignore if rsa1 key generation fails
113
114 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
115 - Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
116 - Can implement 'upgrade' in addition to 'reinstall' boot state
117 - upgrade does essentially the same as reinstall except that slices are preserved
118 - upgrade works only on nodes already running containers
119 - because /vservers/ needs to be a btrfs filesystem
120 - pycurl is now a strong requirement (old curl-based code removed)
121 - bugfix for ssh key generation (were all typed rsa1)
122 - a lot of prettification
123
124 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
125 - runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
126 - introduces the ONE_PARTITION configuration variable
127 - some suport for chainbooting ubuntu
128
129 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
130 - no functional change, only tweaks in Makefile for interating with test environment
131
132 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
133 - some old f18 bootCDs do not support mkfs.btrfs -f
134 - so invoke this option only when supported
135
136 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
137 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
138 - smarter for locating initrd, for f20
139 - add -f to mkfs.btrfs - sometimes hangs otherwise
140
141 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
142 - merged the branches for vserver and lxc
143 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
144 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
145 - also note that fsck management for btrfs/lxc is still weak
146 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
147 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
148 - expects ntpd to be turned on in the nodeimage
149
150 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
151 - fix for heterogeneous bootimage/nodeimage
152
153 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
154 - Turn off WriteModprobeConfig for f18
155 - enable btrfs quota
156 - fix very old ssh DSA key generation
157
158 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
159 - run parted with --script to keep it from hanging
160
161 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
162 - run parted with --script to avoid it to hang
163
164 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
165 - pour the 5.0-22 and 5.0-23 features into the lxc mix
166
167 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
168 - added support for disks larger than 2Tb using gpt instead of msdos
169
170 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
171 - bootmanager log clearly states duration of download and extraction of node image
172
173 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
174 - first working draft for dealing with f16 nodes
175 - not expected to work with mainline nodes (use 5.0 for that for now)
176
177 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
178 - no significant change, just checkpoint as 5.1 is addressing lxc
179
180 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
181 - be more explicit on the node conf_file actually used
182 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
183
184 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
185 - nicer log - was intended for previous tag
186
187 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
188 - {Start,Stop,}RunLevelAgent now ship with bootmanager
189 - new UpdateLastBootOnce
190 - root_size bumped to 14Gb which is more in line with modern h/w
191 - more safely tries to umount /dev/ and /sys
192 - support for raid partitions
193 - mkswap -f
194 - blacklist files from /etc/modprobe.conf/* instead
195
196 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
197 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
198
199 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
200 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
201 - fix for chosing version of parted - for f14
202 - added support for virtio deveices in /dev/vd
203 - fixed scanning of new disks
204 - slightly reviewed logs - default mode is verbose
205 - removed deprecated mkinitrd.sh
206
207 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
208 - Fix problems caused by shell redirection
209
210 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
211 - tag 5.0-13 is broken
212
213 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
214 - Add support for uploading bash_history to a central server for failboot nodes.
215 - Start to use subprocess instead of deprecated popen2 module
216 - Fix typo for VSERVERS_SIZE
217 - Add --allow-missing parameter to support different kernel configs with mkinitrd
218
219 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
220 - Revert "replace deprecated popen2 with subprocess"
221
222 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
223 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
224
225 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
226 - Fix typo
227
228 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
229 - fix typo
230
231 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
232 - disable time/count based filesystem checks
233
234 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
235 - Fix new disk additions to LVM array
236
237 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
238 - bugfix for centos5/python2.4 missing hashlib
239
240 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
241 - check sha1sum of downloaded bootstrapfs
242 - try recovering filesystem errors
243
244 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
245 - nicer initscript now uses 'action' from /etc/init.d/functions
246 - bugfix for nodes with extensions
247
248 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
249 - create /etc/planetlab if missing
250 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
251
252 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
253 - caglar's change to run MkInitrd right before kexec
254 - plus clean up old code
255
256 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
257 - first working version of 5.0:
258 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
259 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
260 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
261
262 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
263 - support for fedora 12
264
265 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
266 - - support for when the node is behind a NAT
267 - - clean up RUN_LEVEL support
268 - - support for early sshd
269
270 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
271 - Add NAT model option for nodes which don't resolve properly.
272
273 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
274 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
275 - BootServerRequest takes the 'VARS' variable to read these values.
276 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
277 - (or any other interface that accepts a POST file)
278 - build.sh bundles cacerts for boot and monitor servers (if present) to
279 - authenticate the UPLOAD_LOG_SCRIPT.
280 - Previously, these certs were re-used from the bootcd, now they are bundled
281 - with BM.  This allows the BM to point to a completely different myplc if
282 - desired, and it is still secure, because the original download is
283 - authenticated.
284
285 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
286 - raise a single exception for nodes with authentication errors
287 - fix syntax error in MakeInitrd.py
288
289 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
290 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
291 - Removed failboot and install from forced states.
292 - Removed checks for initrd in Validate
293 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
294 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
295
296 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
297 - Special handling for "forcedeth" ethernet NIC.
298
299 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
300 - include a fix for public pl dealing with old/new boot images and root
301 - environments
302
303 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
304 - review selection nodefamily at bootstrapfs install-time
305 - now based on (1) tags (2) nodefamily and (3) defaults
306 - this is required on very old bootcd
307
308 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
309 - Use modprobe module to write out /etc/modprobe.conf.
310
311 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
312 - minor updates - using the new modprobe module *not* in this tag
313
314 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
315 - load device mapper if needed, for centos5-based bootcd variant
316
317 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
318 - renumbered 4.3
319 - New step StartRunLevelAgent
320 - various other tweaks
321
322 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
323 - most of the actual network config job moved to (py)plnet
324 - support for RAWDISK
325 - network interfaces deterministically sorted
326 - does not use nodegroups anymore for getting node arch and other extensions
327 - drop yum-based extensions
328 - debug sshd started as early as possible
329 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
330 - cleaned up (drop support for bootcdv2)
331 - still needs testing
332
333 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
334 - reflects new names from the data model
335
336 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
337 - dont unload cpqphp
338
339 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
340 - changes in the state automaton logic 
341 - root+swap = 7G
342 - usb-key threshhold increased to 17 G
343 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
344
345 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
346 - renamed step InstallBootstrapRPM into InstallBootstrapFS
347 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
348 - import pypcimap rather than pypciscan
349 - initial downlaoding of plc_config made more robust
350 - root and /vservers file systems mounted ext3
351 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
352 - also seems to be using session-based authentication rather than former hmac-based one
353
354 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
355 - usage of wireless attributes fixed and tested
356 - breakpoints cleaned up (no change for production)
357 - less alarming message when floppy does not get unloaded
358
359 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
360 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
361 - removes legacy calls to PlanetLabConf.py 
362 - refrains from unloading floppy 
363 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
364
365 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
366 - Initial build.
367