6 %define name bootmanager
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
17 Summary: The PlanetLab Boot Manager
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 4.3
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
33 %define debug_package %{nil}
36 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
46 rm -rf $RPM_BUILD_ROOT
48 # Install source so that it can be rebuilt
49 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
52 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
54 # This is only required for 2.x bootcds.
55 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
58 rm -rf $RPM_BUILD_ROOT
61 if [ -n "$SUDO_USER" ] ; then
62 # Allow user to delete the build directory
63 chown -h -R $SUDO_USER .
64 # Some temporary cdroot files like /var/empty/sshd and
65 # /usr/bin/sudo get created with non-readable permissions.
66 find . -not -perm +0600 -exec chmod u+rw {} \;
67 # Allow user to delete the built RPM(s)
68 chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
73 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
74 PlanetLab private key.
77 # NOTE: do not run this agent when installed on a myplc.
78 chkconfig monitor-runlevelagent off
79 chkconfig --del monitor-runlevelagent
82 %defattr(-,root,root,-)
84 %ghost /var/www/html/boot/bootmanager.sh
85 /var/www/html/boot/uudecode.gz
88 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
89 - Add NAT model option for nodes which don't resolve properly.
91 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
92 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
93 - BootServerRequest takes the 'VARS' variable to read these values.
94 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
95 - (or any other interface that accepts a POST file)
96 - build.sh bundles cacerts for boot and monitor servers (if present) to
97 - authenticate the UPLOAD_LOG_SCRIPT.
98 - Previously, these certs were re-used from the bootcd, now they are bundled
99 - with BM. This allows the BM to point to a completely different myplc if
100 - desired, and it is still secure, because the original download is
103 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
104 - raise a single exception for nodes with authentication errors
105 - fix syntax error in MakeInitrd.py
107 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
108 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
109 - Removed failboot and install from forced states.
110 - Removed checks for initrd in Validate
111 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
112 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
114 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
115 - Special handling for "forcedeth" ethernet NIC.
117 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
118 - include a fix for public pl dealing with old/new boot images and root
121 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
122 - review selection nodefamily at bootstrapfs install-time
123 - now based on (1) tags (2) nodefamily and (3) defaults
124 - this is required on very old bootcd
126 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
127 - Use modprobe module to write out /etc/modprobe.conf.
129 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
130 - minor updates - using the new modprobe module *not* in this tag
132 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
133 - load device mapper if needed, for centos5-based bootcd variant
135 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
137 - New step StartRunLevelAgent
138 - various other tweaks
140 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
141 - most of the actual network config job moved to (py)plnet
142 - support for RAWDISK
143 - network interfaces deterministically sorted
144 - does not use nodegroups anymore for getting node arch and other extensions
145 - drop yum-based extensions
146 - debug sshd started as early as possible
147 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
148 - cleaned up (drop support for bootcdv2)
149 - still needs testing
151 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
152 - reflects new names from the data model
154 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
157 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
158 - changes in the state automaton logic
160 - usb-key threshhold increased to 17 G
161 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
163 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
164 - renamed step InstallBootstrapRPM into InstallBootstrapFS
165 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
166 - import pypcimap rather than pypciscan
167 - initial downlaoding of plc_config made more robust
168 - root and /vservers file systems mounted ext3
169 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
170 - also seems to be using session-based authentication rather than former hmac-based one
172 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
173 - usage of wireless attributes fixed and tested
174 - breakpoints cleaned up (no change for production)
175 - less alarming message when floppy does not get unloaded
177 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
178 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
179 - removes legacy calls to PlanetLabConf.py
180 - refrains from unloading floppy
181 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
183 * Fri Sep 2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> -
186 %define module_current_branch 3.2