Setting tag bootmanager-4.3-22
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 4.3
8 %define taglevel 22
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27 Requires: PLCAPI >= 4.3
28
29 # the python code packaged in these are shipped on the node as well
30 Requires: pypcilib pyplnet monitor-runlevelagent
31
32 AutoReqProv: no
33 %define debug_package %{nil}
34
35 %description
36 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
37 nodes.
38
39 %prep
40 %setup -q
41
42 %build
43 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 # Install source so that it can be rebuilt
49 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
50
51 touch bootmanager.sh
52 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
53
54 # This is only required for 2.x bootcds.
55 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 # If run under sudo
61 if [ -n "$SUDO_USER" ] ; then
62     # Allow user to delete the build directory
63     chown -h -R $SUDO_USER .
64     # Some temporary cdroot files like /var/empty/sshd and
65     # /usr/bin/sudo get created with non-readable permissions.
66     find . -not -perm +0600 -exec chmod u+rw {} \;
67     # Allow user to delete the built RPM(s)
68     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
69 fi
70
71 %post
72 cat <<EOF
73 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
74 PlanetLab private key.
75 EOF
76
77 # NOTE: do not run this agent when installed on a myplc.
78 chkconfig monitor-runlevelagent off
79 chkconfig --del monitor-runlevelagent
80
81 %files
82 %defattr(-,root,root,-)
83 %{_datadir}/%{name}
84 %ghost /var/www/html/boot/bootmanager.sh
85 /var/www/html/boot/uudecode.gz
86
87 %changelog
88 * Fri Mar 11 2011 S.Çağlar Onur <caglar@verivue.com> - bootmanager-4.3-22
89 - Add missing include
90
91 * Wed Mar 09 2011 S.Çağlar Onur <caglar@verivue.com> - bootmanager-4.3-21
92 - Support virtio block devices
93
94 * Fri Jan 07 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-4.3-20
95 - add --allow-missing parameter to support different kernel configs
96
97 * Tue Dec 14 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - bootmanager-4.3-19
98 - Force removal of VG for automation.
99
100 * Fri Nov 19 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - bootmanager-4.3-18
101 - Use resize2fs for resizing.
102 - Fix typo for VSERVERS_SIZE.
103 - Disable time/count-based fsck.
104
105 * Fri Feb 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - BootManager-4.3-17
106 - merge initrd changes from trunk
107
108 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
109 - support for fedora 12
110
111 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
112 - - support for when the node is behind a NAT
113 - - clean up RUN_LEVEL support
114 - - support for early sshd
115
116 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
117 - Add NAT model option for nodes which don't resolve properly.
118
119 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
120 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
121 - BootServerRequest takes the 'VARS' variable to read these values.
122 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
123 - (or any other interface that accepts a POST file)
124 - build.sh bundles cacerts for boot and monitor servers (if present) to
125 - authenticate the UPLOAD_LOG_SCRIPT.
126 - Previously, these certs were re-used from the bootcd, now they are bundled
127 - with BM.  This allows the BM to point to a completely different myplc if
128 - desired, and it is still secure, because the original download is
129 - authenticated.
130
131 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
132 - raise a single exception for nodes with authentication errors
133 - fix syntax error in MakeInitrd.py
134
135 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
136 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
137 - Removed failboot and install from forced states.
138 - Removed checks for initrd in Validate
139 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
140 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
141
142 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
143 - Special handling for "forcedeth" ethernet NIC.
144
145 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
146 - include a fix for public pl dealing with old/new boot images and root
147 - environments
148
149 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
150 - review selection nodefamily at bootstrapfs install-time
151 - now based on (1) tags (2) nodefamily and (3) defaults
152 - this is required on very old bootcd
153
154 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
155 - Use modprobe module to write out /etc/modprobe.conf.
156
157 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
158 - minor updates - using the new modprobe module *not* in this tag
159
160 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
161 - load device mapper if needed, for centos5-based bootcd variant
162
163 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
164 - renumbered 4.3
165 - New step StartRunLevelAgent
166 - various other tweaks
167
168 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
169 - most of the actual network config job moved to (py)plnet
170 - support for RAWDISK
171 - network interfaces deterministically sorted
172 - does not use nodegroups anymore for getting node arch and other extensions
173 - drop yum-based extensions
174 - debug sshd started as early as possible
175 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
176 - cleaned up (drop support for bootcdv2)
177 - still needs testing
178
179 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
180 - reflects new names from the data model
181
182 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
183 - dont unload cpqphp
184
185 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
186 - changes in the state automaton logic 
187 - root+swap = 7G
188 - usb-key threshhold increased to 17 G
189 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
190
191 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
192 - renamed step InstallBootstrapRPM into InstallBootstrapFS
193 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
194 - import pypcimap rather than pypciscan
195 - initial downlaoding of plc_config made more robust
196 - root and /vservers file systems mounted ext3
197 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
198 - also seems to be using session-based authentication rather than former hmac-based one
199
200 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
201 - usage of wireless attributes fixed and tested
202 - breakpoints cleaned up (no change for production)
203 - less alarming message when floppy does not get unloaded
204
205 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
206 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
207 - removes legacy calls to PlanetLabConf.py 
208 - refrains from unloading floppy 
209 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
210
211 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
212 - Initial build.
213
214 %define module_current_branch 3.2