Merge branch 'ansible'
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.2
4 %define taglevel 4
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: plcapi >= 5.2
28 # we need to install these on the myplc side too, although this is suboptimal
29 # b/c this python code gets shipped on the nodes as well
30 Requires: pypcilib pyplnet
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
63
64 # formerly in the MyPLC module
65 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 # initialize the boot manager upload area
72 mkdir -p /var/log/bm
73 chown apache:apache /var/log/bm
74 chmod 700 /var/log/bm
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 /var/www/html/boot/index.php
80 /var/www/html/boot/upload-bmlog.php
81 /var/www/html/boot/getnodeid.php
82 /etc/plc.d/bootmanager
83
84 %changelog
85 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
86 - no functional change, only tweaks in Makefile for interating with test environment
87
88 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
89 - some old f18 bootCDs do not support mkfs.btrfs -f
90 - so invoke this option only when supported
91
92 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
93 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
94 - smarter for locating initrd, for f20
95 - add -f to mkfs.btrfs - sometimes hangs otherwise
96
97 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
98 - merged the branches for vserver and lxc
99 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
100 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
101 - also note that fsck management for btrfs/lxc is still weak
102 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
103 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
104 - expects ntpd to be turned on in the nodeimage
105
106 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
107 - fix for heterogeneous bootimage/nodeimage
108
109 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
110 - Turn off WriteModprobeConfig for f18
111 - enable btrfs quota
112 - fix very old ssh DSA key generation
113
114 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
115 - run parted with --script to keep it from hanging
116
117 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
118 - run parted with --script to avoid it to hang
119
120 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
121 - pour the 5.0-22 and 5.0-23 features into the lxc mix
122
123 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
124 - added support for disks larger than 2Tb using gpt instead of msdos
125
126 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
127 - bootmanager log clearly states duration of download and extraction of node image
128
129 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
130 - first working draft for dealing with f16 nodes
131 - not expected to work with mainline nodes (use 5.0 for that for now)
132
133 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
134 - no significant change, just checkpoint as 5.1 is addressing lxc
135
136 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
137 - be more explicit on the node conf_file actually used
138 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
139
140 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
141 - nicer log - was intended for previous tag
142
143 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
144 - {Start,Stop,}RunLevelAgent now ship with bootmanager
145 - new UpdateLastBootOnce
146 - root_size bumped to 14Gb which is more in line with modern h/w
147 - more safely tries to umount /dev/ and /sys
148 - support for raid partitions
149 - mkswap -f
150 - blacklist files from /etc/modprobe.conf/* instead
151
152 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
153 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
154
155 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
156 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
157 - fix for chosing version of parted - for f14
158 - added support for virtio deveices in /dev/vd
159 - fixed scanning of new disks
160 - slightly reviewed logs - default mode is verbose
161 - removed deprecated mkinitrd.sh
162
163 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
164 - Fix problems caused by shell redirection
165
166 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
167 - tag 5.0-13 is broken
168
169 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
170 - Add support for uploading bash_history to a central server for failboot nodes.
171 - Start to use subprocess instead of deprecated popen2 module
172 - Fix typo for VSERVERS_SIZE
173 - Add --allow-missing parameter to support different kernel configs with mkinitrd
174
175 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
176 - Revert "replace deprecated popen2 with subprocess"
177
178 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
179 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
180
181 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
182 - Fix typo
183
184 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
185 - fix typo
186
187 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
188 - disable time/count based filesystem checks
189
190 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
191 - Fix new disk additions to LVM array
192
193 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
194 - bugfix for centos5/python2.4 missing hashlib
195
196 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
197 - check sha1sum of downloaded bootstrapfs
198 - try recovering filesystem errors
199
200 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
201 - nicer initscript now uses 'action' from /etc/init.d/functions
202 - bugfix for nodes with extensions
203
204 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
205 - create /etc/planetlab if missing
206 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
207
208 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
209 - caglar's change to run MkInitrd right before kexec
210 - plus clean up old code
211
212 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
213 - first working version of 5.0:
214 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
215 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
216 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
217
218 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
219 - support for fedora 12
220
221 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
222 - - support for when the node is behind a NAT
223 - - clean up RUN_LEVEL support
224 - - support for early sshd
225
226 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
227 - Add NAT model option for nodes which don't resolve properly.
228
229 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
230 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
231 - BootServerRequest takes the 'VARS' variable to read these values.
232 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
233 - (or any other interface that accepts a POST file)
234 - build.sh bundles cacerts for boot and monitor servers (if present) to
235 - authenticate the UPLOAD_LOG_SCRIPT.
236 - Previously, these certs were re-used from the bootcd, now they are bundled
237 - with BM.  This allows the BM to point to a completely different myplc if
238 - desired, and it is still secure, because the original download is
239 - authenticated.
240
241 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
242 - raise a single exception for nodes with authentication errors
243 - fix syntax error in MakeInitrd.py
244
245 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
246 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
247 - Removed failboot and install from forced states.
248 - Removed checks for initrd in Validate
249 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
250 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
251
252 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
253 - Special handling for "forcedeth" ethernet NIC.
254
255 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
256 - include a fix for public pl dealing with old/new boot images and root
257 - environments
258
259 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
260 - review selection nodefamily at bootstrapfs install-time
261 - now based on (1) tags (2) nodefamily and (3) defaults
262 - this is required on very old bootcd
263
264 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
265 - Use modprobe module to write out /etc/modprobe.conf.
266
267 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
268 - minor updates - using the new modprobe module *not* in this tag
269
270 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
271 - load device mapper if needed, for centos5-based bootcd variant
272
273 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
274 - renumbered 4.3
275 - New step StartRunLevelAgent
276 - various other tweaks
277
278 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
279 - most of the actual network config job moved to (py)plnet
280 - support for RAWDISK
281 - network interfaces deterministically sorted
282 - does not use nodegroups anymore for getting node arch and other extensions
283 - drop yum-based extensions
284 - debug sshd started as early as possible
285 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
286 - cleaned up (drop support for bootcdv2)
287 - still needs testing
288
289 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
290 - reflects new names from the data model
291
292 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
293 - dont unload cpqphp
294
295 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
296 - changes in the state automaton logic 
297 - root+swap = 7G
298 - usb-key threshhold increased to 17 G
299 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
300
301 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
302 - renamed step InstallBootstrapRPM into InstallBootstrapFS
303 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
304 - import pypcimap rather than pypciscan
305 - initial downlaoding of plc_config made more robust
306 - root and /vservers file systems mounted ext3
307 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
308 - also seems to be using session-based authentication rather than former hmac-based one
309
310 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
311 - usage of wireless attributes fixed and tested
312 - breakpoints cleaned up (no change for production)
313 - less alarming message when floppy does not get unloaded
314
315 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
316 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
317 - removes legacy calls to PlanetLabConf.py 
318 - refrains from unloading floppy 
319 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
320
321 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
322 - Initial build.
323