a first stab at upgrading nodes
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.3
4 %define taglevel 0
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: plcapi >= 5.2
28 # we need to install these on the myplc side too, although this is suboptimal
29 # b/c this python code gets shipped on the nodes as well
30 Requires: pypcilib pyplnet
31
32 ### avoid having yum complain about updates, as stuff is moving around
33 # plc.d/bootmanager
34 Conflicts: myplc <= 4.3
35 # nodeconfig/boot/*
36 Conflicts: nodeconfig <= 4.3
37
38 AutoReqProv: no
39 %define debug_package %{nil}
40
41 %description
42 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
43 nodes.
44
45 %prep
46 %setup -q
47
48 %build
49 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 # Install source so that it can be rebuilt
55 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
56
57 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
58
59 # formerly in the nodeconfig module
60 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
61 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
62 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
63
64 # formerly in the MyPLC module
65 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 # initialize the boot manager upload area
72 mkdir -p /var/log/bm
73 chown apache:apache /var/log/bm
74 chmod 700 /var/log/bm
75
76 %files
77 %defattr(-,root,root,-)
78 %{_datadir}/%{name}
79 /var/www/html/boot/index.php
80 /var/www/html/boot/upload-bmlog.php
81 /var/www/html/boot/getnodeid.php
82 /etc/plc.d/bootmanager
83
84 %changelog
85 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
86 - runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
87 - introduces the ONE_PARTITION configuration variable
88 - some suport for chainbooting ubuntu
89
90 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
91 - no functional change, only tweaks in Makefile for interating with test environment
92
93 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
94 - some old f18 bootCDs do not support mkfs.btrfs -f
95 - so invoke this option only when supported
96
97 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
98 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
99 - smarter for locating initrd, for f20
100 - add -f to mkfs.btrfs - sometimes hangs otherwise
101
102 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
103 - merged the branches for vserver and lxc
104 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
105 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
106 - also note that fsck management for btrfs/lxc is still weak
107 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
108 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
109 - expects ntpd to be turned on in the nodeimage
110
111 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
112 - fix for heterogeneous bootimage/nodeimage
113
114 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
115 - Turn off WriteModprobeConfig for f18
116 - enable btrfs quota
117 - fix very old ssh DSA key generation
118
119 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
120 - run parted with --script to keep it from hanging
121
122 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
123 - run parted with --script to avoid it to hang
124
125 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
126 - pour the 5.0-22 and 5.0-23 features into the lxc mix
127
128 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
129 - added support for disks larger than 2Tb using gpt instead of msdos
130
131 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
132 - bootmanager log clearly states duration of download and extraction of node image
133
134 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
135 - first working draft for dealing with f16 nodes
136 - not expected to work with mainline nodes (use 5.0 for that for now)
137
138 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
139 - no significant change, just checkpoint as 5.1 is addressing lxc
140
141 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
142 - be more explicit on the node conf_file actually used
143 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
144
145 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
146 - nicer log - was intended for previous tag
147
148 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
149 - {Start,Stop,}RunLevelAgent now ship with bootmanager
150 - new UpdateLastBootOnce
151 - root_size bumped to 14Gb which is more in line with modern h/w
152 - more safely tries to umount /dev/ and /sys
153 - support for raid partitions
154 - mkswap -f
155 - blacklist files from /etc/modprobe.conf/* instead
156
157 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
158 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
159
160 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
161 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
162 - fix for chosing version of parted - for f14
163 - added support for virtio deveices in /dev/vd
164 - fixed scanning of new disks
165 - slightly reviewed logs - default mode is verbose
166 - removed deprecated mkinitrd.sh
167
168 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
169 - Fix problems caused by shell redirection
170
171 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
172 - tag 5.0-13 is broken
173
174 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
175 - Add support for uploading bash_history to a central server for failboot nodes.
176 - Start to use subprocess instead of deprecated popen2 module
177 - Fix typo for VSERVERS_SIZE
178 - Add --allow-missing parameter to support different kernel configs with mkinitrd
179
180 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
181 - Revert "replace deprecated popen2 with subprocess"
182
183 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
184 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
185
186 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
187 - Fix typo
188
189 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
190 - fix typo
191
192 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
193 - disable time/count based filesystem checks
194
195 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
196 - Fix new disk additions to LVM array
197
198 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
199 - bugfix for centos5/python2.4 missing hashlib
200
201 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
202 - check sha1sum of downloaded bootstrapfs
203 - try recovering filesystem errors
204
205 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
206 - nicer initscript now uses 'action' from /etc/init.d/functions
207 - bugfix for nodes with extensions
208
209 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
210 - create /etc/planetlab if missing
211 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
212
213 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
214 - caglar's change to run MkInitrd right before kexec
215 - plus clean up old code
216
217 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
218 - first working version of 5.0:
219 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
220 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
221 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
222
223 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
224 - support for fedora 12
225
226 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
227 - - support for when the node is behind a NAT
228 - - clean up RUN_LEVEL support
229 - - support for early sshd
230
231 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
232 - Add NAT model option for nodes which don't resolve properly.
233
234 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
235 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
236 - BootServerRequest takes the 'VARS' variable to read these values.
237 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
238 - (or any other interface that accepts a POST file)
239 - build.sh bundles cacerts for boot and monitor servers (if present) to
240 - authenticate the UPLOAD_LOG_SCRIPT.
241 - Previously, these certs were re-used from the bootcd, now they are bundled
242 - with BM.  This allows the BM to point to a completely different myplc if
243 - desired, and it is still secure, because the original download is
244 - authenticated.
245
246 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
247 - raise a single exception for nodes with authentication errors
248 - fix syntax error in MakeInitrd.py
249
250 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
251 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
252 - Removed failboot and install from forced states.
253 - Removed checks for initrd in Validate
254 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
255 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
256
257 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
258 - Special handling for "forcedeth" ethernet NIC.
259
260 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
261 - include a fix for public pl dealing with old/new boot images and root
262 - environments
263
264 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
265 - review selection nodefamily at bootstrapfs install-time
266 - now based on (1) tags (2) nodefamily and (3) defaults
267 - this is required on very old bootcd
268
269 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
270 - Use modprobe module to write out /etc/modprobe.conf.
271
272 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
273 - minor updates - using the new modprobe module *not* in this tag
274
275 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
276 - load device mapper if needed, for centos5-based bootcd variant
277
278 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
279 - renumbered 4.3
280 - New step StartRunLevelAgent
281 - various other tweaks
282
283 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
284 - most of the actual network config job moved to (py)plnet
285 - support for RAWDISK
286 - network interfaces deterministically sorted
287 - does not use nodegroups anymore for getting node arch and other extensions
288 - drop yum-based extensions
289 - debug sshd started as early as possible
290 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
291 - cleaned up (drop support for bootcdv2)
292 - still needs testing
293
294 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
295 - reflects new names from the data model
296
297 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
298 - dont unload cpqphp
299
300 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
301 - changes in the state automaton logic 
302 - root+swap = 7G
303 - usb-key threshhold increased to 17 G
304 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
305
306 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
307 - renamed step InstallBootstrapRPM into InstallBootstrapFS
308 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
309 - import pypcimap rather than pypciscan
310 - initial downlaoding of plc_config made more robust
311 - root and /vservers file systems mounted ext3
312 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
313 - also seems to be using session-based authentication rather than former hmac-based one
314
315 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
316 - usage of wireless attributes fixed and tested
317 - breakpoints cleaned up (no change for production)
318 - less alarming message when floppy does not get unloaded
319
320 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
321 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
322 - removes legacy calls to PlanetLabConf.py 
323 - refrains from unloading floppy 
324 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
325
326 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
327 - Initial build.
328