Setting tag bootmanager-5.1-1
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.1
4 %define taglevel 1
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
85 - first working draft for dealing with f16 nodes
86 - not expected to work with mainline nodes (use 5.0 for that for now)
87
88 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
89 - be more explicit on the node conf_file actually used
90 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
91
92 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
93 - nicer log - was intended for previous tag
94
95 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
96 - {Start,Stop,}RunLevelAgent now ship with bootmanager
97 - new UpdateLastBootOnce
98 - root_size bumped to 14Gb which is more in line with modern h/w
99 - more safely tries to umount /dev/ and /sys
100 - support for raid partitions
101 - mkswap -f
102 - blacklist files from /etc/modprobe.conf/* instead
103
104 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
105 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
106
107 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
108 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
109 - fix for chosing version of parted - for f14
110 - added support for virtio deveices in /dev/vd
111 - fixed scanning of new disks
112 - slightly reviewed logs - default mode is verbose
113 - removed deprecated mkinitrd.sh
114
115 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
116 - Fix problems caused by shell redirection
117
118 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
119 - tag 5.0-13 is broken
120
121 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
122 - Add support for uploading bash_history to a central server for failboot nodes.
123 - Start to use subprocess instead of deprecated popen2 module
124 - Fix typo for VSERVERS_SIZE
125 - Add --allow-missing parameter to support different kernel configs with mkinitrd
126
127 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
128 - Revert "replace deprecated popen2 with subprocess"
129
130 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
131 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
132
133 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
134 - Fix typo
135
136 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
137 - fix typo
138
139 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
140 - disable time/count based filesystem checks
141
142 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
143 - Fix new disk additions to LVM array
144
145 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
146 - bugfix for centos5/python2.4 missing hashlib
147
148 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
149 - check sha1sum of downloaded bootstrapfs
150 - try recovering filesystem errors
151
152 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
153 - nicer initscript now uses 'action' from /etc/init.d/functions
154 - bugfix for nodes with extensions
155
156 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
157 - create /etc/planetlab if missing
158 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
159
160 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
161 - caglar's change to run MkInitrd right before kexec
162 - plus clean up old code
163
164 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
165 - first working version of 5.0:
166 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
167 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
168 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
169
170 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
171 - support for fedora 12
172
173 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
174 - - support for when the node is behind a NAT
175 - - clean up RUN_LEVEL support
176 - - support for early sshd
177
178 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
179 - Add NAT model option for nodes which don't resolve properly.
180
181 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
182 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
183 - BootServerRequest takes the 'VARS' variable to read these values.
184 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
185 - (or any other interface that accepts a POST file)
186 - build.sh bundles cacerts for boot and monitor servers (if present) to
187 - authenticate the UPLOAD_LOG_SCRIPT.
188 - Previously, these certs were re-used from the bootcd, now they are bundled
189 - with BM.  This allows the BM to point to a completely different myplc if
190 - desired, and it is still secure, because the original download is
191 - authenticated.
192
193 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
194 - raise a single exception for nodes with authentication errors
195 - fix syntax error in MakeInitrd.py
196
197 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
198 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
199 - Removed failboot and install from forced states.
200 - Removed checks for initrd in Validate
201 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
202 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
203
204 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
205 - Special handling for "forcedeth" ethernet NIC.
206
207 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
208 - include a fix for public pl dealing with old/new boot images and root
209 - environments
210
211 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
212 - review selection nodefamily at bootstrapfs install-time
213 - now based on (1) tags (2) nodefamily and (3) defaults
214 - this is required on very old bootcd
215
216 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
217 - Use modprobe module to write out /etc/modprobe.conf.
218
219 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
220 - minor updates - using the new modprobe module *not* in this tag
221
222 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
223 - load device mapper if needed, for centos5-based bootcd variant
224
225 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
226 - renumbered 4.3
227 - New step StartRunLevelAgent
228 - various other tweaks
229
230 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
231 - most of the actual network config job moved to (py)plnet
232 - support for RAWDISK
233 - network interfaces deterministically sorted
234 - does not use nodegroups anymore for getting node arch and other extensions
235 - drop yum-based extensions
236 - debug sshd started as early as possible
237 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
238 - cleaned up (drop support for bootcdv2)
239 - still needs testing
240
241 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
242 - reflects new names from the data model
243
244 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
245 - dont unload cpqphp
246
247 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
248 - changes in the state automaton logic 
249 - root+swap = 7G
250 - usb-key threshhold increased to 17 G
251 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
252
253 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
254 - renamed step InstallBootstrapRPM into InstallBootstrapFS
255 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
256 - import pypcimap rather than pypciscan
257 - initial downlaoding of plc_config made more robust
258 - root and /vservers file systems mounted ext3
259 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
260 - also seems to be using session-based authentication rather than former hmac-based one
261
262 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
263 - usage of wireless attributes fixed and tested
264 - breakpoints cleaned up (no change for production)
265 - less alarming message when floppy does not get unloaded
266
267 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
268 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
269 - removes legacy calls to PlanetLabConf.py 
270 - refrains from unloading floppy 
271 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
272
273 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
274 - Initial build.
275
276 %define module_current_branch 4.3