bugfixes for the location of kernel and initrd as observed on recent f23
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.3
4 %define taglevel 1
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 # in theory this should be a noarch rpm
22 # however because of libc-opendir-hack (which apparently targets f12 bootCDs)
23 # this is not true anymore and fedora23 won't let us build this as noarch anymore
24 # BuildArch: noarch
25
26 Requires: tar, gnupg, sharutils, bzip2
27 # need the apache user at install-time
28 Requires: httpd 
29
30 Requires: plcapi >= 5.2
31 # we need to install these on the myplc side too, although this is suboptimal
32 # b/c this python code gets shipped on the nodes as well
33 Requires: pypcilib pyplnet
34
35 ### avoid having yum complain about updates, as stuff is moving around
36 # plc.d/bootmanager
37 Conflicts: myplc <= 4.3
38 # nodeconfig/boot/*
39 Conflicts: nodeconfig <= 4.3
40
41 AutoReqProv: no
42 %define debug_package %{nil}
43
44 %description
45 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
46 nodes.
47
48 %prep
49 %setup -q
50
51 %build
52 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 # Install source so that it can be rebuilt
58 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
59
60 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
61
62 # formerly in the nodeconfig module
63 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
64 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
65 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
66
67 # formerly in the MyPLC module
68 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # initialize the boot manager upload area
75 mkdir -p /var/log/bm
76 chown apache:apache /var/log/bm
77 chmod 700 /var/log/bm
78
79 %files
80 %defattr(-,root,root,-)
81 %{_datadir}/%{name}
82 /var/www/html/boot/index.php
83 /var/www/html/boot/upload-bmlog.php
84 /var/www/html/boot/getnodeid.php
85 /etc/plc.d/bootmanager
86
87 %changelog
88 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
89 - Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
90 - Can implement 'upgrade' in addition to 'reinstall' boot state
91 - upgrade does essentially the same as reinstall except that slices are preserved
92 - upgrade works only on nodes already running containers
93 - because /vservers/ needs to be a btrfs filesystem
94 - pycurl is now a strong requirement (old curl-based code removed)
95 - bugfix for ssh key generation (were all typed rsa1)
96 - a lot of prettification
97
98 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
99 - runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
100 - introduces the ONE_PARTITION configuration variable
101 - some suport for chainbooting ubuntu
102
103 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
104 - no functional change, only tweaks in Makefile for interating with test environment
105
106 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
107 - some old f18 bootCDs do not support mkfs.btrfs -f
108 - so invoke this option only when supported
109
110 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
111 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
112 - smarter for locating initrd, for f20
113 - add -f to mkfs.btrfs - sometimes hangs otherwise
114
115 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
116 - merged the branches for vserver and lxc
117 - requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
118 - note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
119 - also note that fsck management for btrfs/lxc is still weak
120 - vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
121 - vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
122 - expects ntpd to be turned on in the nodeimage
123
124 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
125 - fix for heterogeneous bootimage/nodeimage
126
127 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
128 - Turn off WriteModprobeConfig for f18
129 - enable btrfs quota
130 - fix very old ssh DSA key generation
131
132 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
133 - run parted with --script to keep it from hanging
134
135 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
136 - run parted with --script to avoid it to hang
137
138 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
139 - pour the 5.0-22 and 5.0-23 features into the lxc mix
140
141 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
142 - added support for disks larger than 2Tb using gpt instead of msdos
143
144 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
145 - bootmanager log clearly states duration of download and extraction of node image
146
147 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
148 - first working draft for dealing with f16 nodes
149 - not expected to work with mainline nodes (use 5.0 for that for now)
150
151 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
152 - no significant change, just checkpoint as 5.1 is addressing lxc
153
154 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
155 - be more explicit on the node conf_file actually used
156 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
157
158 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
159 - nicer log - was intended for previous tag
160
161 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
162 - {Start,Stop,}RunLevelAgent now ship with bootmanager
163 - new UpdateLastBootOnce
164 - root_size bumped to 14Gb which is more in line with modern h/w
165 - more safely tries to umount /dev/ and /sys
166 - support for raid partitions
167 - mkswap -f
168 - blacklist files from /etc/modprobe.conf/* instead
169
170 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
171 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
172
173 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
174 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
175 - fix for chosing version of parted - for f14
176 - added support for virtio deveices in /dev/vd
177 - fixed scanning of new disks
178 - slightly reviewed logs - default mode is verbose
179 - removed deprecated mkinitrd.sh
180
181 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
182 - Fix problems caused by shell redirection
183
184 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
185 - tag 5.0-13 is broken
186
187 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
188 - Add support for uploading bash_history to a central server for failboot nodes.
189 - Start to use subprocess instead of deprecated popen2 module
190 - Fix typo for VSERVERS_SIZE
191 - Add --allow-missing parameter to support different kernel configs with mkinitrd
192
193 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
194 - Revert "replace deprecated popen2 with subprocess"
195
196 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
197 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
198
199 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
200 - Fix typo
201
202 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
203 - fix typo
204
205 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
206 - disable time/count based filesystem checks
207
208 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
209 - Fix new disk additions to LVM array
210
211 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
212 - bugfix for centos5/python2.4 missing hashlib
213
214 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
215 - check sha1sum of downloaded bootstrapfs
216 - try recovering filesystem errors
217
218 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
219 - nicer initscript now uses 'action' from /etc/init.d/functions
220 - bugfix for nodes with extensions
221
222 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
223 - create /etc/planetlab if missing
224 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
225
226 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
227 - caglar's change to run MkInitrd right before kexec
228 - plus clean up old code
229
230 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
231 - first working version of 5.0:
232 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
233 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
234 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
235
236 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
237 - support for fedora 12
238
239 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
240 - - support for when the node is behind a NAT
241 - - clean up RUN_LEVEL support
242 - - support for early sshd
243
244 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
245 - Add NAT model option for nodes which don't resolve properly.
246
247 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
248 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
249 - BootServerRequest takes the 'VARS' variable to read these values.
250 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
251 - (or any other interface that accepts a POST file)
252 - build.sh bundles cacerts for boot and monitor servers (if present) to
253 - authenticate the UPLOAD_LOG_SCRIPT.
254 - Previously, these certs were re-used from the bootcd, now they are bundled
255 - with BM.  This allows the BM to point to a completely different myplc if
256 - desired, and it is still secure, because the original download is
257 - authenticated.
258
259 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
260 - raise a single exception for nodes with authentication errors
261 - fix syntax error in MakeInitrd.py
262
263 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
264 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
265 - Removed failboot and install from forced states.
266 - Removed checks for initrd in Validate
267 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
268 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
269
270 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
271 - Special handling for "forcedeth" ethernet NIC.
272
273 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
274 - include a fix for public pl dealing with old/new boot images and root
275 - environments
276
277 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
278 - review selection nodefamily at bootstrapfs install-time
279 - now based on (1) tags (2) nodefamily and (3) defaults
280 - this is required on very old bootcd
281
282 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
283 - Use modprobe module to write out /etc/modprobe.conf.
284
285 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
286 - minor updates - using the new modprobe module *not* in this tag
287
288 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
289 - load device mapper if needed, for centos5-based bootcd variant
290
291 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
292 - renumbered 4.3
293 - New step StartRunLevelAgent
294 - various other tweaks
295
296 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
297 - most of the actual network config job moved to (py)plnet
298 - support for RAWDISK
299 - network interfaces deterministically sorted
300 - does not use nodegroups anymore for getting node arch and other extensions
301 - drop yum-based extensions
302 - debug sshd started as early as possible
303 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
304 - cleaned up (drop support for bootcdv2)
305 - still needs testing
306
307 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
308 - reflects new names from the data model
309
310 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
311 - dont unload cpqphp
312
313 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
314 - changes in the state automaton logic 
315 - root+swap = 7G
316 - usb-key threshhold increased to 17 G
317 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
318
319 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
320 - renamed step InstallBootstrapRPM into InstallBootstrapFS
321 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
322 - import pypcimap rather than pypciscan
323 - initial downlaoding of plc_config made more robust
324 - root and /vservers file systems mounted ext3
325 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
326 - also seems to be using session-based authentication rather than former hmac-based one
327
328 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
329 - usage of wireless attributes fixed and tested
330 - breakpoints cleaned up (no change for production)
331 - less alarming message when floppy does not get unloaded
332
333 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
334 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
335 - removes legacy calls to PlanetLabConf.py 
336 - refrains from unloading floppy 
337 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
338
339 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
340 - Initial build.
341