ddabaed5c53f9e3ce33e248392d38a323048c761
[bootmanager.git] / bootmanager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name bootmanager
7 %define version 3.2
8 %define taglevel 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %(echo %{url} | cut -d ' ' -f 2)
16
17 Summary: The PlanetLab Boot Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: BSD
22 Group: System Environment/Base
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Requires: tar, gnupg, sharutils, bzip2, pypcilib
27
28 AutoReqProv: no
29 %define debug_package %{nil}
30
31 %description
32 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
33 nodes.
34
35 %prep
36 %setup -q
37
38 %build
39 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 # Install source so that it can be rebuilt
45 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
46
47 touch bootmanager.sh
48 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
49
50 # This is only required for 2.x bootcds.
51 install -D -m 644 support-files/uudecode.gz $RPM_BUILD_ROOT/var/www/html/boot/uudecode.gz
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 # If run under sudo
57 if [ -n "$SUDO_USER" ] ; then
58     # Allow user to delete the build directory
59     chown -h -R $SUDO_USER .
60     # Some temporary cdroot files like /var/empty/sshd and
61     # /usr/bin/sudo get created with non-readable permissions.
62     find . -not -perm +0600 -exec chmod u+rw {} \;
63     # Allow user to delete the built RPM(s)
64     chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
65 fi
66
67 %post
68 cat <<EOF
69 Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
70 PlanetLab private key.
71 EOF
72
73 %files
74 %defattr(-,root,root,-)
75 %{_datadir}/%{name}
76 %ghost /var/www/html/boot/bootmanager.sh
77 /var/www/html/boot/uudecode.gz
78
79 %changelog
80 * Wed Jul 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-11
81 - More hacks.
82
83 * Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-10
84 - Make the hack work.
85
86 * Tue Jul 01 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-3.2-9
87 - Ugly hack stuff.
88
89 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - BootManager-3.2-8
90 - move the UpdateNodeConfiguration step after the NodeUpdate step in ChainBoot
91
92 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
93 - dont unload cpqphp
94
95 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
96 - changes in the state automaton logic 
97 - root+swap = 7G
98 - usb-key threshhold increased to 17 G
99 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
100
101 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
102 - renamed step InstallBootstrapRPM into InstallBootstrapFS
103 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
104 - import pypcimap rather than pypciscan
105 - initial downlaoding of plc_config made more robust
106 - root and /vservers file systems mounted ext3
107 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
108 - also seems to be using session-based authentication rather than former hmac-based one
109
110 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
111 - usage of wireless attributes fixed and tested
112 - breakpoints cleaned up (no change for production)
113 - less alarming message when floppy does not get unloaded
114
115 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
116 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
117 - removes legacy calls to PlanetLabConf.py 
118 - refrains from unloading floppy 
119 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
120
121 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
122 - Initial build.