Setting tag bootmanager-5.1-3
[bootmanager.git] / bootmanager.spec
1 #
2 %define name bootmanager
3 %define version 5.1
4 %define taglevel 3
5
6 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
7
8 Vendor: PlanetLab
9 Packager: PlanetLab Central <support@planet-lab.org>
10 Distribution: PlanetLab %{plrelease}
11 URL: %{SCMURL}
12
13 Summary: The PlanetLab Boot Manager
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: BSD
18 Group: System Environment/Base
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21 BuildArch: noarch
22
23 Requires: tar, gnupg, sharutils, bzip2, pypcilib
24 # need the apache user at install-time
25 Requires: httpd 
26
27 Requires: PLCAPI >= 5.0
28 # the python code packaged in these are shipped on the node as well
29 Requires: pypcilib pyplnet
30
31 ### avoid having yum complain about updates, as stuff is moving around
32 # plc.d/bootmanager
33 Conflicts: myplc <= 4.3
34 # nodeconfig/boot/*
35 Conflicts: nodeconfig <= 4.3
36
37 AutoReqProv: no
38 %define debug_package %{nil}
39
40 %description
41 The PlanetLab Boot Manager securely authenticates and boots PlanetLab
42 nodes.
43
44 %prep
45 %setup -q
46
47 %build
48 gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 # Install source so that it can be rebuilt
54 find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/regular/
55
56 install -m 644 README  $RPM_BUILD_ROOT/%{_datadir}/%{name}/README
57
58 # formerly in the nodeconfig module
59 install -D -m 755 nodeconfig/boot/index.php $RPM_BUILD_ROOT/var/www/html/boot/index.php
60 install -D -m 755 nodeconfig/boot/upload-bmlog.php $RPM_BUILD_ROOT/var/www/html/boot/upload-bmlog.php
61 install -D -m 755 nodeconfig/boot/getnodeid.php $RPM_BUILD_ROOT/var/www/html/boot/getnodeid.php
62
63 # formerly in the MyPLC module
64 install -D -m 755 plc.d/bootmanager $RPM_BUILD_ROOT/etc/plc.d/bootmanager
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 # initialize the boot manager upload area
71 mkdir -p /var/log/bm
72 chown apache:apache /var/log/bm
73 chmod 700 /var/log/bm
74
75 %files
76 %defattr(-,root,root,-)
77 %{_datadir}/%{name}
78 /var/www/html/boot/index.php
79 /var/www/html/boot/upload-bmlog.php
80 /var/www/html/boot/getnodeid.php
81 /etc/plc.d/bootmanager
82
83 %changelog
84 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
85 - run parted with --script to keep it from hanging
86
87 * Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
88 - pour the 5.0-22 and 5.0-23 features into the lxc mix
89
90 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
91 - added support for disks larger than 2Tb using gpt instead of msdos
92
93 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
94 - bootmanager log clearly states duration of download and extraction of node image
95
96 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
97 - first working draft for dealing with f16 nodes
98 - not expected to work with mainline nodes (use 5.0 for that for now)
99
100 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
101 - no significant change, just checkpoint as 5.1 is addressing lxc
102
103 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-20
104 - be more explicit on the node conf_file actually used
105 - did this after a former PLC node tried to boot at PLE with its PLC plnode.txt still on a usb stick
106
107 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-19
108 - nicer log - was intended for previous tag
109
110 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-18
111 - {Start,Stop,}RunLevelAgent now ship with bootmanager
112 - new UpdateLastBootOnce
113 - root_size bumped to 14Gb which is more in line with modern h/w
114 - more safely tries to umount /dev/ and /sys
115 - support for raid partitions
116 - mkswap -f
117 - blacklist files from /etc/modprobe.conf/* instead
118
119 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-17
120 - on install of boostrapfs, keep track in /bm-install.log with date & flavour
121
122 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-16
123 - for f14 : try to mount /dev as devtmpfs before bind-mounting to on the hdd's /dev
124 - fix for chosing version of parted - for f14
125 - added support for virtio deveices in /dev/vd
126 - fixed scanning of new disks
127 - slightly reviewed logs - default mode is verbose
128 - removed deprecated mkinitrd.sh
129
130 * Fri Dec 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-15
131 - Fix problems caused by shell redirection
132
133 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-14
134 - tag 5.0-13 is broken
135
136 * Wed Dec 08 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-13
137 - Add support for uploading bash_history to a central server for failboot nodes.
138 - Start to use subprocess instead of deprecated popen2 module
139 - Fix typo for VSERVERS_SIZE
140 - Add --allow-missing parameter to support different kernel configs with mkinitrd
141
142 * Thu Aug 26 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-12
143 - Revert "replace deprecated popen2 with subprocess"
144
145 * Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-11
146 - replace deprecated popen2 with subprocess and handle fsck return codes in a different code path
147
148 * Fri Jul 30 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-10
149 - Fix typo
150
151 * Fri Jul 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - bootmanager-5.0-9
152 - fix typo
153
154 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-8
155 - disable time/count based filesystem checks
156
157 * Tue Jul 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-5.0-7
158 - Fix new disk additions to LVM array
159
160 * Wed Jul 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-6
161 - bugfix for centos5/python2.4 missing hashlib
162
163 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootManager-5.0-5
164 - check sha1sum of downloaded bootstrapfs
165 - try recovering filesystem errors
166
167 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-4
168 - nicer initscript now uses 'action' from /etc/init.d/functions
169 - bugfix for nodes with extensions
170
171 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-3
172 - create /etc/planetlab if missing
173 - uses key 'ssh_rsa_key' in BootUpdateNode (requires PLCAPI-5.0.5)
174
175 * Sat Feb 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-2
176 - caglar's change to run MkInitrd right before kexec
177 - plus clean up old code
178
179 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-5.0-1
180 - first working version of 5.0:
181 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
182 - uses PLCAPI's GetNodeFlavour to get all info on the bootstrapfs tarball(s) to install
183 - installation layout on the plc side has changed, more consistent for e.g. 'alpha' bootmanagers
184
185 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
186 - support for fedora 12
187
188 * Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
189 - - support for when the node is behind a NAT
190 - - clean up RUN_LEVEL support
191 - - support for early sshd
192
193 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
194 - Add NAT model option for nodes which don't resolve properly.
195
196 * Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
197 - Moved some configuration values from BootServerRequest.py to 'configuration' file.
198 - BootServerRequest takes the 'VARS' variable to read these values.
199 - UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
200 - (or any other interface that accepts a POST file)
201 - build.sh bundles cacerts for boot and monitor servers (if present) to
202 - authenticate the UPLOAD_LOG_SCRIPT.
203 - Previously, these certs were re-used from the bootcd, now they are bundled
204 - with BM.  This allows the BM to point to a completely different myplc if
205 - desired, and it is still secure, because the original download is
206 - authenticated.
207
208 * Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
209 - raise a single exception for nodes with authentication errors
210 - fix syntax error in MakeInitrd.py
211
212 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
213 - Replace UpdateBootstate with UpdateRunlevel where appropriate.
214 - Removed failboot and install from forced states.
215 - Removed checks for initrd in Validate
216 - Added extra messages for Validate failures, not-installed, no kernel, failed fsck
217 - Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
218
219 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
220 - Special handling for "forcedeth" ethernet NIC.
221
222 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
223 - include a fix for public pl dealing with old/new boot images and root
224 - environments
225
226 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
227 - review selection nodefamily at bootstrapfs install-time
228 - now based on (1) tags (2) nodefamily and (3) defaults
229 - this is required on very old bootcd
230
231 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
232 - Use modprobe module to write out /etc/modprobe.conf.
233
234 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
235 - minor updates - using the new modprobe module *not* in this tag
236
237 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
238 - load device mapper if needed, for centos5-based bootcd variant
239
240 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
241 - renumbered 4.3
242 - New step StartRunLevelAgent
243 - various other tweaks
244
245 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-2
246 - most of the actual network config job moved to (py)plnet
247 - support for RAWDISK
248 - network interfaces deterministically sorted
249 - does not use nodegroups anymore for getting node arch and other extensions
250 - drop yum-based extensions
251 - debug sshd started as early as possible
252 - timestamped and uploadable logs (requires upload-bmlog.php from nodeconfig/)
253 - cleaned up (drop support for bootcdv2)
254 - still needs testing
255
256 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-1
257 - reflects new names from the data model
258
259 * Sat May 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-7
260 - dont unload cpqphp
261
262 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-6
263 - changes in the state automaton logic 
264 - root+swap = 7G
265 - usb-key threshhold increased to 17 G
266 - bootstrafs selection logic altered - uses /etc/planetlab/nodefamily instead of GetPlcRelease
267
268 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-3.2-4 BootManager-3.2-5
269 - renamed step InstallBootstrapRPM into InstallBootstrapFS
270 - reviewed selection of bootstrapfs, based on nodegroups, for multi-arch deployment
271 - import pypcimap rather than pypciscan
272 - initial downlaoding of plc_config made more robust
273 - root and /vservers file systems mounted ext3
274 - calls to BootGetNodeDetails replaced with GetNodes/GetNodeNetworks
275 - also seems to be using session-based authentication rather than former hmac-based one
276
277 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-3 bootmanager-3.2-4
278 - usage of wireless attributes fixed and tested
279 - breakpoints cleaned up (no change for production)
280 - less alarming message when floppy does not get unloaded
281
282 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-3.2-2 bootmanager-3.2-3
283 - network config : support the full set of settings from ifup-wireless - see also http://svn.planet-lab.org/svn/MyPLC/tags/myplc-4.2-1/db-config
284 - removes legacy calls to PlanetLabConf.py 
285 - refrains from unloading floppy 
286 - first draft of the dual-method for implementing extensions (bootstrapfs-like images or yum install)
287
288 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
289 - Initial build.
290
291 %define module_current_branch 4.3